Jump to content
funtoo forums
  • 0
tuxman

update problem

Question

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

media-libs/libass:0

  (media-libs/libass-0.13.0:0/5::gentoo, ebuild scheduled for merge) conflicts with
    >=media-libs/libass-0.12.1:=[enca(-),fontconfig] required by (media-video/mpv-0.11.0:0/0::gentoo, installed)
                                                    
    >=media-libs/libass-0.12.1:0/5=[enca(-),fontconfig] required by (media-video/mpv-0.11.0:0/0::gentoo, installed)
                                                       


Nothing to merge; quitting.

I tried uninstall libass then do emerge -auDN @world. It will go through but if I run another emerge -auDN @world I get the exact same message. It seems ike version 13 of libass is not being installed. Help.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
# eix media-libs/libass
[U] media-libs/libass
     Available versions:  0.11.2(0/5) 0.12.3(0/5) (~)0.13.0(0/5) {+enca +fontconfig +harfbuzz static-libs ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  0.12.3(05:00:41 PM 12/02/2015)(enca fontconfig harfbuzz -static-libs ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32")
     Homepage:            https://github.com/libass/libass
     Description:         Library for SSA/ASS subtitles rendering

and

# emerge -DNupv world --with-bdeps=y

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-util/re2c-0.15.2::gentoo [0.14.3::gentoo] 3,979 KiB
[ebuild  N     ] www-client/w3m-0.5.3-r5::gentoo  USE="X gpm nls ssl unicode -fbcon -gtk -imlib -lynxkeymap (-migemo) -nntp -vanilla -xface" LINGUAS="-ja" 2,151 KiB
[ebuild  N     ] virtual/w3m-0::gentoo  0 KiB
[ebuild     U  ] sys-apps/help2man-1.47.3::gentoo [1.47.2::gentoo] USE="nls" 181 KiB
[ebuild     U  ] app-text/asciidoc-8.6.9-r2::gentoo [8.6.9-r1::gentoo] USE="-examples -graphviz -highlight {-test} (-vim-syntax%)" PYTHON_SINGLE_TARGET="python2_7 -pypy" PYTHON_TARGETS="python2_7 -pypy" 0 KiB
[ebuild     U  ] app-text/xmlto-0.0.28-r1::gentoo [0.0.26::gentoo] USE="-latex" 125 KiB
[ebuild     U  ] media-gfx/fontforge-20150824::gentoo [20150612-r1::gentoo] USE="X gif jpeg png python readline svg tiff unicode -cairo -gtk -truetype-debugger" PYTHON_SINGLE_TARGET="python3_3 -python2_7 -python3_4" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 20,310 KiB

Total: 7 packages (5 upgrades, 2 new), Size of downloads: 26,745 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

media-libs/libass:0

  (media-libs/libass-0.13.0:0/5::gentoo, ebuild scheduled for merge) conflicts with
    >=media-libs/libass-0.12.1:0/5=[enca(-),fontconfig] required by (media-video/mpv-0.11.0:0/0::gentoo, installed)
                                                       
    >=media-libs/libass-0.12.1:=[enca(-),fontconfig] required by (media-video/mpv-0.11.0:0/0::gentoo, instal

Thank you too!

Share this post


Link to post
Share on other sites
  • 0

I run into same issue on updated current system if I install mpv.
Portage wants to downgrade libass-0.13.0 to libass-0.12.3

funtoo rj # sudo emerge -av mpv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/libmowgli-1.0.0::gentoo  0 KiB
[ebuild  N     ] app-i18n/libguess-1.2::gentoo  USE="-examples" 0 KiB
[ebuild  N     ] dev-python/pygments-2.0.2-r1::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_3 -pypy -pypy3 -python3_4 -python3_5" 0 KiB
[ebuild  N     ] dev-python/docutils-0.12::gentoo  PYTHON_TARGETS="python2_7 python3_3 -pypy -pypy3 -python3_4 -python3_5" 0 KiB
[ebuild     UD ] media-libs/libass-0.12.3:0/5::gentoo [0.13.0:0/5::gentoo] USE="enca%* fontconfig harfbuzz -static-libs" 0 KiB
[ebuild  N     ] media-video/mpv-0.11.0::gentoo  USE="X alsa bluray cdio cli dvd enca encode iconv jpeg libass libguess opengl v4l vaapi vdpau xscreensaver -doc-pdf -drm -dvb -egl -jack -lcms (-libav) -libcaca -libmpv -lua -luajit -openal -oss -pulseaudio -pvr -raspberry-pi -rubberband -samba -sdl (-selinux) -vf-dlopen -wayland -xinerama -xv" 0 KiB

Total: 6 packages (1 downgrade, 5 new), Size of downloads: 0 KiB


Next "emerge -avuDN world" after install of mpv  portage wants to upgrade to libass-0.13.0 which causes mpv  conflict error.
If package.mask versions of libass greater than 0.12.3, then portage has no higher version of libass to upgrade to.

funtoo rj # mkdir /etc/portage/package.mask/media-libs
funtoo rj # echo ">media-libs/libass-0.12.3" > /etc/portage/package.mask/media-libs/libass

Reference:
Gentoo's Bugzilla ? Bug 562394 - =media-libs/libass-0.13.0: update blockers as enca USE was dropped
 

Share this post


Link to post
Share on other sites
  • 0

[ot]

Cardinal is a real great Master of Funtoo :)

[/ot]

 

But ... Cardinal, i see thath you use the "new tecnique" used by Gentoo about te /etc/portage/package.*/package_name

 

Do You think is a better solution than to have only one file for /etc/portage/package.* ?

 

Thank You :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...