Jump to content
Our Second Funtoo Newsletter! ×

openRC issues, warning.


Recommended Posts

The latest version of openrc (ver-0.12.4-r4) for some reason, dumps librc.so.1, libeinfo.so.1, and their links into /. I found out the error of this when this system decided not to boot. I got things to boot with a sysrescuecd, and manually copied the files into /usr/lib (tried /usr first, no go). I don't think it's a peculiarity with this system.

That brings me to a second question. Is there a bugzilla here, or would I need to report this issue to gentoo's bugzilla? Just curious, because it's rather disconcerting when your computer won't boot after you get home from being out and about on a gorgeous day. It has a way of messing with serenity.


Link to comment
Share on other sites

I have emerged openrc-0.12.4-r4 4 times since installing funtoo on 05.28.2015 with no problems.
>>> Completed installing openrc-0.12.4-r4 into /var/tmp/portage/sys-apps/openrc-0.12.4-r4/image/

strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment -R .GCC.command.line -R .note.gnu.gold-version
ecompressdir: bzip2 -9 /usr/share/doc
ecompressdir: bzip2 -9 /usr/share/man
making executable: lib64/libeinfo.so.1
making executable: lib64/librc.so.1

Pure64 arch installs libs to /lib64


bugs.funtoo.org Log in with the same username and password as the forum.

Link to comment
Share on other sites

It appears this is not an openrc issue. Because of corruption, it seems the file that tells ./config where the preferred library path is, in my case, /usr/lib is not passing that information at configuration time. This is definitely the case, as I just installed kmod, and it dropped files destined for /usr/lib into /usr. Closer than openrc, to be sure, but still not right.


So the question becomes where is that information stored in Funtoo?


As precise as Funtoo is about what goes where path-wise, I'm sure there's a file with some jibberish that can't be parsed properly, and that causes files to be put where they don't belong. That is my current hypothesis on the matter, anyway.

So, where would I look? I'm pretty sure once I found the file in question, I'd be able to make it snap back to proper operation.


Thanks in advance.


Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

From what I'm seeing, pkgconfig is where the data is held.

It doesn't much matter at this point. I've salvaged the data from the hard drive, save some firefox cache files. I downloaded a new tar ball, and have expanded it into a directory on my 64 bit main machine. I'm going to do a chroot setup, like I did when I first put funtoo on the machine in question. Once done, I'll update that machine with binary packages I compile elsewhere. That should save a bit of wear and tear on the machine and its rather old and tired hard drives.

I didn't choose the geek life. It chose me!


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...