Jump to content
Read the Funtoo Newsletter: Summer 2023 ×
  • 0

gcc-config: error: could not run/locate 'i686-pc-linux-gnu-gcc'



I'm trying to update dev-libs/nss so I can update firefox, however it fails with a message saying that it cannot find "i686-pc-linux-gnu-gcc". I do not in fact have such a file on my system, except for /usr/bin/usr/bin/i686-pc-linux-gnu-gcc which is the gcc-config wrapper. Attempting to run that produces the final line of the log. I am particularly confused by the "broken config file" error, as I haven't touched that file to my knowledge. I would guess that I messed up something during the transition to ARCH_X86? Any help would be very much appreciated.


Partial log:

>>> Compiling source in /var/tmp/portage/dev-libs/nss-3.20/work/nss-3.20/nss ...
 * abi_x86_32.x86: running multilib-minimal_abi_src_compile
make -j5 -j1 -C coreconf CC=i686-pc-linux-gnu-gcc 
make: Entering directory '/var/tmp/portage/dev-libs/nss-3.20/work/nss-3.20/nss-abi_x86_32.x86/coreconf'
cd nsinstall; make export
make[1]: Entering directory '/var/tmp/portage/dev-libs/nss-3.20/work/nss-3.20/nss-abi_x86_32.x86/coreconf/nsinstall'
make[1]: Nothing to be done for 'export'.
make[1]: Leaving directory '/var/tmp/portage/dev-libs/nss-3.20/work/nss-3.20/nss-abi_x86_32.x86/coreconf/nsinstall'
cd nsinstall; make libs
make[1]: Entering directory '/var/tmp/portage/dev-libs/nss-3.20/work/nss-3.20/nss-abi_x86_32.x86/coreconf/nsinstall'
i686-pc-linux-gnu-gcc -o Linux3.19_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/nsinstall.o -c -O2 -fno-strict-aliasing -fPIC -Di386 -DLINUX2_1 -m32 -Wall -Werror-implicit-function-declaration -Wno-switch -pipe -ffunction-sections -fdata-sections -DLINUX -Dlinux -DHAVE_STRERROR -DXP_UNIX -UDEBUG -DNDEBUG -D_REENTRANT -DUSE_UTIL_DIRECTLY -DNO_NSPR_10_SUPPORT -DSSL_DISABLE_DEPRECATED_CIPHER_SUITE_NAMES -I../../dist/Linux3.19_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/include -I../../dist/public/coreconf -I../../dist/private/coreconf -I../../dist/Linux3.19_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/include/dbm  nsinstall.c
 * gcc-config: Active gcc profile is invalid!
 * broken config file: /etc/env.d/gcc/x86_64-pc-linux-gnu-4.9.3
gcc-config: error: could not run/locate 'i686-pc-linux-gnu-gcc'

My gcc-config listing:

 [1] x86_64-pc-linux-gnu-4.9.3 *

emerge --info:

Portage 2.3.6-r9 (funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.9.3, glibc-2.20-r2, 3.19.1-gentoo x86_64)
System uname: Linux-3.19.1-gentoo-x86_64-Intel-R-_Core-TM-_i5-3570_CPU_@_3.40GHz-with-gentoo-2.2.0
KiB Mem:    16453496 total,   8403420 free
KiB Swap:   16777212 total,  16503488 free
Timestamp of tree: Unknown
ld GNU ld (Gentoo 2.23.2 p1.0) 2.23.2
app-shells/bash:          4.3_p39-r1
dev-java/java-config:     2.2.0-r1000
dev-lang/perl:            5.22.0
dev-lang/python:          2.7.10-r1000, 3.3.6-r1000, 3.4.1-r1000
dev-util/cmake:           3.1.0
sys-apps/baselayout:      2.2.0-r6
sys-apps/openrc:          0.12.3-r6
sys-apps/sandbox:         2.6-r2
sys-devel/autoconf:       2.13, 2.69-r1
sys-devel/automake:       1.11.6-r1, 1.12.6, 1.13.4, 1.14.1, 1.15
sys-devel/binutils:       2.23.2, 2.24-r3, 2.25-r2
sys-devel/gcc:            4.9.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.3-r2
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 4.0 (virtual/os-headers)
sys-libs/glibc:           2.20-r2
Repositories: gentoo gamerlay sage-on-gentoo haskell science x11 anders-larsson steam-overlay jorgicio java luman hasufell media-overlay local
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -O2 -ggdb -pipe"
CONFIG_PROTECT="${CONFIG_PROTECT} /etc /etc/idea/conf /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -ggdb -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
GENTOO_MIRRORS="rsync://gentoo.mirrors.tds.net/gentoo http://gentoo.mirrors.tds.net/gentoo ftp://gentoo.mirrors.pair.com/"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
LINGUAS="en_AU en_GB en"
PORTDIR_OVERLAY="/var/lib/layman/gamerlay /var/lib/layman/sage-on-gentoo /var/lib/layman/haskell /var/lib/layman/science /var/lib/layman/x11 /var/lib/layman/anders-larsson /var/lib/layman/steam-overlay /var/lib/layman/jorgicio /var/lib/layman/java /var/lib/layman/luman /var/lib/layman/hasufell /var/lib/layman/media-overlay /usr/local/portage"
USE="X a52 aac acl alsa amd64 apng avx berkdb bluray bzip2 caps cdda cddb cdio cdr cracklib crypt cups cxx dbus dri dts dvd dvdr dvdread encode exif faac faad ffmpeg flac gdbm gif gpm hoogle ico iconv icu ieee1394 ios ipod ipv6 jack jpeg jpeg2k lame libass libguess libmpeg2 libnotify mad matroska mjpeg mmx modules mp3 mpeg mtp mudflap multilib ncurses nls nptl nsplugin ogg opengl openmp pam pcre pdf png postproc pppd python quicktime readline resolvconf sndfile sse sse2 ssl ssse3 svg taglib tcpd theora tiff truetype twolame udev unicode v4l vim-syntax vorbis vpx wav wavpack webp win32codecs wmf x264 x265 xattr xml xvid zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel ice1724 intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_AU en_GB en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_ABIS="2.7 3.3 3.4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3 python3_4" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19 ruby20 ruby21 ruby22" STEAMGAMES="dwarfs" USERLAND="GNU" VIDEO_CARDS="radeon radeonsi" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

I don't know what You wanna make....


But: is correct "i686-pc-linux-gnu-gcc" ?

May be corect "i686-pc-linux-gnu" ?


Since You are on a 64 bit system, is not necessary to make:


# linux32 


before the compilation for 32 bits software then change the "CHOST=" ? but to change chost may be dangerous.....


(and excuse my ignorance ..... 

Link to comment
Share on other sites

  • 0

I think the "-gcc" part is correct. If I understand what is going on correctly, their should be a directory of files called i686-pc-linux-gnu-{gcc,gas,ar,ld,etc} created by a multilib install of gcc, and it is complaining that it cannot find the gcc one. linux32 and CHOST changes should not be necessary; the multilib infrastructure should be responsible for doing that stuff as necessary, and I can confirm that at the point where gcc is being invoked CHOST=i686-pc-linux-gnu.

Link to comment
Share on other sites

  • 0

Problem solved!

qfile -o /usr/bin/i686-pc-linux-gnu-*

reported that several gcc-related files there were orphaned. I deleted them, and everything Just Worked. I *think* this is because I had the new toolchain unmasked when people where doing the experimental multilib wrappers or something.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...