Jump to content
funtoo forums
  • 0
Otakku

net-libs/glib-networking Conflict with almost all

Question

Hi everybody, sorry for ask something like that, but I tried everthing that I know about. 

 

so, I'm using  the current version with XFCE and flavor CORE, so when I go install the networkmanager the dependence : net-libs/glib-networking  crash my system I can't open the browsers, file-manager,WMs, nothing with GUI

 

 

I tried compile with other flags or nothing flags but the issue remain, if someone looked that or know how to solve I'll appreciate so much 

 

 

sorry my english I'm brazilian and here we only speak Portuguese. 

 

Thanks

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I think you must select "desktop" since You use a DE (xfce4 in your case).

 

Do You want to try to change the profile to "Desktop" ? (this enable some use flags that may be necessary for using a Desktop environment).

 

I use xfce4 and kde.

 

It is possible to use also the "old" method:

# eselect profile list

__________________

 

For only an example, I post my profiles; I whish may be for You an aid :)

sandro@ci74771ht ~ $ eselect profile list
Currently available arch profiles:
  [1]   funtoo/1.0/linux-gnu/arch/x86-64bit * 
  [2]   funtoo/1.0/linux-gnu/arch/pure64
Currently available subarch profiles:
  [3]   funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/amd64-bulldozer
  [4]   funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/amd64-jaguar
  [5]   funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/amd64-k10
  [6]   funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/amd64-k8
  [7]   funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/amd64-k8+sse3
  [8]   funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/amd64-piledriver
  [9]   funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/amd64-steamroller
  [10]  funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/atom_64
  [11]  funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/btver1_64
  [12]  funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/core2_64
  [13]  funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/core-avx-i
  [14]  funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/corei7
  [15]  funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/generic_64
  [16]  funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/intel64-broadwell
  [17]  funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/intel64-haswell
  [18]  funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/intel64-ivybridge
  [19]  funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/intel64-sandybridge
  [20]  funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/intel64-silvermont
  [21]  funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/native_64 * 
  [22]  funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/nocona
  [23]  funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/opteron_64
  [24]  funtoo/1.0/linux-gnu/arch/x86-64bit/subarch/xen-pentium4+sse3_64
Currently available build profiles:
  [25]  funtoo/1.0/linux-gnu/build/stable * 
  [26]  funtoo/1.0/linux-gnu/build/current
  [27]  funtoo/1.0/linux-gnu/build/experimental
Currently available flavor profiles:
  [28]  funtoo/1.0/linux-gnu/flavor/minimal
  [29]  funtoo/1.0/linux-gnu/flavor/core
  [30]  funtoo/1.0/linux-gnu/flavor/desktop * 
  [31]  funtoo/1.0/linux-gnu/flavor/workstation
  [32]  funtoo/1.0/linux-gnu/flavor/hardened
Currently available mix-ins profiles:
  [33]  funtoo/1.0/linux-gnu/mix-ins/audio * 
  [34]  funtoo/1.0/linux-gnu/mix-ins/cinnamon
  [35]  funtoo/1.0/linux-gnu/mix-ins/console-extras
  [36]  funtoo/1.0/linux-gnu/mix-ins/dvd * 
  [37]  funtoo/1.0/linux-gnu/mix-ins/gnome
  [38]  funtoo/1.0/linux-gnu/mix-ins/kde * 
  [39]  funtoo/1.0/linux-gnu/mix-ins/mate
  [40]  funtoo/1.0/linux-gnu/mix-ins/media (auto) 
  [41]  funtoo/1.0/linux-gnu/mix-ins/media-pro * 
  [42]  funtoo/1.0/linux-gnu/mix-ins/mediadevice-audio-consumer (auto) 
  [43]  funtoo/1.0/linux-gnu/mix-ins/mediadevice-audio-pro (auto) 
  [44]  funtoo/1.0/linux-gnu/mix-ins/mediadevice-base (auto) 
  [45]  funtoo/1.0/linux-gnu/mix-ins/mediadevice-video-consumer (auto) 
  [46]  funtoo/1.0/linux-gnu/mix-ins/mediadevice-video-pro (auto) 
  [47]  funtoo/1.0/linux-gnu/mix-ins/mediaformat-audio-common (auto) 
  [48]  funtoo/1.0/linux-gnu/mix-ins/mediaformat-audio-extra * 
  [49]  funtoo/1.0/linux-gnu/mix-ins/mediaformat-gfx-common (auto) 
  [50]  funtoo/1.0/linux-gnu/mix-ins/mediaformat-gfx-extra * 
  [51]  funtoo/1.0/linux-gnu/mix-ins/mediaformat-video-common (auto) 
  [52]  funtoo/1.0/linux-gnu/mix-ins/mediaformat-video-extra * 
  [53]  funtoo/1.0/linux-gnu/mix-ins/lxde
  [54]  funtoo/1.0/linux-gnu/mix-ins/lxqt
  [55]  funtoo/1.0/linux-gnu/mix-ins/no-emul-linux-x86 * 
  [56]  funtoo/1.0/linux-gnu/mix-ins/no-systemd * 
  [57]  funtoo/1.0/linux-gnu/mix-ins/print (auto) 
  [58]  funtoo/1.0/linux-gnu/mix-ins/python3-only
  [59]  funtoo/1.0/linux-gnu/mix-ins/X * 
  [60]  funtoo/1.0/linux-gnu/mix-ins/xfce * 
  [61]  funtoo/1.0/linux-gnu/mix-ins/vmware-guest
  [62]  funtoo/1.0/linux-gnu/mix-ins/hardened

If You want You can also use the chat Freenode #funtoo :)

 

Or if you want you can contact me in Private Messages :)

 

Best Regards

 

Sandro.

 

 

PS: could you describe Your hardware ? (thanks) :)

 

PS2: but may be that you've "circular dependencies" ?

 

Ciao :)

Share this post


Link to post
Share on other sites
  • 0

I won't use the flavor Desktop, I want add the flags, manually, but anyway I'll try enabel the abi_x86_32 in make.conf 

 

maybe has a issue because not all package support 32 are enabled, if don't work I'll enable the flavor Desktop and re-emerge the system 

 

 

I use a HP-probook 4530s > 8GB ram ddr3 > SSD Kingston v300 240GB.

 

I used Funtoo in begin of year and the networking manager worked normal and all dependences, I believe that is some mistake mine.

 

Thank you.

Share this post


Link to post
Share on other sites
  • 0

What stage you've used ? if you have used "pure64" there will be a problem.

If You've used the "normal" (multilib) stage 3 , so no problem ......

 

I post to you my make.conf (consider it as en example, cause the flexibility of Funtoo can make you able to  configure your computer as you want).

 

What cpu have you ?

cat /proc/cpuinfo

____________________________________________

 

This is my make.conf : 

sandro@ci74771ht ~ $ cat /etc/make.conf 
CFLAGS="-march=native -Ofast -ftree-vectorize -pipe"
CXXFLAGS="${CFLAGS}"
FFLAGS="${CFLAGS}"
FCFLAGS="${CFLAGS}"
LDFLAGS="${LDFLAGS} -Wl,--hash-style=gnu"
ABI_X86="64 32"
CHOST="x86_64-pc-linux-gnu"
 
CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"
 
USE="icu jit gtk3 sdl X Xaw3d a52 aac aalib acl adns afs aim ao apm atm \
     audiofile bash-completion bcmath bidi opencl blas bluetooth nvidia \
     bzip2 cairo calendar caps cdb cdda cddb xvmc cdparanoia cdr cgi \
     clamav cracklib crypt css ctype cups vdpau curlwrappers \
     custom-cflags cvs cxx dbi dbm dbus dga djvu dri dts dv dvb dvdr \
     encode exif fam fastcgi ffmpeg fftw filecaps flac flatfile \
     fontconfig foomaticdb fortran ftp gcj gd gdbm geoip gif gimp git \
     glut gmp gnuplot gnutls gphoto2 gpm gps graphviz gsl gsm \
     gstreamer guile gzip hddtemp iconv icq idn ieee1394 imagemagick \
     imap imlib inifile inotify introspection iodbc ios ipod jack \
     java javascript jbig jabber jingle jpeg jpeg2k kde kontact \
     ladspa lame lapack lash ldap libass libav libcaca libedit \
     libffi libnotify libsamplerate libwww lirc lm_sensors lua lzma lzo \
     mad maildir matroska mbox mikmod milter mime mmap mms mng \
     modplug motif mozilla mp3 mp4 mpeg mpi mplayer msn mtp musepack \
     musicbrainz netcdf pcre pda pdf perl php pie plasma \
     plotutils policykit portaudio posix postscript ppds python qdbm \
     qmail-spp quicktime raw readline recode rss sasl scanner cdpau \
     semantic-desktop sharedmem shorten simplexml sip smartcard smp \
     sndfile soap speex spell ssl subversion svg syslog szip tcpd \
     theora threads tidy tiff timidity tk tcl truetype udev udisks \
     unicode upower usb v4l vala vcd vnc vorbis wavpack wddx wifi \
     wxwidgets x264 xattr xcb xcomposite xface xft xine xinerama \
     xinetd xmlrpc xmp xmpp xscreensaver xv xvid zlib \
     networkmanager qt3support qt5 qt4 video opengl ogg tools acpi libcanberra \
     -systemd gtk gtk2 gnome webkit -gnome-keyring alsa pulseaudio \
     pic"
MAKEOPTS="-j9"
LINGUAS="it"
INPUT_DEVICES="keyboard mouse evdev"
VIDEO_CARDS="nvidia"
ACCEPT_LICENSE="*"
#PORTAGE_TMPDIR="/dev/shm"
 
#source /var/lib/layman/make.conf

Pay attention: I've used in *FLAGS "-Ofast that is equal to (-O3 -ffast-math) and -ftree-vectorize, but some ebuilds doesn't compile with these use then I think to use "-march=native -O2 -pipe" (-O3 works fine if your cpu has a lot of L2 cache, otherwise use "-O2").

 

About "Global USE Flags, you can see https://www.gentoo.org/support/use-flags/

 

 

 

However you can use eselect or ego & epro .... it depend of your preference :)

 

I hope that my suggestions are of Your interesting to compile Your magic new Funtoo :P :) :) :)

 

There is possible that you encounter some trouble but .... no problem; at the end you'll have a brilliant and fascinous serious & performant system (with optimization not all software try benefit, but in same case you must have 3x or 4x faster than a precompiled distro :P.... i tell this words cause i've made various benchmarks :)

 

Ask for any trouble .....

Good Work Dear friend :)

 

PS: Looking that i've commented the PORTAGE_TMPDIR; i've 16 GiB of ram then I can compile also libreoffice using /dev/shm. 8GiB are Good for 99% of the software; but by default not for libreoffice or chromium....... in this case you must specify the size of /dev/shm in /etc/fstab to 6GB. But it is not for now important....... if You want to use /dev/shm to compile in ram, tell me; otherwise, don't declare PORTAGE_TMPDIR (by default will be /var/tmp/.

 

I hope not to have create confusion :|

 

Good Work :)

Share this post


Link to post
Share on other sites
  • 0

I made few tests here and the librarie : libgiognutls.so cause the conflict if I don't delete a lot of packages show : segmentation fault

 

I install the the glib-networking, and delete that lib on : /usr/lib64/gio/modules/

 

 

someone knows something about that ?

Share this post


Link to post
Share on other sites
  • 0

I've either Funtoo-stable (that is my primary OS), W10 (for the family) and Gentoo (cause i like also it).

I use the same make.conf for funtoo and Gentoo; the differences are in "local USE <=> /etc/portage/package.use" and in package.accept_keywords, but it is not your case since you use the "current version" (you must have the package.accept_keywords file empty).

 

If You want I can try to create a connection using sshd for example, to see the status of your system and to search the method to "tune" your system.

 

However, if you dislike this idea, then in your successive post give to us the output ..... so to "see" if someone can tell to you the solution.

 

With estimate

 

Sandro.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...