Jump to content
funtoo forums
  • 0
m31271n

An issue about set @kernel described in official wiki page "Funtoo Linux Download/Install"

Question

A few days ago, I reinstalled my funtoo box.

 

I followed this page http://www.funtoo.org/Funtoo_Linux_Installation#Configuring_and_installing_the_Linux_kernel to configure a set kernel:

 

    1. mkdir /etc/portage/sets

    2. echo sys-kernel/debian-sources > /etc/portage/sets/kernel

    3. echo "sys-kernel/debian-sources binary" >> /etc/portage/package.use

    4. emerge -1 @kernel

 

I am sure about 2 things:

 

    1. nothing is in /usr/lib/portage/world_sets

    2. sys-kernel/debian-sources is not in /usr/lib/portage/world

 

Now , the question is coming - When I emerge --depclean, portage will clean my kernel.

>>> Calculating removal order...

>>> These are the packages that would be unmerged:

sys-kernel/debian-sources
  selected: 3.14.15
 protected: none
   omitted: none

sys-kernel/genkernel
  selected: 3.4.40.7-r6
 protected: none
   omitted: none

sys-fs/cryptsetup
  selected: 1.6.6
 protected: none
   omitted: none

sys-fs/mdadm
  selected: 3.3.2
 protected: none
   omitted: none

All selected packages: sys-kernel/genkernel-3.4.40.7-r6 sys-kernel/debian-sources-3.14.15 sys-fs/cryptsetup-1.6.6 sys-fs/mdadm-3.3.2

I don't know why Portage didn't work as I know.

 

Can you guys give a tip ?

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

`emerge -1` (-1 = --oneshot) will not add the package to the world file.  You need to remove the --oneshot option for any package to be added to the world file when manually installing a package.

 

--oneshot SHOULD be used when manually reinstalling @system files, that way they are not added to the @world set as well as belonging to the @system set.

 

One can manually add a previously installed package to the world set by using the --noreplace flag, ie `emerge --noreplace =debian-sources-3.14.37`.

Share this post


Link to post
Share on other sites
  • 0

`emerge -1` (-1 = --oneshot) will not add the package to the world file.  You need to remove the --oneshot option for any package to be added to the world file when manually installing a package.

 

--oneshot SHOULD be used when manually reinstalling @system files, that way they are not added to the @world set as well as belonging to the @system set.

 

One can manually add a previously installed package to the world set by using the --noreplace flag, ie `emerge --noreplace =debian-sources-3.14.37`.

I created a user-defined set call "kernel" which contains "sys-kernel/debian-sources"

 

In this way, I can seperate sys-kernel/debian-sources from other packages in world file.

When I use "emerge -auDN @world", I can not have to update @kernel.

 

That is what I want to do.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...