Jump to content
  • 0
kxmx

emerge -auND @world unsatisfied requirements

Question

Hello, im pretty new here and my second installation of funtoo give me this output if im trying run emerge -auND @world

These are the packages that would be merged, in order:
Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=app-misc/tracker-1" has unmet requirements.
- app-misc/tracker-1.2.3::gentoo USE="exif ffmpeg flac gif gstreamer gtk iso jpeg miner-fs mp3 nautilus tiff vorbis xml -cue (-eds) -firefox-bookmarks -gsf -iptc -networkmanager -pdf -playlist -rss -test -thunderbird -upnp-av -upower -xmp -xps"

  The following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( gstreamer ffmpeg )

  The above constraints are a subset of the following complete expression:
    at-most-one-of ( gstreamer ffmpeg ) cue? ( gstreamer ) upnp-av? ( gstreamer ) !miner-fs? ( !cue !exif !flac !gif !gsf !iptc !iso !jpeg !mp3 !pdf !playlist !tiff !vorbis !xml !xmp !xps )

(dependency required by "gnome-base/gnome-extra-apps-3.14.1-r1[tracker]" [installed])
(dependency required by "gnome-base/gnome-3.14.1[extras]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

I really dont know where start, what I can do. Thanks for help

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

You have two options. 

 

  1. You edit the make.conf in /etc/portage with USE="gstreamer" and/or USE="ffmpeg".
  2. You edit the package.use in /etc/portage with app-misc/tracker gstreamter and/or app-misc/tracker ffmpeg.

What  <The above constraints are a subset of the following complete expression:> means is that

 

 cue? ( gstreamer ) if you have cue use flag, you need gstreamer use flag.

Share this post


Link to post
Share on other sites
  • 0

[ot]

Excuse me aryvandaar, i hope not du distrb you.

I read sometimes http://www.gentoo.org/dyn/use-index.xml

 

Then for You may be a good idea ta add ffmpeg in "Global use flags" and the others in "local Use Flags" ?

 

Also gstreamer is a Global Use; in my make.conf there are both enabled globally. And my system is coerent.

[/ot]

 

Excuse me for this off topic ...... Thanks for any answwer :)

 

However, I use the "euse command". in this case should be

 

 

# euse -E ffmpeg

 

. Ciao an excuse me for the disturb :|

Share this post


Link to post
Share on other sites
  • 0

app-misc/tracker-1.2.3::gentoo USE="exif ffmpeg flac gif gstreamer........

 

 

at-most-one-of ( gstreamer ffmpeg )

 

 

and so as you can see either gstreamer or ffmpeg stays, 1 or the other.....

 

to disable gstreamer:

echo "app-misc/tracker -gstreamer" >> /etc/portage/package.use

 

to disable ffmpeg:

echo "app-misc/tracker -ffmpeg" >> /etc/portage/package.use

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...