Jump to content
funtoo forums
  • 0
sitquietly

No route to local network on new install

Question

I've installed Funtoo Current core-i7 hardened onto an empty partition alongside my existing Funtoo system, and followed the usual easy steps http://www.funtoo.org/Funtoo_Linux_Networking for setting up a static interface on eth0, but there is no route to the local network.

 

Everything boots ok.

eth0 is UP with correct address and mask.

resolv.conf looks good

/etc/conf.d/netif.eth0 is the same as on my old (functioning) install

 

BUT I can't ping other machines on my local network.  netstat -r hangs for a long time and then does not show any entry for the local network.  i.e. the line

192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0

is missing [EDIT: if I wait long enough that line is printed]

 

BTW, the interface comes up functioning if I use dhcp instead of the static addressing (on this network dhcp is reserved for guests and assigns addresses that lack certain priviledges).

 

I don't understand how the system (using the Funtoo networking scripts) can fail to create an entry in the routing table for the eth0 interface. 

 

Anyone have an idea what could be wrong?  I've already come to the end of my knowledge and don't know how to proceed on this networking problem.  I've even tried to copy my old /etc directory onto the new system for testing, editing the fstab of course.  The new install still fails to bring up a functioning network (using same kernel config, same configuration files in /etc, same hardware).

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

what does ip route say?

 

this is a working example of a wifi connection produced by networkmanager

mkultra@spaceball-1 / $ ip route
default via 192.168.1.1 dev wlan0  proto static  metric 1024 
127.0.0.0/8 dev lo  scope host 
192.168.1.0/24 dev wlan0  proto kernel  scope link  src 192.168.1.88 
mkultra@spaceball-1 / $ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.1.1     0.0.0.0         UG    1024   0        0 wlan0
loopback        0.0.0.0         255.0.0.0       U     0      0        0 lo
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0
 

Share this post


Link to post
Share on other sites
  • 0

 

what does ip route say?

 

 

ip route actually says what we would expect for the interface:

default via 192.168.1.254 dev eth0
127.0.0.0/8 dev lo  scope host
192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.1

and netstat -r reports (after hanging for about a minute)

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
default         192.168.1.254   0.0.0.0         UG        0 0          0 eth0
loopback        0.0.0.0         255.0.0.0       U         0 0          0 lo
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0

These look ok.  But I can't connect to or ping the other computers on the 192.168.1.0/255 network.  Can't get out to the internet of course.  This seems very weird to me...

 

The eth0 interface is UP.  The routing table is correct (but netstat hangs for a long time).  The dns info is correctly in /etc/resolv.conf.  And the network is not accessible:

 

 

# ping 192.168.1.2 # my file server
PING 192.168.1.2 (192.168.1.2) 56(84) bytes of data.
From 192.168.1.1: icmp_seq=1 Destination Host Unreachable
From 192.168.1.1: icmp_seq=2 Destination Host Unreachable
From 192.168.1.1: icmp_seq=3 Destination Host Unreachable

Share this post


Link to post
Share on other sites
  • 0

this sounds more reasonable to me...  i doubt your gateways ip is 254 i bet 254 is probably what your computers static address is supposed to be.....

default via 192.168.1.1 dev eth0
127.0.0.0/8 dev lo  scope host
192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.254

Share this post


Link to post
Share on other sites
  • 0

 

this sounds more reasonable to me...  i doubt your gateways ip is 254 i bet 254 is probably what your computers static address is supposed to be.....

default via 192.168.1.1 dev eth0
127.0.0.0/8 dev lo  scope host
192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.254

 

Here's the addressing for my existing Funtoo installation (I'm accessing this forum using these settings)

 

__> ip route
default via 192.168.1.254 dev eth0
127.0.0.0/8 dev lo  scope host
192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.1

So you see 192.168.1.254 is the address of my router, and 192.168.1.1 is the address of my workstation. So it still seems that my new installation is correctly setup and should be working.  But isn't working. :blink:

Share this post


Link to post
Share on other sites
  • 0
192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.1
should not the source be the broadcast address?

 

Maybe post your /etc/conf.d/netif.eth0 file?

 

 

Here is the netif.eth0 config file I've been using on my previous install (which is ok) and my new install (which does not work):

template="interface"
ipaddr="192.168.1.1/24"
gateway="192.168.1.254"
nameservers="8.8.8.8 208.67.222.222"
domain="launchmodem.com"

Has it been wrong all along??

 

Share this post


Link to post
Share on other sites
  • 0

looks fine, are you able to ping gateway?

 

No. :(

 

ping always complains of "No route to host"

 

I even checked the Funtoo script /etc/init.d/netif.tmpl for changes but it is identical between the functioning and non-functioning installations.  I haven't found any real difference between the good and bad systems, except that the bad system is a new install from a new stage3.  I'm afraid of finding that I've done something really stupid (it would not be the first time), but I'm not seeing it.

Share this post


Link to post
Share on other sites
  • 0

This is going to be really silly suggestion...

But have you...?

 

 

Now I'm laughing...  That was a silly question. :D

 

But the answer is probably just as silly.  I just haven't discovered my own silliness yet.  Thank you for all of your inputs, it has been a really useful sanity check.  I may just start over in a few days with a fresh stage3 and a fresh mind.  [i've done a half dozen Funtoo installs in the past year and it has always proven to be a dead-simple and foolproof process with current or stable, hardened or not, pure64 or multiarch.  They've all installed sweetly.]

Share this post


Link to post
Share on other sites
  • 0

Everything with the netif.eth0 seems consistent with the Network Install wiki page.

You mentioned that using the interface with DHCP worked(no HW issues).

 

The only thing I can think of is that your DNS/DHCP doesn't like the address you're assigning statically.

I'm getting the impression the issue is not with your setup but the network you're trying to connect with.

 

Good Luck :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...