Jump to content
  • 0
romikb

1.4 bash completion not working

Question

I have a server on 1.4 upgraded from 1.3

Bash completion not working when I connect by ssh to server. It is because bash option "progcomp" is unset (but should be setted by default).

If a run a new bash shell from existing (type bash or mc) the completion is working in new shell.

 

On 1.3 a have no this issue.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

I found the source of issue - it is the /etc/profile:

# turn off progammable completion in bash by default:
shopt -u progcomp

 

17 minutes ago, bcowan said:

I just checked on a fresh container of 1.4 and on my main machine as normal user and root. shopt shows

progcomp           on

in all cases

 

I think that containers are nested bash shells. My containers also has no issues but main system have.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...