Jump to content
funtoo forums
  • 0
nigga-china

Connection with X server refused after emerge updates

Question

I did emerge -auDN @world and I got a list of new packages to be installed and others to be reinstalled. I saw that xorg-server should be updated, bringing some other dependecies with it. After the world update I did reboot my notebook. On the initiation of OpenRC I realized that the letters on the screen did not become small (as it usually does) and when I tried startx I got: 

Quote

xinit: giving up

xinit: unable to connect to X server: Connection refused

xinit: server error

 

I suspect about flags of xorg-server and flags of its dependencies, but I'm not sure about that. Can anybody help me with this issue?

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 1

most likely /etc/boot.conf got updated and nomodeset got added

please remove the nomodeset and run ego boot update then reboot your box.

hopefully all will be well then 🙂

Share this post


Link to post
Share on other sites
  • 0

But I got other issue, I have no wi-fi access anymore. It seems like some time ago when I tried to install liquorix kernel by an overlay. But this time I'm using the default debian sources kernel that got updated when I updated @world. After the update I did run genkernel all because I thought that the X server problem was because kernel configuration. Although if I choose the older kernel on GRUB's init I can get access to wi-fi.

Share this post


Link to post
Share on other sites
  • 0

You may need to modify your kernel build options to make sure that a module for your wifi chipset is being built.  You may also need to check whether the module is being loaded or if there is other firmware or drivers for the chipset that need to be installed.

https://wiki.gentoo.org/wiki/Kernel/Gentoo_Kernel_Configuration_Guide

https://www.funtoo.org/Install#Wi-Fi

 

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, nrc said:

You may need to modify your kernel build options to make sure that a module for your wifi chipset is being built.  You may also need to check whether the module is being loaded or if there is other firmware or drivers for the chipset that need to be installed.

https://wiki.gentoo.org/wiki/Kernel/Gentoo_Kernel_Configuration_Guide

https://www.funtoo.org/Install#Wi-Fi

 

Seems complicated to me but I'll try, because I want to install liquorix kernel on my computer.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...