Jump to content
funtoo forums
  • 0
Sign in to follow this  
stamasd

flatpak, Steam and non-privileged namespaces

Question

Current up-to-date installation of Funtoo (1.3), trying to have Steam installed via flatpak.

The installation of flatpak was successful, then I added the Steam flatpak repo. Now trying to run Steam with flatpak.

As regular user, the output of "flatpak run com.valvesoftware.Steam" is

	bwrap: No permissions to creating new namespace, likely because the kernel does not allow non-privileged user namespaces. On e.g. debian this can be enabled with 'sysctl kernel.unprivileged_userns_clone=1'.
error: ldconfig failed, exit status 256

I looked around and the only mention of a similar problem was

 

The solution there was to run as root. However trying to run the above as root fails because Steam cannot run as root.

 

All help appreciated.

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Default setting is disabled:

# cat /proc/sys/kernel/unprivileged_userns_clone 
0

Enable on reboot:

# echo 'kernel.unprivileged_userns_clone=1' > /etc/sysctl.d/unprivileged_userns_clone.conf

Verify enabled:

# cat  /proc/sys/kernel/unprivileged_userns_clone 
1

 

Share this post


Link to post
Share on other sites
  • 0
15 hours ago, cardinal said:

Default setting is disabled:


# cat /proc/sys/kernel/unprivileged_userns_clone 
0

Enable on reboot:


# echo 'kernel.unprivileged_userns_clone=1' > /etc/sysctl.d/unprivileged_userns_clone.conf

Verify enabled:


# cat  /proc/sys/kernel/unprivileged_userns_clone 
1

Thank you, that worked. Steam started after reboot, updating now.

(edit) Yes it works fine.

Share this post


Link to post
Share on other sites
  • 0

@synteejol

You will only see

/proc/sys/kernel/unprivileged_userns_clone

if you are booted into debian-sources or debian-sources-lts kernel.

I use  vanilla kernel sources, had to enable CONFIG_{USER_NS, UTS_NS, IPC_NS, PID_NS} and recompile.

Flatpak has pulseaudio error and I have no sound with any flatpak programs.

@stamasd

I installed flatpac and am unable to get sound to work. Perhaps you can help if it works for you?

Share this post


Link to post
Share on other sites
  • 0

I booted into linux-debian-sources-lts-4.9.130-2 but I obtain the error above. Anyway no problem, I solved my issue with flatpak following cardinal adivice and enabling proper kernel entry.  I installed Dota and it seems work fine,  I didn't try it yet.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...