Jump to content


  • Content Count

  • Joined

  • Last visited

  • Days Won


jhan last won the day on September 14 2019

jhan had the most liked content!


About jhan

  • Rank
    Advanced Member

Recent Profile Visitors

1,274 profile views
  1. I solved these problems by making myself an ebuild for a newer version of libreoffice-bin. Have updated it lately to libreoffice If you like you can find the ebuilds for it at: https://code.funtoo.org/bitbucket/users/jhan/repos/local-stuff/browse/app-office That is for libreoffice-bin and libreoffice-l10n. The ebuild works fine for me during my daily use. Feel free to test it. There might be some dependencies that need to be updated for funtoo 1.4 as well.
  2. This is an error that somehow got introduced into the funtoo system. So far there seems to be no solution but a workaround exists. See this bug for details.
  3. Ah, the full error messages helps. You need to add the line RESTRICT="network-sandbox" to the ebuild for it to work.
  4. I think the correct URL would be: https://github.com/Mange/rtl8192eu-linux-driver.git EGIT_REPO_URI (REQUIRED) URIs to the repository, e.g. https://foo. If multiple URIs are provided, the eclass will consider the remaining URIs as fallbacks to try if the first URI does not work. For supported URI syntaxes, read the manpage for git-clone(1). URIs should be using https:// whenever possible. http:// and git:// URIs are completely unsecured and their use (even if only as a fallback) renders the ebuild completely vulnerable to MITM attacks. Can be a whitespace-separated list or an array. Example: EGIT_REPO_URI="https://a/b.git https://c/d.git"
  5. I would do like the message suggests and check if the packages net-libs/gssdp net-libs/gupnp are installed. They are required for gupnp-idg
  6. OK, it seems the problem is a config script with pango that has hardcoded include paths: https://github.com/eiskaltdcpp/eiskaltdcpp/issues/413 https://gitlab.gnome.org/GNOME/pango/issues/387 After some tests there seem to be two solutions: - Patching the include path for kde-gtk-config to also include /usr/include/harfbuzz/ - Updating to kde-gtk-config-5.17.4 which does seem to have resolved that problem. But that would require to update most kde packages to 5.64.0 as well. Please open up a bug report at bug.funtoo.org with this information, so that the problem can get fixed one way or the other.
  7. Do you have media-libs/harfbuzz installed?
  8. The question is not if it can be fetched from the git repository but why you are getting that message. As there is no ebuild pango-9999 the problem is probably that some other ebuild is requesting a pango version that is higher than currently available in the tree. So, what did you try to emerge as you got that error and what does the build log say?
  9. Not if you emerge gimp with the USE flag '-python' pygtk is only required for gimp if you use python, as stated in the ebuild: python? ( ${PYTHON_DEPS} =dev-python/pygtk-2.10.4:2[${PYTHON_USEDEP}] =dev-python/pycairo-1.0.2[${PYTHON_USEDEP}] ) And to my knowledge you only loose the ability to use python based plugins. Everything else should work.
  10. A few more packages is still progress. And removing kde-plasma does not ensure success. But there are other ways you can try to get it working. Try equery d qtgui to see what other packages you have installed that depend on qtgui. Installing one of those might trick portage to update qtgui. You could also try uninstalling just kiconthemes. Or you can drop the parameter -D from emerge doing just a emerge -auN @world Probably some other things you can try (like installing single packages,...) but overall my experience is that working with a couple with those techniques is helpful. Always trying a world update in between to see if it works or not.
  11. I would try to update world first: emerge -auDN @world If that still wants to install kiconthemes before updating qtgui, try emerge -auDN @world --exclude kiconthemes Not sure if that won't lead to other conflicts but you can always play around with the exclude parameter (or multiple). Or try installing other packages first to reduce the number of updates needed.
  12. Look at line 101-102 in the log: ^[[01m^[[K/var/tmp/portage/kde-frameworks/kiconthemes-5.59.0/work/kiconthemes-5.59.0/src/kicontheme.cpp:^[[m^[[K In function ‘^[[01m^[[Kvoid setBreezeFallback()^[[m^[[K’: ^[[01m^[[K/var/tmp/portage/kde-frameworks/kiconthemes-5.59.0/work/kiconthemes-5.59.0/src/kicontheme.cpp:80:12:^[[m^[[K ^[[01;31m^[[Kerror: ^[[m^[[K‘^[[01m^[[KsetFallbackThemeName^[[m^[[K’ is not a member of ‘^[[01m^[[KQIcon^[[m^[[K’ or a bit clearer: /var/tmp/portage/kde-frameworks/kiconthemes-5.59.0/work/kiconthemes-5.59.0/src/kicontheme.cpp: In function void setBreezeFallback(): /var/tmp/portage/kde-frameworks/kiconthemes-5.59.0/work/kiconthemes-5.59.0/src/kicontheme.cpp:80:12: error: setFallbackThemeName is not a member of QIcon Which doesn't help much but points you in another direction. As QIcon seems to be provided by dev-qt/qtgui, this should be the next point to check. My successful test was with dev-qt/qtgui-5.12.3-r1. What version of qtgui do you have installed? As you migrated from funtoo 1.3, it could be that thus package is not yet upgraded.
  13. Those messages don't help either, as they are just warnings. They also appeared in the test install I did in a container just now, which completed successfully. The actual error has to be still higher up. And as the log file is not that large, it probably should be enough to provide the first part of it, if you can't find the error on your own.
  14. The message is only the final error. The real error is usually a bit higher up in the log file. Have a look and see if you can find another error.
  15. I would say that your are looking for the functionality of versionator.eclass or eapi7-ver.eclass. versionator.eclass can be found at https://code.funtoo.org/bitbucket/projects/AUTO/repos/gentoo-staging/browse/eclass/versionator.eclass eapi7-ver.eclass at https://code.funtoo.org/bitbucket/projects/AUTO/repos/gentoo-staging/browse/eclass/eapi7-ver.eclass
  • Create New...