Jump to content
funtoo forums
  • 0

Getting KDE to start


Core system working well, including X.  Problem is getting KDE to start; it doesn't.  Tried sddm first - followed suggestions, adding it to /etc/conf.d/xdm DISPLAYMANAGER="sddm".  That caused the system to hang when rc started xdm - got a blank screen with the mouse cursor, but nothing worked beyond that.  Rebooted with the sysresqcd to log onto the system and delete xdm (with sddm as displaymanager) from the rc-update default setting.  I've heard good things about gdm, but found no mention of someone using it to start KDE, and no instructions for how to aim the displaymanager at KDE, much less any other desktop environment.

BTW, I followed what directions I could find as far as setting up sddm, including other users experiences with the frozen login screen.

I'm stumped!  (Again!)

Share this post

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Yes, dbus is enabled.  I use consolekit; elogind in not installed.  I'm going to try gnome.  I've always used KDE in the past, but I think there is, right now, an issue with KDE's display manager.  (Besides, I really enjoy starting an install from scratch....)

Thanks for responding, Otakku!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now