Jump to content
funtoo forums
  • 0
Sign in to follow this  
checko55

Virtualbox issues fresh Funtoo install

Question

Hi guys,

I have a fresh installed Funtoo on a Threadripper environment.

When creating a new VM in Virtualbox I get following error message when creating the virtual disc:

Callee RC: NS_ERROR_ABORT (0x80004004)

without any more info. 

Even when starting Virtualbox from command line there are no further messages about that error.

Couldn't find any help so far.

 

Thanks for your help.

regards

Checko

 

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0

vboxpci                28672  0
vboxnetadp             28672  0
vboxnetflt             32768  0
vboxdrv               421888  3 vboxpci,vboxnetadp,vboxnetflt


modules are loaded

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, Oleg Vinichenko said:

is app-emulation/virtualbox-guest-additions really at version 5.2.20?

Sorry, thought guest-additions are same version as virtualbox. Just saw that the package isn't installed and can't be compiled.

Share this post


Link to post
Share on other sites
  • 0

hi again,

here are logs from VBoxSVC.log

HostDnsMonitorProxy::notify
00:00:00.104663 nspr-2   SUPR0QueryVTCaps -> VERR_SVM_DISABLED
00:00:00.104917 nspr-2   VD: VDInit finished with VINF_SUCCESS
00:00:00.105969 nspr-2   VirtualBox: object created
00:00:00.606697 nspr-2   ERROR [COM]: aRC=VBOX_E_OBJECT_NOT_FOUND (0x80bb0001) aIID={9b6e1aee-35f3-4f4d-b5bb-ed0ecefd8538} aComponent={EventSourceWrap} aText={Listener was never registered}, preserve=false aResultDetail=0
00:00:56.142676 main     VirtualBox: object deletion starts
00:00:56.146706 Watcher  ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={9570b9d5-f1a1-448a-10c5-e12f5285adad} aComponent={VirtualBoxWrap} aText={The object is not ready}, preserve=false aResultDetail=0
00:00:56.146832 main     VirtualBox: object deleted

and selectorwindow.log

00:00:00.251380 Log opened 2018-11-13T17:16:32.861293000Z
00:00:00.251380 Build Type: release
00:00:00.251382 OS Product: Linux
00:00:00.251383 OS Release: 4.19.0-gentoo
00:00:00.251383 OS Version: #14 SMP PREEMPT Fri Nov 9 08:22:46 CET 2018
00:00:00.251428 Host RAM: 32066MB (31.3GB) total, 31025MB (30.2GB) available
00:00:00.251431 Executable: /usr/lib64/virtualbox/VirtualBox
00:00:00.251431 Process ID: 7600
00:00:00.251432 Package type: LINUX_64BITS_GENERIC (OSE)
00:00:00.251444 Qt version: 5.9.4
00:00:00.262557 GUI: UIMediumEnumerator: Medium-enumeration started...
00:00:00.262581 GUI: UIMediumEnumerator: Medium-enumeration finished!
00:00:00.394042 GUI: UIDesktopWidgetWatchdog::sltHandleHostScreenAvailableGeometryCalculated: Screen 0 work area is actually resized to: 44x0 x 1876x1080
00:00:00.397724 GUI: UIDesktopWidgetWatchdog::sltHandleHostScreenAvailableGeometryCalculated: Screen 1 work area is actually resized to: 1920x0 x 1920x1200
00:00:01.901423 GUI: UIMediumEnumerator: Medium-enumeration started...
00:00:01.901512 GUI: UIMediumEnumerator: Medium-enumeration finished!
00:00:12.201820 GUI: UIMediumEnumerator: Medium with key={4e1b691d-60a6-4a66-bd48-f932f45ada78} created
00:00:15.228562 VirtualBoxClient: detected unresponsive VBoxSVC (rc=NS_ERROR_CALL_FAILED)
00:00:45.338331 VirtualBoxClient: detected working VBoxSVC (rc=NS_OK)
00:00:45.846757 GUI: UIMediumEnumerator: Medium-enumeration started...
00:00:45.846777 GUI: UIMediumEnumerator: Medium-enumeration finished!

that was all I found

Installed packages are:

virtualbox

virtualbox-additions

virtualbox-extpack-oracle

virtualbox-modules

versions are 5.2.20 for all these packages

virtualbox-guest-additions still can't be compiled like mentioned above

 

thanks

 

Share this post


Link to post
Share on other sites
  • 0

Hi Checko,

just guessing that it might help to rename your preferences folder for Virtualbox, e.g.

mv ~/.VirtualBox ~/.VirtualBox.bak

On the next start of VirtualBox it will get recreated. Possibly the autogenerated files compreg.dat and xpti.dat could be causing issues if you had the wrong guest additions installed.

And, you can alternatively install the guest additions manually in the UI. No need to do it with emerge if that does not work.

Cheers,
eyesee

Share this post


Link to post
Share on other sites
  • 0

Hello,

meanwhile I have done a reinstall again.

Unfortunately that didn't help at all.

I've followed your suggestions, but without success.

The guest additions provided by portage are version 5.2.14 and virtualbox is 5.2.22. Guest additions (5.2.14) can't be compiled at all.

This is what dmesg gives me when I try to create a new VM:

nspr-3[26894]: segfault at 0 ip 0000000000000000 sp 00007f76061dabc8 error 14 in VBoxSVC[55e1e0ea8000+5d3000]
 

Modules are loaded and these are all virtualbox packages that are installed at the moment, all version 5.2.22 from portage.

virtualbox

virtualbox-additions

virtualbox-modules

 

thx

Checko

 

Share this post


Link to post
Share on other sites
  • 0

Well, I remember I also once had problems with VirtualBox so I decided to switch to the binary package (virtualbox-bin). I also have just the virtualbox-modules installed, both in version 5.2.22 from portage. It might be worth a try, so if you uninstall everything related to Virtualbox and just emerge virtualbox-bin and virtualbox-modules I hope you will succeed. As a sidenote it is the case that in virtualbox-bin the executables changed from lowercase to camelcase. The additions can be installed manually from the UI, as said no need to do this with portage.

However, as I do not have a AMD Ryzen system the problem might be something completely different...

Share this post


Link to post
Share on other sites
  • 0

Hi again,

I finally got it running with virtualbox-bin and just recognized that a recent BIOS update seems to have switched off Virtualization.

Unfortunately something seems still be missing when uninstalling bin version and try to compile it by myself.

Maybe this is connected with the Threadripper?!

For now it will have to work like that.

 

Thanks for your help.

regards

Share this post


Link to post
Share on other sites
  • 0

Hej!

Good it worked for you so far! 😀

I can imagine VirtualBox source ebuild or the installed guest additions have some issues. As said, I remember having problems with the source package on my Intel system too. But I have not investigated any further yet due to lack of time. I just switched to the binary package and that worked for me. So unfortunately I can not tell if this is a Threadripper related problem. I hope someone else can help you better than me. Perhaps you should consider writing a bug report on the Funtoo bug tracker. By the end of year I will also retry installing from sources.

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×