Jump to content
  • 0

[Solved] ebuild for pysl package


Dear all,

for atom-1.3.1 I would like to write an ebuild pysl-0.21.1

As i looked in setup.py, I saw:

        'configparser; python_version<"3.0"',
        'futures; python_version<"3.2"',

        'all': [
        'autopep8': ['autopep8'],
        'mccabe': ['mccabe'],
        'pycodestyle': ['pycodestyle'],
        'pydocstyle': ['pydocstyle>=2.0.0'],
        'pyflakes': ['pyflakes>=1.6.0'],
        'rope': ['rope>0.10.5'],
        'yapf': ['yapf'],
        'test': ['tox', 'versioneer', 'pytest', 'mock', 'pytest-cov', 'coverage'],

How could i write something like 

'configparser; python_version<"3.0"'

in my ebuild?

Would it be correct to see all the packages below install_requires as DEPEND and all packages below extras_require as RDEPEND?




Share this post

Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

@Oleg VinichenkoThank you for your replay.

if i understand you correctly, then in my case of using python 3.6, then there is no problem.

What will happen if someone else with python 2.7 only would like to install this package as well? Then configparser will be needed.


What i am missing in your answer is a solution to the case that the someone else and I could use the same ebuild. Is there way to write one ebuild for both cases?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...