Jump to content
Read the Funtoo Newsletter: Summer 2023 ×
  • 0

www-client/firefox-61.0 requires Python 3.5 that is hard masked




I am using the 1.2 kit but stumbled onto a problem when building www-client/firefox-61.0;

 0:03.20 checking for Python 3... : python_wrapper_setup: python3 is not supported by python2.7 (PYTHON_COMPAT)
 0:03.20 no
 0:03.20 ERROR: Python 3.5 or newer is required to build. Ensure a `python3.x` executable is in your PATH or define PYTHON3 to point to a Python 3.5 executable.
 0:03.22 *** Fix above errors and then restart with\
 0:03.22                "/usr/bin/gmake -f client.mk build"
 0:03.22 gmake: *** [client.mk:149: configure] Error 1

While Firefox upgrade will have to wait for now I'm curious what to do when it's time to deal with this?

Is Python 3.5 "just" a matter of a python upgrade and a kit-change that I should have done or what? I am not using python myself, it is only there for the system so I am open for changes :)


// Erik

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 1

Funtoo 1.2 release has no effect on python-kit:

python-kit = 3.6-prime enables python-3.6.5-r1

funtoo /home/rj # ego  query v python
 dev-lang/python|     slot|                 repo
       2.7.13-r1|      2.7| python-kit/3.6-prime
     * 2.7.14-r2|         | python-kit/3.6-prime
        3.4.6-r1| 3.4/3.4m| python-kit/3.6-prime
           3.5.3| 3.5/3.5m| python-kit/3.6-prime
        3.5.3-r1|         | python-kit/3.6-prime
        3.6.1-r2| 3.6/3.6m| python-kit/3.6-prime
      * 3.6.5-r1|         | python-kit/3.6-prime
funtoo /home/rj # ego kit
/var/git/meta-repo (updated 1 day 14 hours 13 minutes ago):

  kit                  active branch        default              stability
  core-kit             1.2-prime            1.0-prime            beta
  core-hw-kit          master               (same)               prime
  security-kit         1.2-prime            1.0-prime            beta
  xorg-kit             1.19-prime           (same)               prime
  gnome-kit            3.20-prime           (same)               prime
  kde-kit              5.12-prime           (same)               prime
  media-kit            1.2-prime            1.1-prime            beta
  perl-kit             5.24-prime           (same)               prime
  python-modules-kit   master               (same)               prime
  python-kit           3.6-prime            3.4-prime            prime
  php-kit              master               (same)               prime
  java-kit             1.2-prime            1.1-prime            beta
  ruby-kit             1.2-prime            1.1-prime            beta
  haskell-kit          1.2-prime            1.1-prime            beta
  ml-lang-kit          1.2-prime            (same)               prime
  lisp-scheme-kit      1.2-prime            1.1-prime            beta
  lang-kit             1.2-prime            1.1-prime            beta
  llvm-kit             1.2-prime            (same)               prime
  dev-kit              1.2-prime            1.1-prime            beta
  xfce-kit             4.12-prime           (same)               prime
  desktop-kit          1.2-prime            1.1-prime            beta
  editors-kit          master               (same)               prime
  net-kit              master               (same)               prime
  text-kit             master               (same)               prime
  science-kit          master               (same)               prime
  games-kit            master               (same)               prime
  nokit                master               (same)               prime


Link to comment
Share on other sites

  • 0

You can unmask dev-lamg/python-3.5.3-r1
(Then you're using the 1.1-prime kits version ?)

Other way is to switch to 1.2-prime ß

8i'm using 1.2-prime ß andq the system seems to run very well ^^

ANyway after upgrade to 1.2-prime ß python-3.5.x will be pruned .... and you will have the 2.7 and 3.6 :)


Link to comment
Share on other sites

  • 0
 dev-lang/python|     slot|                 repo
       2.7.13-r1|      2.7| python-kit/3.4-prime
     * 2.7.14-r2|         | python-kit/3.4-prime
      * 3.4.6-r1| 3.4/3.4m| python-kit/3.4-prime
           3.5.3| 3.5/3.5m| python-kit/3.4-prime
        3.5.3-r1|         | python-kit/3.4-prime
        3.6.1-r2| 3.6/3.6m| python-kit/3.4-prime
        3.6.5-r1|         | python-kit/3.4-prime


I am using 1.2 in general but made no change to the python-kits.

Is there an upgrade procedure to be aware of? I am a newbie when it comes to python - besides all kind of hell from gentoo upgrades over the year. Been happy that I didn't need to upgrade for quite a while :) 



// Erik

Link to comment
Share on other sites

  • 0
>ERROR: Python 3.5 or newer is required to build. Ensure a `python3.x` executable is in your PATH or define PYTHON3 to point to a Python 3.5 executable. 0:03.22 *** Fix above errors and then restart with\

Quindi potresti passare a:

	python-kit                           3.4-prime       prime           
                      active          3.6-prime       prime

Another thing:

I've the same situation of Cardinal (he got ever reason ... in effect the passage from 1.1 to 1.2 doesn't require the upgrade of python-kit"

	ci74771ht ~ # ego query v python 
dev-lang/python|     slot|                 repo
      2.7.13-r1|      2.7| python-kit/3.6-prime 
    * 2.7.14-r2|         | python-kit/3.6-prime 
       3.4.6-r1| 3.4/3.4m| python-kit/3.6-prime 
          3.5.3| 3.5/3.5m| python-kit/3.6-prime 
       3.5.3-r1|         | python-kit/3.6-prime 
       3.6.1-r2| 3.6/3.6m| python-kit/3.6-prime 
     * 3.6.5-r1|         | python-kit/3.6-prime

and this describes that there are not installed python version >= 3.5

i don't now if is utile but my ego.onf is:


python-kit = 3.6-prime

core-kit = 1.2-prime
security-kit = 1.2-prime
xorg-kit = 1.19-prime
gnome-kit = 3.20-prime
kde-kit = 5.12-prime
media-kit = 1.2-prime
perl-kit = 5.24-prime
# php-kit =  
java-kit = 1.2-prime
ruby-kit = 1.2-prime
haskell-kit = 1.2-prime
ml-lang-kit = 1.2-prime
lisp-scheme-kit = 1.2-prime
lang-kit = 1.2-prime
llvm-kit = 1.2-prime
dev-kit = 1.2-prime
xfce-kit = 4.12-prime
desktop-kit = 1.2-prime
# editors-kit =  
# net-kit =  
# text-kit =  
# science-kit =
# games-kit =
# nokit


Good work for All _'_

Link to comment
Share on other sites

  • 0

Well, I though of Nike and just did it :)


It wasn't even than hard (I think). Then I ran into the EAPI=7 problem instead and verified that it's not related to the python upgrade and it isn't. Now I have the upgrade on hold until portage is upgraded.

Words will not express how much I adore the possibility to do upgrades in snapshots along side the live system!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...