Jump to content
funtoo forums
  • 0
Sandro

some inconsistencies

Question

ci74771ht ~ # emerge -DNu world --with-bdeps=y
Calculating dependencies... done!

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-python/PySocks:0

 dev-python/PySocks-1.6.7:0/0::python-kit, ebuild scheduled for merge conflicts with
   >=dev-python/PySocks-1.5.6[python_targets_python2_7(-),python_targets_python3_4(-),p
ython_targets_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),
-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_tar
get_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/urllib3-1.22
:0/0::python-kit, installed                                                              
                                                                                       
                                                                                       
                                                                                       
                                                    
   <dev-python/PySocks-2.0[python_targets_python2_7(-),python_targets_python3_4(-),pyth
on_targets_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-py
thon_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target
_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/urllib3-1.22:0/
0::python-kit, installed                                                                 
                                                                                       
                                                                                       
                                                                                       
                                                 

app-text/scrollkeeper-dtd:1.0

 app-text/scrollkeeper-dtd-1.0-r1:1.0/1.0::text-kit, ebuild scheduled for merge conflic
ts with
   =app-text/scrollkeeper-dtd-1.0 required by app-text/scrollkeeper-9999-r1:0/0::text-k
it, installed                                                                            
   ^                          ^^^

dev-python/chardet:0

 dev-python/chardet-3.0.4:0/0::python-kit, ebuild scheduled for merge conflicts with
   >=dev-python/chardet-3.0.2[python_targets_python2_7(-),python_targets_python3_4(-),p
ython_targets_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),
-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_tar
get_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/requests-2.1
8.4:0/0::python-kit, installed                                                           
                                                                                       
                                                                                       
                                                                                       
                                                    

dev-python/requests:0

 dev-python/requests-2.18.4:0/0::python-kit, ebuild scheduled for merge conflicts with
   dev-python/requests[python_targets_python3_5(-),-python_single_target_jython2_7(-),-
python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python
2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_6(-),python_sing
le_target_python3_5(+)] required by media-gfx/blender-2.78a-r1:0/0::media-kit, installed
                                                                                       
                                                                                       
                                                                                       
                       

dev-python/urllib3:0

 dev-python/urllib3-1.22:0/0::python-kit, ebuild scheduled for merge conflicts with
   >=dev-python/urllib3-1.21.1[python_targets_python2_7(-),python_targets_python3_4(-),
python_targets_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)
,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_ta
rget_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/requests-2.
18.4:0/0::python-kit, installed                                                          
                                                                                       
                                                                                       
                                                                                       
                                                     

dev-python/numpy:0

 dev-python/numpy-1.12.1:0/0::python-kit, ebuild scheduled for merge conflicts with
   >=dev-python/numpy-1.10.1[python_targets_python3_5(-),-python_single_target_jython2_
7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_
python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_6(-),pytho
n_single_target_python3_5(+)] required by media-gfx/blender-2.78a-r1:0/0::media-kit, ins
talled
                                                                                       
                                                                                       
                                                                                    
                             


!!! The following installed packages are masked:
- kde-apps/kremotecontrol-17.08.1::kde-kit (masked by: package.mask)
/var/git/meta-repo/kits/core-kit/profiles/package.mask/00-gentoo:
# Andreas Sturmlechner <asturm@gentoo.org> (30 Nov 2017)
# Declared dead upstream. Masked for removal in 30 days. Bug #634138

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.


_____________________________________________________________

Is it possible to solve this inconsistency?

 

Thx very much

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 1
5 hours ago, Sandro said:

!!! The ebuild selected to satisfy "app-text/asciidoc" has unmet requirements. - app-text/asciidoc-8.6.10::text-kit USE="graphviz -examples -highlight -test" PYTHON_SINGLE_TARGET="-pypy -python2_7" PYTHON_TARGETS="python2_7 -pypy"

 The following REQUIRED_USE flag constraints are unsatisfied:    exactly-one-of ( python_single_target_pypy python_single_target_python2_7 )

You need just do as it says: choose one of the python targets.

Share this post


Link to post
Share on other sites
  • 0

Those packages should have been updated months ago.

I think most of the packages don't want to install because of no declared python_single_target or python_targets

I recall having to add PYTHON_TARGETS="python2_7 python3_4" and PYTHON_SINGLE_TARGET="python3_4"  to /etc/portage/make.conf

After ego was fixed I removed it.

This is the closed bug report: https://bugs.funtoo.org/browse/FL-4123?jql=text ~ "python_single"

Verify you have ego-2.3.3-r1 installed

Share this post


Link to post
Share on other sites
  • 0

 

Uhm I've some trouble.:

>
	ci74771ht ~ # PYTHON_TARGETS="python2_7 python3_4" PYTHON_SINGLE_TARGET="python3_4" emer
ge -DNu world
Calculating dependencies... done!

!!! The ebuild selected to satisfy "app-text/asciidoc" has unmet requirements. 
- app-text/asciidoc-8.6.10::text-kit USE="graphviz -examples -highlight -test" PYTHON_SI
NGLE_TARGET="-pypy -python2_7" PYTHON_TARGETS="python2_7 -pypy" 

 The following REQUIRED_USE flag constraints are unsatisfied:
   exactly-one-of ( python_single_target_pypy python_single_target_python2_7 )

 The above constraints are a subset of the following complete expression:
   exactly-one-of ( python_single_target_pypy python_single_target_python2_7 ) python_s
ingle_target_pypy? ( python_targets_pypy ) python_single_target_python2_7? ( python_targ
ets_python2_7 )

(dependency required by "dev-util/colm-0.13.0.5::dev-kit" [installed]) 
(dependency required by "dev-util/ragel-7.0.0.10::dev-kit" [installed]) 
(dependency required by "dev-ruby/json-2.1.0::ruby-kit" [installed]) 
(dependency required by "dev-ruby/rdoc-5.1.0::ruby-kit[ruby_targets_ruby23]" [installed]
)
(dependency required by "dev-lang/ruby-2.2.8::ruby-kit[rdoc]" [installed]) 
(dependency required by "dev-ruby/test-unit-3.2.6::ruby-kit[ruby_targets_ruby22]" [insta
lled])
(dependency required by "dev-lang/ruby-2.3.5::ruby-kit" [installed]) 
(dependency required by "dev-ruby/did_you_mean-1.0.2::ruby-kit[ruby_targets_ruby23]" [in
stalled])

I've 1948 ebuilds.

World

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×