Jump to content
  • 0

[SOLVED]Fetch failed for 'media-sound/spotify-1.0.64


morphmex
 Share

Question

funtoomex messana # emerge spotify
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) media-sound/spotify-1.0.64::media-kit
>>> Downloading 'http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.64.407.g9bd02c2d-26_amd64.deb'
--2017-12-26 09:52:28--  http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.64.407.g9bd02c2d-26_amd64.deb
Resolving repository.spotify.com... 216.137.61.244, 216.137.61.185, 216.137.61.4, ...
Connecting to repository.spotify.com|216.137.61.244|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2017-12-26 09:52:28 ERROR 404: Not Found.

!!! Couldn't download 'spotify-client_1.0.64.407.g9bd02c2d-26_amd64.deb'. Aborting.
 * Fetch failed for 'media-sound/spotify-1.0.64', Log file:
 *  '/var/tmp/portage/media-sound/spotify-1.0.64/temp/build.log'

>>> Failed to emerge media-sound/spotify-1.0.64, Log file:

>>>  '/var/tmp/portage/media-sound/spotify-1.0.64/temp/build.log'

 * Messages for package media-sound/spotify-1.0.64:

 * Fetch failed for 'media-sound/spotify-1.0.64', Log file:
 *  '/var/tmp/portage/media-sound/spotify-1.0.64/temp/build.log'
funtoomex messana # 

 

Thanks for the help, have a nice day.

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Hello!

Have you run `ego sync` to update meta-repo?

I had the same problem. I solved. ...Trying to remember it...

The solution can be found by reading Funtoo Github > Media-Kit > media-sound > spotify: https://github.com/funtoo/media-kit/tree/1.0-prime/media-sound/spotify

ebuild file contains the link:

...DESCRIPTION="Spotify is a social music platform"
HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
BUILD_ID="407.g9bd02c2d"
SRC_BASE="http://repository.spotify.com/pool/non-free/s/${PN}-client/"
SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID}-26_amd64.deb )
	x86? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID}-26_i386.deb )"
LICENSE="Spotify"
SLOT="0"
KEYWORDS="~amd64 ~x86"...

But here are those source files: http://repository.spotify.com/pool/non-free/s/spotify-client/  The new version 69 released: spotify-client_1.0.69.336.g7edcc575-39_amd64.deb

I can assume it is a bug that can be solved by one of two ways:

1) manual downloading necessary version and placing it into /var/cache

2) editing the link in the ebuild file and using your own edited ebuild

I think this info will be useful:

https://www.funtoo.org/Repository_Configuration

https://www.funtoo.org/The_/var_Hierarchy

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...