Jump to content
funtoo forums
  • 0
More_Piffle

Cmake fails with "bus error"

Question

Hello all,

dev-util/cmake-3.8.0::core-kit

I was working on my Raspberry pi this weekend, (chroot from Rasberry linux) did ego sync, then emerge networkmanager. I had problems with use flags , did --autounmask-write and updated config file. everything goes along fine 51 packages installed. Then we get to cmake, everything seems to get started properly, applying patches etc until this one part shown below and I get "bus error"

armv7a-hardfloat-linux-gnueabi-g++ -O2 -pipe -march=armv7-a -mfloat-abi=hard  -I/var/tmp/portage/dev-util/cmake-3.8.0/work/cmake-3.8.0/Bootstrap.cmk -I/var/tmp/portage/dev-util/cmake-3.8.0/work/cmake-3.8.0/Source   -I/var/tmp/portage/dev-util/cmake-3.8.0/work/cmake-3.8.0/Utilities  -c /var/tmp/portage/dev-util/cmake-3.8.0/work/cmake-3.8.0/Source/cmGlobalGenerator.cxx -o cmGlobalGenerator.o
armv7a-hardfloat-linux-gnueabi-g++ -O2 -pipe -march=armv7-a -mfloat-abi=hard  -I/var/tmp/portage/dev-util/cmake-3.8.0/work/cmake-3.8.0/Bootstrap.cmk -I/var/tmp/portage/dev-util/cmake-3.8.0/work/cmake-3.8.0/Source   -I/var/tmp/portage/dev-util/cmake-3.8.0/work/cmake-3.8.0/Utilities  -c /var/tmp/portage/dev-util/cmake-3.8.0/work/cmake-3.8.0/Source/cmGlobalUnixMakefileGenerator3.cxx -o cmGlobalUnixMakefileGenerator3.o

Bus error

Everything is locked up for awhile but comes back - except chroot - terminal window has all of the info in it still.  

I did as much as i know to do - tried again - redid ego sync - rebooted and chroot with different chroot instructions - Checked that I still had disk space - tried another Pi - I reflashed my raspberry pi to clean SD with pi Linux, reinstalled funtoo and paid particularly close attention when setting up env and portage config / environment variables.

i did notice at the beginning of emerge it says 

*unable to find kernel  sources at /usr/src/linux

*Was unable to determine your kernel .config
 

Not sure where to look or what to do. suggestions requested.

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

bus error would be an indication of some hardware problems still.

for the .config, there ebuilds that looks for existence of /usr/src/linux, but those warnings should be harmless as normally they are for the runtime functionality. If the kernel sources needed for the bulding, then it should die during compilation. More information can be obtained from full build.log

Share this post


Link to post
Share on other sites
  • 0

Ok,

Turkey day break from Techie stuff is over, figured out how to find build log and use wgetpaste. 

Build log is at:

https://paste.pound-python.org/show/K9q4NBqmUr0YwXCSNX1c/

Doesnt seem to show much but I wouldnt know. The last line is where I get bus error, I thought it might be a power issue since I am Chroot into funtoo install on Raspberry Pi and my funtoo is in usb sd card reader. Found 2.5 amp PSU still get Bus error.

Share this post


Link to post
Share on other sites
  • 0

That is all that there is as far as build log (maddening how it just stops and leaves me in a dead zone of - WTF just happened? ) - the next thing I have noticed is I was not using a Class 10 SD card and on what I have been reading that is what is suggested for pi - Funny that I bought them at fry's electronics and even asked the guy working for a SD card for raspberry pi and he took me to the Pi section and handed me a card - turns out it was a class 4. when I asked this time for class 10 the guy looked at me like he was lost - anyway found class 10 SD and trying again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×