Jump to content
funtoo forums
  • 0
Sign in to follow this  
biocyberman

can't sync with emerge

Question

I could not sync with emerge. Manually sync'ing did not help. I guess it has something to do with the funtoo repo changes. Could not find any relevant document about this.

emerge --sync                                        
>> Syncing repository 'gentoo' into '/usr/portage'...        
usr/bin/git pull                                             
atal: remote error:                                          
 Repository not found.                                       
!! git pull error in /usr/portage                            
: Updating ebuild cache in /usr/portage ...                  
: Finished 39471 entries in 0.138483 seconds                 


cd /usr/portage
git remote -v                                    
origin  git://github.com/funtoo/ports-2012.git (fetch
origin  git://github.com/funtoo/ports-2012.git (push)

git clean -f -d 
git pull              
fatal: remote error:           
  Repository not found.        

 

Update:

Editting /etc/portage/repos.conf/gentoo did not help: 

sync-uri = git://github.com/funtoo/ports-2017.git

I am reading README on this repo https://github.com/funtoo/meta-repo

but not sure how to proceed

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Holy cow, I have a local version of dev-libs/glib-2.50.3-r1. Moved that out of place and the update could start. Wonder why I created the most challenging upgrade for myself. Lesson learned: When there is a conflict, check , really check where it comes from. I was assuming that both gdbus-codegen and dev-libs/glib come from the same repo, but later found out that dev-libs/glib comes from another repo.

Share this post


Link to post
Share on other sites
  • 0

Ok found this one and reading: http://forums.funtoo.org/topic/1176-how-to-migrate-from-ports-2012-to-meta-repo/

 

Still can't find the answer to "what should I do with stage3 files?"

 

Running this:

emerge -auDN @world --with-bdeps=y --verbose-conflicts --backtrack=30

gives error messages for one package after another:

 

These are the packages that would be merged, in order:                         


Calculating dependencies /             


!!! Problem resolving dependencies for sys-apps/file from @system              
... done!                              


!!! The ebuild selected to satisfy "sys-apps/file" has unmet requirements.     
- sys-apps/file-5.30::core-kit USE="python zlib -static-libs" ABI_X86="64 -32 -x32" PYTHON_TARGETS="-pypy -python2_7 -python3_4 -python3_5 -python3_6"        


  The following REQUIRED_USE flag constraints are unsatisfied:                 
    python? ( any-of ( python_targets_pypy python_targets_python2_7 python_targets_python3_4 python_targets_python3_5 python_targets_python3_6 ) )  

I editted the package.use and added:

>=sys-apps/file-5.30 python_targets_python2_7

And similar error appeared for another package, and another package, ...

 

There must be something not right here. Should I download stage3 file and overwrite before proceed further? I installed Funtoo with this stage3 file: stage3-intel64-sandybridge-funtoo-current-hardened-2017-06-09.tar.xz

Share this post


Link to post
Share on other sites
  • 0

@Oleg: Thanks for the pointer. It solved the problem with pythong_tagrgets. However, I came to another problem: version conflict between dev-util/gdbus-codegen-2.50.3 and dev-libs/glib-2.50.3-r1:

 

# emerge -av "dev-libs/glib"                                                                                                                                                                                                                                                                                
                                                                                                                                                                                                                                                                                                                             
These are the packages that would be merged, in order:                                                                                                                                                                                                                                                                       
                                                                                                                                                                                                                                                                                                                             
Calculating dependencies... done!                                                                                                                                                                                                                                                                                            
[ebuild     U  ] dev-libs/glib-2.50.3-r1:2::x-portage [2.48.2:2::gentoo] USE="dbus* mime xattr -debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 9,298 KiB                                                                                                
[blocks B      ] <dev-util/gdbus-codegen-2.50.3 ("<dev-util/gdbus-codegen-2.50.3" is blocking dev-libs/glib-2.50.3-r1)
                                                                                                        
Total: 1 package (1 upgrade), Size of downloads: 9,298 KiB                                         
Conflict: 1 block (1 unsatisfied)                                                                     
                                                                                                                                                              
 * Error: The above package list contains packages which cannot be                                                                                            
 * installed at the same time on the same system.                                                                                                             
                                                                                                                    
  dev-util/gdbus-codegen-2.48.2:0/0::gentoo, installed pulled in by                                                     
    >=dev-util/gdbus-codegen-2.32 required by sys-fs/udisks-2.6.5:2/2::gentoo, installed                            
    dev-util/gdbus-codegen required by net-print/cups-filters-1.14.1:0/0::gentoo, installed                   
    dev-util/gdbus-codegen required by app-crypt/gcr-3.20.0:0/1::gentoo, installed                    
    dev-util/gdbus-codegen required by net-libs/webkit-gtk-2.4.11-r1:3/25::gentoo, installed  
    dev-util/gdbus-codegen required by net-misc/modemmanager-1.6.4:0/1::gentoo, installed                         
    >=dev-util/gdbus-codegen-2.38.2 required by x11-libs/gtk+-3.20.9:3/3::gentoo, installed                     
    dev-util/gdbus-codegen required by gnome-base/gnome-desktop-3.20.2:3/12::gentoo, installed  
    dev-util/gdbus-codegen required by gnome-base/gvfs-1.28.3-r1:0/0::gentoo, installed                            
    dev-util/gdbus-codegen required by gnome-extra/evolution-data-server-3.20.5:0/57::gentoo, installed
    dev-util/gdbus-codegen required by app-misc/geoclue-2.4.4:2.0/2.0::gentoo, installed                          
    >=dev-util/gdbus-codegen-2.30.0 required by net-libs/gnome-online-accounts-3.20.4:0/1::gentoo, installed
    dev-util/gdbus-codegen required by net-libs/webkit-gtk-2.16.3:4/37::gentoo, installed                                 
    dev-util/gdbus-codegen required by gnome-base/dconf-0.26.0:0/0::gentoo, installed                               
    dev-util/gdbus-codegen required by app-crypt/libsecret-0.18.5:0/0::gentoo, installed                             
                                                                                                    
  dev-libs/glib-2.50.3-r1:2/2::x-portage, ebuild scheduled for merge pulled in by                                                                                                                                                                                                                                            
    >=dev-libs/glib-2.34:2 required by sci-geosciences/geocode-glib-3.20.1:0/0::gentoo, installed
    >=dev-libs/glib-2.40:2 required by gnome-extra/evolution-ews-3.20.5:0/0::gentoo, installed    
    >=dev-libs/glib-2.40:2=[dbus] required by sys-auth/consolekit-1.0.1:0/0::gentoo, installed       
    >=dev-libs/glib-2.40:2 required by gnome-extra/evolution-data-server-3.20.5:0/57::gentoo, installed
    >=dev-libs/glib-2.46.2:2 required by gnome-base/gvfs-1.28.3-r1:0/0::gentoo, installed                              
    dev-libs/glib:2 required by net-misc/remmina-1.2.0_rc18:0/0::gentoo, installed           
    >=dev-libs/glib-2.34.3:2[abi_x86_64(-)] required by net-libs/libsoup-2.54.1-r1:2.4/2.4::gentoo, installed          
    >=dev-libs/glib-2.45.8:2[abi_x86_64(-)] required by x11-libs/gtk+-3.20.9:3/3::gentoo, installed        
    >=dev-libs/glib-2.37.6:2[abi_x86_64(-)] required by dev-libs/json-glib-1.2.2:0/0::gentoo, installed
    dev-libs/glib:2 required by dev-qt/qtgui-5.7.1:5/5.7::gentoo, installed                                                                                                                                                                                                                                                  
    >=dev-libs/glib-2.32:2[abi_x86_64(-)] required by app-accessibility/at-spi2-atk-2.20.1:2/2::gentoo, installed                
    >=dev-libs/glib-2.34:2 required by app-misc/geoclue-2.4.4:2.0/2.0::gentoo, installed
    >=dev-libs/glib-2.32:2 required by dev-lang/vala-0.32.1:0.32/0.32::gentoo, installed                                      
    >=dev-libs/glib-2.28:2[abi_x86_64(-)] required by net-wireless/bluez-5.45:0/3::gentoo, installed
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-),abi_x86_64(-)] required by x11-libs/pango-1.40.3:0/0::gentoo, installed
    >=dev-libs/glib-2.35.1:2 required by dev-libs/libgweather-3.20.3:2/3-6::gentoo, installed
    >=dev-libs/glib-2.48.0:2[abi_x86_64(-)] required by dev-cpp/glibmm-2.48.1:2/2::gentoo, installed
    dev-libs/glib required by app-emulation/virtualbox-bin-5.1.22.115126:0/0::gentoo, installed
    >=dev-libs/glib-2.4.0:2[abi_x86_64(-)] required by media-sound/pulseaudio-10.0:0/0::gentoo, installed                                                                                                                    
    >=dev-libs/glib-2.45.8:2 required by dev-util/gtk-update-icon-cache-3.20.9:0/0::gentoo, installed                                                                                                                                                                                                                        
    >=dev-libs/glib-2.40:2 required by x11-libs/vte-0.44.2:2.91/2.91::gentoo, installed                 
    dev-libs/glib:2 required by net-misc/icaclient-13.5.0.10185126:0/0::gentoo, installed          
    >=dev-libs/glib-2.34.3:2[abi_x86_64(-)] required by dev-libs/fribidi-0.19.7:0/0::gentoo, installed
    >=dev-libs/glib-2.36:2 required by mate-base/mate-desktop-1.18.0:0/0::gentoo, installed                
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-),abi_x86_64(-)] required by dev-libs/libcroco-0.6.11:0.6/0.6::gentoo, installed
    dev-libs/glib:2 required by app-text/poppler-0.51.0:0/66::gentoo, installed                                        
    >=dev-libs/glib-2.16.0:2[abi_x86_64(-)] required by gnome-base/libgnome-keyring-3.12.0-r1:0/0::gentoo, installed
    dev-libs/glib:2 required by net-print/cups-filters-1.14.1:0/0::gentoo, installed                                    
    >=dev-libs/glib-2.34.3:2[abi_x86_64(-)] required by media-libs/gstreamer-0.10.36-r2:0.10/0.10::gentoo, installed
    >=dev-libs/glib-2.48:2 required by dev-libs/gobject-introspection-1.48.0:0/0::gentoo, installed                                                                                                                                                                                                                          
    >=dev-libs/glib-2.6:2 required by dev-util/gtk-doc-1.25-r1:0/0::gentoo, installed                 
    >=dev-libs/glib-2.32 required by net-libs/libqmi-1.18.0:0/5.1::gentoo, installed          
    >=dev-libs/glib-2.24:2[abi_x86_64(-)] required by net-libs/rest-0.8.0:0.7/0.7::gentoo, installed              
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-),abi_x86_64(-)] required by dev-libs/atk-2.20.0:0/0::gentoo, installed
    >=dev-libs/glib-2:2 required by app-admin/system-config-printer-1.4.8:0/0::gentoo, installed
    >=dev-libs/glib-2.44.0:2[dbus] required by gnome-base/gnome-desktop-3.20.2:3/12::gentoo, installed             
    dev-libs/glib:2 required by net-im/slack-bin-2.5.2:0/0::gentoo, installed                          
    >=dev-libs/glib-2.36:2 required by net-libs/webkit-gtk-2.4.11-r1:3/25::gentoo, installed                      
    >=dev-libs/glib-2.32:2 required by net-libs/libmbim-1.14.0:0/0::gentoo, installed                       
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-),abi_x86_64(-)] required by media-libs/harfbuzz-9999:0/0.9.18::gentoo, installed                                                                                                                                                                                                   
    >=dev-libs/glib-2.40.0:2[abi_x86_64(-)] required by media-libs/gst-plugins-bad-1.10.3:1.0/1.0::gentoo, installed
    >=dev-libs/glib-2.40.0:2[abi_x86_64(-)] required by media-libs/gst-plugins-base-1.10.4:1.0/1.0::gentoo, installed
    >=dev-libs/glib-2.30.0:2[abi_x86_64(-)] required by dev-libs/libgudev-231:0/0::gentoo, installed
    >=dev-libs/glib-2.38:2 required by gnome-base/gnome-keyring-3.20.0:0/0::gentoo, installed                                                                                                           
    dev-libs/glib:2 required by x11-misc/rofi-1.3.1:0/0::gentoo, installed                       
    dev-libs/glib:2[abi_x86_64(-)] required by dev-qt/qtcore-4.8.7-r2:4/4::gentoo, installed      
    >=dev-libs/glib-2.46:2 required by net-im/telepathy-mission-control-5.16.4:0/0::gentoo, installed
    >=dev-libs/glib-2.34.3:2[abi_x86_64(-)] required by dev-libs/dbus-glib-0.108:0/0::gentoo, installed
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-),abi_x86_64(-)] required by gnome-base/librsvg-2.40.16:2/2::gentoo, installed

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...