Jump to content
  • 0
yczo

Can' t mask an ebuild

Question

Hello, I am on current und new instalation,

 

I tried to mask  =dev-libs/openssl-1.1.0e because produce a failure rebuilding  python 2.7, but, don't work.

 

I tried to create the file /etc/portage/package.mask... and there added the line "=dev-libs/openssl-1.1.0e". Did not work...

 

later I did make tje next simbolyc link "package.mask -> /var/git/meta-repo/kits/core-kit/profiles/base/package.mask" and added the same line; Had not working too.

 

when i make emerge --update --deep --newuse world...   the dev-libs/openssl-1.1.0e install again un produce the error rebuilding python 2.7

 

Why is not masked?? What Can i do for mask the ebuild? Is anything wrong?

 

Thanks in advance.

 

Greetings

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

(0) 1.0.2k^d {M}(~)1.1.0e(0/1.1)^d

Curly brackets { } around the Mask  =>  {M}
The version was originally masked in $PORTDIR/profiles/package.mask, but this was locally changed in /etc/portage/package.unmask.
Eix indicates you have manually unmasked openssl-1.1.0e in /etc/portage/package.unmask

Remove that configuration.

 

Reference: eix manpage

Share this post


Link to post
Share on other sites
  • 0

Your system should not be trying to emerge dev-libs/openssl-1.1.0e

 

dev-libs/openssl-1.1.0e is masked by portage:

 

/var/git/meta-repo/kits/core-kit/profiles/package.mask/00-gentoo

 

# Lars Wendler <polynomial-c@gentoo.org> (26 Aug 2016)
# Masked while being tested and reverse deps aren't fully compatible
=dev-libs/openssl-1.1*

 

 On  my systems Installed versions: openssl-1.0.2k, Available versions: [M](~)1.1.10e [M] indicates masked.

funtoo rj # eix -I openssl
dev-libs/openssl
     Available versions:  
     (0.9.8) 0.9.8z_p8^d
     (0)    (~)1.0.2g-r1(0/1.0.2g)^d[1] 1.0.2k^d [M](~)1.1.0e(0/1.1)^d
       {+asm bindist gmp kerberos rfc3779 sctp sslv2 +sslv3 static-libs test (+)tls-heartbeat vanilla zlib ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" CPU_FLAGS_X86="sse2"}
     Installed versions:  1.0.2k^d[?](12:49:14 PM 01/30/2017)(asm sslv3 tls-heartbeat zlib -bindist -gmp -kerberos -rfc3779 -sctp -sslv2 -static-libs -test -vanilla ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32" CPU_FLAGS_X86="sse2")
     Homepage:            http://www.openssl.org/
     Description:         full-strength general purpose cryptography library (including SSL and TLS)
 

Share this post


Link to post
Share on other sites
  • 0

Thank you very much for answer;

 

Yes, in my system is too like unstable marked

The questios is: Why try to install it????

where should look to fix it?

 

 

Regards

Share this post


Link to post
Share on other sites
  • 0

 

#eix dev-libs/openssl

[U] dev-libs/openssl
     Verf?gbare Versionen:   
     (0.9.8) 0.9.8z_p8^d
     (0)    1.0.2k^d {M}(~)1.1.0e(0/1.1)^d
       {+asm bindist gmp kerberos rfc3779 sctp sslv2 +sslv3 static-libs test (+)tls-heartbeat vanilla zlib ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" CPU_FLAGS_X86="sse2"}                                                                                                          
     Installierte Versionen: 1.0.2k^d(21:27:41 10.08.2017)(asm sslv3 tls-heartbeat zlib -bindist -gmp -kerberos -rfc3779 -sctp -sslv2 -static-libs -test -vanilla ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32" CPU_FLAGS_X86="sse2")                                          
     Startseite:             http://www.openssl.org/
     Beschreibung:           full-strength general purpose cryptography library (including SSL and TLS)
 
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...