Jump to content
Funtoo Linux
  • 0
Sandro

I'm not able to compile a kernel withouth genkernel/initramfs

Question

Hi to all.

I' trying to use the last git-sources-4.9_rc5

 

But starting my PC i obtain kernel panic.

 

The .config now is: http://pastebin.com/Qexwtgup

 

And:

 

my

ci74771ht ~ # lspci 
00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (r
ev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI
Express x16 Controller (rev 06)
00:14.0 USB controller: Intel Corporation 9 Series Chipset Family USB xHCI Contr
oller
00:16.0 Communication controller: Intel Corporation 9 Series Chipset Family ME I
nterface #1
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection (2) I218-V
00:1a.0 USB controller: Intel Corporation 9 Series Chipset Family USB EHCI Contr
oller #2
00:1b.0 Audio device: Intel Corporation 9 Series Chipset Family HD Audio Control
ler
00:1c.0 PCI bridge: Intel Corporation 9 Series Chipset Family PCI Express Root P
ort 1 (rev d0)
00:1c.3 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d0)
00:1c.7 PCI bridge: Intel Corporation 9 Series Chipset Family PCI Express Root P
ort 8 (rev d0)
00:1d.0 USB controller: Intel Corporation 9 Series Chipset Family USB EHCI Contr
oller #1
00:1f.0 ISA bridge: Intel Corporation 9 Series Chipset Family Z97 LPC Controller
00:1f.2 SATA controller: Intel Corporation 9 Series Chipset Family SATA Controll
er [AHCI Mode]
00:1f.3 SMBus: Intel Corporation 9 Series Chipset Family SMBus Controller
01:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 660] (r
ev a1)
01:00.1 Audio device: NVIDIA Corporation GK106 HDMI Audio Controller (rev a1)
03:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev
04)
04:01.0 Multimedia controller: Philips Semiconductors SAA7131/SAA7133/SAA7135 Vi
deo Broadcast Decoder (rev d1)
05:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (re
v 01)

 

Thanx for any suggestion _'_ forgive my ignorance .....  :'(

 

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Ok .... Solved with "restarting from 0" the kernel .config file _'_

 

I'm sorry I did not understand what he could create conflicts in my previous kernel .config (Sob ... ;'( )
 
Anyway, now I miss to fix the fact that I did not recognize the "USB tethering" with smartphones _'_
 
However Thx :)
 
For info:
My latest [url=I'm sorry I did not understand what he could create conflicts in my previous kernel .config: |
 
Anyway, now I miss to fix the fact that I did not recognize the "USB tethering" with smartphones _'_
 
However ...my lateset kernel config : http://pastebin.com/zA821bdx

Share this post


Link to post
Share on other sites
  • 0
ci74771ht ~ # fdisk -l 
Disk /dev/sdb: 931,5 GiB, 1000204886016 bytes, 1953525168 sectors 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x8f8002b1

Dispositivo Avvio      Start       Fine    Settori   Size Id Tipo 
/dev/sdb1               2048 1153433599 1153431552   550G  7 HPFS/NTFS/exFAT
/dev/sdb2         1153433600 1919971327  766537728 365,5G 83 Linux
/dev/sdb3         1919971328 1953525167   33553840    16G 82 Linux swap / Solari


Disk /dev/sda: 111,8 GiB, 120034123776 bytes, 234441648 sectors 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xa0af8bdf

Dispositivo Avvio     Start      Fine   Settori  Size Id Tipo 
/dev/sda1   *          2048   1026047   1024000  500M  7 HPFS/NTFS/exFAT
/dev/sda2           1026048 146802687 145776640 69,5G  7 HPFS/NTFS/exFAT
/dev/sda3         146802688 234440703  87638016 41,8G  5 Esteso
/dev/sda5         146804736 147329023    524288  256M 83 Linux
/dev/sda6         147331072 234440703  87109632 41,6G 83 Linux

My Funtoo root is on /dev/sda6

 

Motherboard Asus Z97-AR

 

I don't use **EFI" but "legacy mbr")

 

the "built-in kernel command string is a "null" string)

 

Thanx.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×