Jump to content
Read the Funtoo Newsletter: Summer 2023 ×
  • 0

[SOLVED] ERROR: media-tv/kodi-16.1::gentoo failed



Hi to all!!!



funtoomex messana # emerge --info
Portage 2.3.2 (python 2.7.12-final-0, funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.9.3, glibc-2.22, 4.7.8-1~bpo8+1 x86_64)
System uname: Linux-4.7.8-1~bpo8+1-x86_64-Intel-R-_Core-TM-_i7_CPU_Q_720_@_1.60GHz-with-gentoo-2.2.1
KiB Mem:     3982780 total,    119108 free
KiB Swap:    5119996 total,   4865128 free
sh bash 4.3_p42
ld GNU ld (Funtoo 2.25) 2.25.0
app-shells/bash:          4.3_p42::gentoo
dev-lang/perl:            5.24.0-r2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.6.3::gentoo
sys-apps/baselayout:      2.2.1::gentoo
sys-apps/openrc:          0.18.3-r2::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25-r2::gentoo
sys-devel/gcc:            4.9.3-r3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22::gentoo

    location: /usr/portage
    sync-type: git
    sync-uri: git://github.com/funtoo/ports-2012.git
    priority: -1000

ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=core2 -O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
USE="X a52 aac acl alsa amd64 apng berkdb bluray bzip2 cdda cddb cdio cdr consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr dvdread encode exif faac faad ffmpeg flac gdbm gif gpm ico iconv icu ieee1394 ios ipod ipv6 jpeg jpeg2k kde kipi lame libass libguess libmpeg2 mad matroska mjpeg mmx modules mp3 mpeg mtp mudflap multilib ncurses nls nptl nsplugin ogg opengl openmp pam pcre pdf phonon plasma png policykit postproc pppd python qml qt5 quicktime readline resolvconf semantic-desktop sndfile sse sse2 ssl svg taglib tcpd theora tiff truetype twolame udev unicode v4l vorbis vpx wav wavpack webp widgets win32codecs wmf x264 x265 xattr xcomposite xinerama xml xscreensaver xvid zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel ice1724 intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="mouse keyboard evdev synaptics" KERNEL="linux" L10N="it" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby20 ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

funtoomex messana # 

Thanks in advance for your advice and your help. ;-)

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0
Kodi built successfully
>>> Source compiled.
>>> Test phase [not enabled]: media-tv/kodi-16.1

>>> Install kodi-16.1 into /var/tmp/portage/media-tv/kodi-16.1/image/ category media-tv
make -j9 DESTDIR=/var/tmp/portage/media-tv/kodi-16.1/image/ install 
Copying kodi binary to /var/tmp/portage/media-tv/kodi-16.1/image//usr/lib64/kodi/
Copying support and legal files...
You can run kodi with the command 'kodi'                                       
Copying system files to /var/tmp/portage/media-tv/kodi-16.1/image//usr/share/kodi
Copying bindings to /var/tmp/portage/media-tv/kodi-16.1/image//usr/include/kodi
>>> Completed installing kodi-16.1 into /var/tmp/portage/media-tv/kodi-16.1/image/

 * Final size of build directory: 398328 KiB
 * Final size of installed tree: 51944 KiB

 * QA Notice: This package installs one or more .desktop files that do not
 * pass validation.
 *      /usr/share/applications/kodi.desktop: warning: key "OnlyShowIn" in group "Desktop Action Fullscreen" is deprecated
 *      /usr/share/applications/kodi.desktop: warning: key "OnlyShowIn" in group "Desktop Action Standalone" is deprecated

 * QA Notice: Package triggers severe warnings which indicate that it
 *            may exhibit random runtime failures.
 * /var/tmp/portage/media-tv/kodi-16.1/work/xbmc-16.1-Jarvis/lib/libdvd/libdvdread/src/md5.c:107:3: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
 * /var/tmp/portage/media-tv/kodi-16.1/work/xbmc-16.1-Jarvis/lib/libdvd/libdvdread/src/md5.c:108:3: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
 * /var/tmp/portage/media-tv/kodi-16.1/work/xbmc-16.1-Jarvis/lib/libdvd/libdvdread/src/nav_print.c:39:3: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
 * libdcr.c:2124:30: warning: iteration 386u invokes undefined behavior [-Waggressive-loop-optimizations]
 * libdcr.c:2115:16: warning: iteration 386u invokes undefined behavior [-Waggressive-loop-optimizations]
 * libdcr.c:5720:20: warning: iteration 3u invokes undefined behavior [-Waggressive-loop-optimizations]
 * libdcr.c:6462:20: warning: iteration 3u invokes undefined behavior [-Waggressive-loop-optimizations]

 * Please do not file a Gentoo bug and instead report the above QA
 * issues directly to the upstream developers of this software.
 * Homepage: https://kodi.tv/ http://kodi.wiki/
strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment -R .GCC.command.line -R .note.gnu.gold-version
ecompressdir: bzip2 -9 /usr/share/doc

>>> Installing (6 of 6) media-tv/kodi-16.1::gentoo

>>> Recording media-tv/kodi in "world" favorites file...
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

funtoomex messana #

Solved: USE="java" emerge kodi  (https://bugs.gentoo.org/show_bug.cgi?id=598058)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...