Jump to content
Read the Funtoo Newsletter: Summer 2023 ×
  • 0

GNOME: no power manager utility or lid close trigger



Dear funtoo users,


I have a wonderful Funtoo GNOME on my Lenovo Thinkpad T450s as my main workstation desktop.

Thank you developers (and Gentoo and GNOME developers too) for your hard work!


I have only one (or two...) more issue that I can't solve with googling or reading wikis and forums.


I can't have the GNOME power manager utility working.

The system doesn't memorize the backlight level between reboots.

And even if the suspend button (with ALT + power botton in the GNOME menu) works, the system can't detect the lid close event.


I read a lot about that in the Funtoo Bug JIRA but I don't understand what information can I apply at the present situation and version of GNOME.

https://bugs.funtoo.org/browse/FL-2792https://bugs.funtoo.org/browse/FL-1329 https://bugs.funtoo.org/browse/FL-1637


Have anyone any updated information or procedure to get the power system working on my laptop?

Thank you for your time and patience!





Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I can only report the behavior of my one funtoo installation on my Sony VAIO laptop. I did not intensionally test your fix. I did an update and then the suspend would happen on every lid close. The roll back gets me the normal behavior for lid close. I don't know the particulars. All I did was update (emerge -ua acpid) with and without adding to /etc/portage/package.mask the (uncommented) line `=sys-power/acpid-2.0.28'. I just installed one version of acpid and tried the lid close, then I installed the other and tested the lid close. The result was entirely dependent on which version of acpid was installed. I changed nothing else to get the contrast in the funtoo response to closing the lid. I know less than you about how funtoo works, and I don't have anything more to add. Other people's results may vary. Sometimes I have a Sony VAIO driver issue that others do not have, at least that is how I explain to myself problems for which I can't find documentation or description from searching the Web. I think the fix broke the function of funtoo for me. That's all I can suggest with any confidence. If it is not causing the same problem for others, I can't explain it.


Perhaps my install is different somehow?

Host me # uname -srvmpio
Linux 4.8.5 #1 SMP Wed Nov 2 08:49:05 EDT 2016 x86_64 Intel(R) Core(TM) i5-2430M CPU @ 2.40GHz GenuineIntel GNU/Linux
Host me #
Host me # emerge --info
Portage 2.3.2 (python 2.7.12-final-0, funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.9.3, glibc-2.22, 4.8.5 x86_64)
System uname: Linux-4.8.5-x86_64-Intel-R-_Core-TM-_i5-2430M_CPU_@_2.40GHz-with-gentoo-2.2.1
KiB Mem:     3966328 total,   2918440 free
KiB Swap:    2097148 total,   2097148 free
sh bash 4.3_p42
ld GNU ld (Funtoo 2.25) 2.25.0
app-shells/bash:          4.3_p42::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.0-r2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.3.5-r8::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.6.2::gentoo
sys-apps/baselayout:      2.2.1::gentoo
sys-apps/openrc:          0.18.3-r2::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25-r2::gentoo
sys-devel/gcc:            4.9.3-r3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22::gentoo

    location: /usr/portage
    sync-type: git
    sync-uri: git://github.com/funtoo/ports-2012.git
    priority: -1000

ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=sandybridge -O2 -pipe"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=sandybridge -O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=sandybridge -O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
USE="X a52 aac acl alsa amd64 apng berkdb bluray bzip2 cdda cddb cdio cdr consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr dvdread encode exif faac faad ffmpeg flac gcj gdbm gif gpm gtk ico iconv icu ieee1394 ios ipod ipv6 java jpeg jpeg2k lame libass libguess libmpeg2 libnotify lock mad matroska mjpeg mmx modules mp3 mpeg mtp mudflap multilib ncurses nls nptl nsplugin ogg opengl openmp pam pcre pdf png policykit postproc pppd python quicktime readline resolvconf sasl session sndfile sse sse2 ssl startup-notification svg taglib tcpd theora thunar tiff truetype twolame udev unac unicode v4l vorbis vpx wav wavpack webp win32codecs wmf x264 x265 xattr xml xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel ice1724 intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="evdev synaptics keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby20 ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="radeon intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Host me #
Link to comment
Share on other sites

  • 0

I put this out into the ether. I tried the latest acpid today, which is acpid-2.0.28-r1, on 10 January 2017. Just like plain acpid-2.0.28, its revision one triggers a Funtoo Gnu/Linux suspension on my Sony VAIO laptop on lid close. I never had the suspend actually work before, so there's the silver lining. Still, I only get correct behavior with acpid-2.0.23. Is there a better choice than acpid?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...