Jump to content
Funtoo Linux
  • 0
adcdam

i get unknow domain after booting

Question

 also when booting:  /lib64/rc/sh/rc_cgroup.sh line 91 : /sys/fs/cgroup/openrc/swapfiles /tasks: file or directory doesn t exist 

 

i saw this page  http://www.funtoo.org/Hostname

 

i edited this file /etc/conf.d/hostname

 

  
# Set to the fully qualified domain name (e.g. "mybox.example.com") of this
# machine, if it has one, otherwise set to the machine name (e.g. "mybox").
# This hostname will be automatically added to /etc/hosts for the 127.0.0.1 and
# ::1 addresses.

hostname="damian"

# If your local system has other aliases for your local interfaces, you can
# add them here. These will also be added to /etc/hosts for 127.0.0.1 and ::1:
# Add aliases for other hosts to /etc/hosts directly. The networking scripts
# automatically generate the localhost lines only.

#aliases="mybox server1"

# Set to the NIS domain name of this machine, if it has one, otherwise leave
# commented out.

#nisdomainname="localdomain.com"

after that i type sudo service hostname restart

 

but my /etc/host file is in blank

and when booting i get the same

 

 

 

 

what im doing wrong? i know this is very stupid and im stupid...

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

 

Bug report about this: open-rc random issue - rc-group.sh cant find file or directory

When booting: /lib64/rc/sh/rc_cgroup.sh line 91 : /sys/fs/cgroup/openrc/swapfiles /tasks: file or directory doesn t exist

 

 

rj@funtoo ~ $ cat /etc/hosts

127.0.0.1	funtoo localhost localhost.localdomain
::1		funtoo localhost localhost.localdomain

I edit /etc/conf.d/hostname and change hostname="damian" and save.

Open terminal as root user:

rj@funtoo ~ $ sudo rc-config restart hostname
Restarting init script
 * WARNING: you are stopping a boot service
 * Caching service dependencies ...                                       [ ok ]
 * Stopping fcron ...                                                     [ ok ]
 * Configuring /etc/hosts ...                                             [ ok ]
 * Setting hostname to damian ...                                         [ ok ]


rj@funtoo ~ $ cat /etc/hosts

127.0.0.1	damian localhost localhost.localdomain
::1		damian localhost localhost.localdomain

Share this post


Link to post
Share on other sites
  • 0

 Thanks Cardinal, about the bug when booting in the web page you sent 

https://bugs.funtoo.org/browse/FL-3139 

they mention something about a patch, how do i use the patch?

Thank you a lot Cardinal you always help me! 

Share this post


Link to post
Share on other sites
  • 0

Go to https://553978.bugs.gentoo.org/attachment.cgi?id=414754 in firefox.

File/Save Page As/printf_write_error_workaround_through_delay.patch

I use default save location ~/Downloads

Open terminal :

sudo mkdir -p /etc/portage/patches/sys-apps/openrc-0.18.3-r2
sudo cp ~/Downloads/printf_write_error_workaround_through_delay.patch /etc/portage/patches/sys-apps/openrc-0.18.3-r2
sudo emerge -1av openrc
Confirmation patching was successful:

>>> Preparing source in /var/tmp/portage/sys-apps/openrc-0.18.3-r2/work/openrc-0.18.3 ...
 * Applying user patches from /etc/portage/patches//sys-apps/openrc-0.18.3-r2 ...
 *   printf_write_error_workaround_through_delay.patch ...                                                                                            [ ok ]
 * Done with patching

Share this post


Link to post
Share on other sites
  • 0

 

I noticed the same output. After the initial shock of trying to 'fix' it, I settled on the idea that the new output is a new normal. You don't have your computer on the Internet, so the domain of your hostname is quite unknown. I don't think that is a problem. Maybe one of the developers forgot to configure the domain on his computer and created the message which is not so pertinent to many of us. I notice the same thing every time I stop Xwindows. The last message is (I think) a spurious problem with my xscreensaver:

 

 

xscreensaver: 13:03:25: .(II)Can't open display: :0.0
Server terminated successfully (0). Closing log file.
xscreensaver: 13:03:27: running as me/me (1000/1000)

xscreensaver: 13:03:27: Errors at startup are usually authorization problems.
But you're not logging in as root (good!) so something
else must be wrong. Did you read the manual and the FAQ?

https://www.jwz.org/xscreensaver/faq.html
https://www.jwz.org/xscreensaver/man.html

 

 

These guys make this stuff for the passion of it. It beats being made what to do by Windows.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×