Jump to content

Photo

vlc flag conflict

- - - - - vlc flags USE

4 replies to this topic

#1
kayvax

kayvax

    Member

  • Members
  • PipPip
  • 10 posts

Hi all!

I am having some problem with USE flags for vlc after todays sync.



These are the packages that would be merged, in order:

Calculating dependencies -

!!! Problem resolving dependencies for media-video/vlc from @selected ... done!

!!! The ebuild selected to satisfy "media-video/vlc" has unmet requirements.
- media-video/vlc-2.2.0::gentoo USE="X a52 aalib alsa avcodec avformat bidi bluray cdda dbus dts dvb dvbpsi dvd encode ffmpeg flac fontconfig gcrypt gnutls httpd jack jpeg libass libcaca libnotify libsamplerate libtar live lua matroska modplug mp3 mpeg mtp musepack ncurses ogg opengl optimisememory png pulseaudio qt4 rtsp schroedinger skins svg swscale theora truetype udev vaapi vdpau vlm vorbis x264 xcb xml xv (-altivec) -atmo (-audioqueue) -avahi -cddb -chromaprint -dc1394 -debug -directfb (-directx) (-dxva2) -faad -fdk -fluidsynth -gme -gnome -growl -ieee1394 -kate -kde (-libav) -libtiger -linsys -lirc (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-media-library) (-neon) -omxil -opencv -opus -oss -postproc -projectm -qt5 -rdp -run-as-root -samba -sdl -sdl-image -sftp -shout -sid -speex -taglib -test -tremor -twolame -upnp -v4l -vcdx -vnc -vpx -wma-fixed -x265 -zvbi" CPU_FLAGS_X86="mmx sse"

The following REQUIRED_USE flag constraints are unsatisfied:
ffmpeg? ( !libav? ( postproc ) )

The above constraints are a subset of the following complete expression:
aalib? ( X ) bidi? ( truetype ) cddb? ( cdda ) dvb? ( dvbpsi ) dxva2? ( avcodec ) ffmpeg? ( avcodec avformat swscale !libav? ( postproc ) ) fontconfig? ( truetype ) gnutls? ( gcrypt ) httpd? ( lua ) libcaca? ( X ) libtar? ( skins ) libtiger? ( kate ) qt4? ( X !qt5 ) qt5? ( X !qt4 ) sdl? ( X ) skins? ( truetype X exactly-one-of ( qt4 qt5 ) ) vaapi? ( avcodec X ) vlm? ( encode ) xv? ( xcb )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

I have set make.conf USE with -libav but no avail, same with package.use setiing. Also there was some eselect-news discussed here: https://forums.gento...hlight-vlc.html but I have not seen this in Funtoo's eselect-news. 

 

 

Here are my global USE flags:



USE="infinality mmx sse sse2 sse3 ssse3 sse4 sse4a sse4_1 alsa consolekit cups dbus jack pam policykit udev X opengl nss unicode nls -bluetooth git subversion icu truetype type1 corefonts pulseaudio cleartype networkmanager -libav"

And vlc use flags:



media-video/vlc X a52 aac aalib alsa bidi blueray bluray cdda cdio dbus dirac directx dshow dts dvb dvd ffmpeg flac fontconfig freetype gnutls hal httpd id3tag libass libcaca libnotify libsamplerate libtar live lua mad matroska media-library mmx modplug mp3 mpeg mtp musepack nsplugin ogg oggvorbis opengl optimisememory png rtsp schroedinger skins sse stream svg svga theora truetype vaapi vcd vdpau vlm vorbis win32codecs wxwindows x264 xml xv 

I would appreciate help in resolving this issue.

 

Best regards!

 

 

Also my Opera seems to show forums.funtoo.org blacklisted as source of malicious software.

 

 

@20:51 2015-03-05

Adding postproc to vlc USE flags solved my issue.

Best regards.


  • aligurs likes this

#2
aligurs

aligurs

    Newbie

  • Members
  • Pip
  • 1 posts

Thanks for posting your solution...

I was faced with the same issue today, but I had incorrectly assumed that "postproc" was an internal directive of some sort rather than a use flag.

Adding postproc as a use  flag for vlc  in package.use worked like a charm!



#3
adessemond

adessemond

    Member

  • Members
  • PipPip
  • 19 posts

VLC 2.2.0 has several problems here => http://forums.funtoo...22-forking-vlc/



#4
aryvandaar

aryvandaar

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts
  • LocationNorway

The following REQUIRED_USE flag constraints are unsatisfied:
ffmpeg? ( !libav? ( postproc ) )

 

This means that if you have the ffmpeg use flag, you need the libav flag, if you have the libav flag you need the post proc flag. In other words, you need to add libav in your make.conf and postproc in package.use, or both in package.use. 


"Loyalty above all else except honour."

Desktop: Funtoo Plasma

Laptop: Windows 8


#5
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 345 posts

this issue has been resolved since 11.3.15. by removing erroneous USE requirement. Should not happen


www.funtoo.org



Reply to this topic



  



Also tagged with one or more of these keywords: vlc, flags, USE

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users