Jump to content

Photo

Emerging biber requires to downgrade Perl


13 replies to this topic

#1
NikosAlexandris

NikosAlexandris

    Advanced Member

  • Members
  • PipPipPip
  • 56 posts
  • LocationSwitzerland

First,

eix-sync

Then, I am trying to emerge `biber`. It is required, along `biblatex` for compiling bibliographies for LaTeX documents.

emerge -av biber
These are the packages that would be merged, in order:
Calculating dependencies... done!
[ebuild  N     ] dev-perl/Date-Simple-3.30.0-r1::gentoo  23 KiB
[ebuild  N    ~] dev-perl/Text-Roman-3.500.0::gentoo  18 KiB
[ebuild  N     ] dev-perl/Data-Dump-1.230.0::gentoo  21 KiB
[ebuild  N     ] dev-perl/Regexp-Common-2013031301.0.0::gentoo  114 KiB
[ebuild  N     ] dev-perl/XML-Writer-0.625.0::gentoo  USE="{-test}" 29 KiB
[ebuild  N    ~] dev-perl/Business-ISSN-0.910.0-r1::gentoo  USE="{-test}" 5 KiB
[ebuild  N     ] dev-perl/Sub-Name-0.50.0-r1::gentoo  4 KiB
[ebuild  N     ] dev-perl/File-Slurp-9999.190.0-r1::gentoo  39 KiB
[ebuild  N     ] dev-perl/MIME-Charset-1.9.3::gentoo  50 KiB
[ebuild  N     ] dev-perl/Number-Compare-0.30.0-r1::gentoo  3 KiB
[ebuild  N     ] dev-perl/Class-Accessor-0.340.0-r1::gentoo  13 KiB
[ebuild     UD ] dev-lang/perl-5.22.2:0/5.22::gentoo [5.24.0-r2:0/5.24::gentoo] USE="berkdb gdbm ithreads
-debug -doc" 0 KiB
[ebuild  N     ] perl-core/Encode-2.730.0::gentoo  0 KiB
[ebuild  N     ] virtual/perl-XSLoader-0.200.0-r2::gentoo  0 KiB
[ebuild  N     ] virtual/perl-CPAN-Meta-YAML-0.12.0-r2::gentoo  0 KiB
[ebuild  N     ] virtual/perl-IPC-Cmd-0.920.0-r5::gentoo  0 KiB
[ebuild  N     ] virtual/perl-CPAN-Meta-Requirements-2.132.0-r1::gentoo  0 KiB
[ebuild  N     ] perl-core/File-Path-2.90.0::gentoo  21 KiB
[ebuild  N     ] virtual/perl-Math-BigInt-1.999.700-r1::gentoo  0 KiB
[ebuild  N    ~] virtual/perl-Unicode-Collate-1.140.0-r2::gentoo  0 KiB
[ebuild  N    ~] virtual/perl-Unicode-Normalize-1.250.0-r2::gentoo  0 KiB
[ebuild  N     ] dev-perl/Capture-Tiny-0.360.0::gentoo  USE="{-test}" 36 KiB
[ebuild  N     ] virtual/perl-File-Path-2.90.0-r4::gentoo  0 KiB
[ebuild  N     ] dev-perl/IPC-Run3-0.48.0::gentoo  USE="{-test}" 20 KiB
[ebuild  N     ] dev-perl/autovivification-0.160.0::gentoo  49 KiB
[ebuild  N     ] dev-perl/Data-Uniqid-0.120.0-r1::gentoo  3 KiB
[ebuild  N    ~] dev-perl/Lingua-Translit-0.250.0::gentoo  385 KiB
[ebuild  N    ~] dev-perl/File-Slurp-Tiny-0.4.0::gentoo  USE="{-test}" 13 KiB
[ebuild  N     ] dev-perl/Exporter-Tiny-0.42.0::gentoo  USE="{-test}" 32 KiB
[ebuild  N    ~] dev-perl/Tie-Cycle-1.221.0::gentoo  USE="{-test}" 10 KiB
[ebuild  N    ~] dev-perl/Business-ISBN-Data-20140910.3.0::gentoo  USE="{-test}" 21 KiB
[ebuild  N     ] perl-core/CPAN-Meta-2.150.1::gentoo  USE="{-test}" 98 KiB
[ebuild  N     ] dev-perl/List-MoreUtils-0.413.0::gentoo  USE="{-test}" 129 KiB
[ebuild  N    ~] dev-perl/Config-AutoConf-0.313.0::gentoo  USE="{-test}" 48 KiB
[ebuild  N    ~] dev-perl/Business-ISBN-2.90.200_rc::gentoo  USE="-barcode {-test} -xisbn" 354 KiB
[ebuild  N    ~] dev-perl/Business-ISMN-1.130.0::gentoo  USE="{-test}" 10 KiB
[ebuild  N    ~] dev-perl/Encode-JIS2K-0.30.0::gentoo  410 KiB
[ebuild  N    ~] dev-perl/Encode-HanExtra-0.230.0-r1::gentoo  1,530 KiB
[ebuild  N    ~] dev-perl/Encode-EUCJPASCII-0.30.0::gentoo  129 KiB
[ebuild  N     ] dev-perl/Unicode-LineBreak-2016.3.0::gentoo  297 KiB
[ebuild  N     ] dev-perl/Log-Log4perl-1.460.0::gentoo  USE="{-test}" 272 KiB
[ebuild  N     ] dev-perl/List-AllUtils-0.90.0::gentoo  USE="{-test}" 19 KiB
[ebuild  N     ] dev-perl/Readonly-2.0.0::gentoo  USE="{-test}" 24 KiB
[ebuild  N    ~] dev-perl/File-Slurp-Unicode-0.7.1-r1::gentoo  4 KiB
[ebuild  N    ~] dev-perl/ExtUtils-LibBuilder-0.80.0::gentoo  USE="{-test}" 6 KiB
[ebuild  N     ] dev-perl/Text-Glob-0.90.0-r1::gentoo  5 KiB
[ebuild  N    ~] dev-perl/Readonly-XS-1.50.0-r1::gentoo  9 KiB
[ebuild  N    ~] dev-perl/Text-BibTeX-0.770.0::gentoo  289 KiB
[ebuild  N     ] dev-perl/File-Find-Rule-0.330.0-r1::gentoo  USE="{-test}" 15 KiB
[ebuild  N     ] dev-perl/Data-Compare-1.250.0::gentoo  USE="{-test}" 26 KiB
[ebuild  N     ] dev-perl/XML-LibXSLT-1.940.0::gentoo  112 KiB
[ebuild  N    ~] dev-perl/XML-LibXML-Simple-0.970.0::gentoo  USE="{-test}" 23 KiB
[ebuild  N     ] dev-tex/biber-2.5::gentoo  USE="-doc {-test}" 1,219 KiB
Total: 53 packages (1 downgrade, 52 new), Size of downloads: 5,917 KiB
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:
dev-lang/perl:0
  (dev-lang/perl-5.24.0-r2:0/5.24::gentoo, installed) pulled in by
    =dev-lang/perl-5.24* required by (virtual/perl-Text-ParseWords-3.300.0-r2:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Digest-Perl-MD5-1.900.0:0/0::gentoo, installed)
                 ^^^^^^^^
    (and 79 more with the same problems)
  (dev-lang/perl-5.22.2:0/5.22::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/perl:0/5.22= required by (virtual/perl-Storable-2.530.100-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22.2* required by (virtual/perl-ExtUtils-MakeMaker-7.40.100_rc-r2:0/0::gentoo, installed)
    ^              ^^^^^^^
    (and 55 more with the same problems)
NOTE: Use the '--verbose-conflicts' option to display parents omitted above
It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.
For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

It is asked to downgrade to `perl=5.22.2`. Why?

 

I tried to upgrade one or two of the packages before realising the list is really long:

emerge -av biber --verbose-conflicts

[..]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.24.0-r2:0/5.24::gentoo, installed) pulled in by
    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/HTTP-Daemon-6.10.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Types-Serialiser-1.0.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/XML-SAX-Base-1.80.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/HTML-Parser-3.710.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/XML-Simple-2.200.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-Exporter-5.720.0-r2:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Error-0.170.240:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Digest-SHA1-2.130.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-Time-Local-1.230.0-r4:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/XML-LibXML-2.12.100:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/XML-Parser-2.440.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/JSON-XS-3.10.0:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.24.0* required by (virtual/perl-JSON-PP-2.273.0-r4:0/0::gentoo, installed)
    ^              ^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/HTTP-Cookies-6.10.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Date-Manip-6.510.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/HTTP-Date-6.20.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (sys-apps/texinfo-6.3:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-Unicode-Normalize-1.250.0-r2:0/0::gentoo, ebuild schedu
led for merge)
    ^              ^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/File-Which-1.90.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Unicode-Map-0.112.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-Digest-MD5-2.540.0-r2:0/0::gentoo, installed)
    ^              ^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-Text-ParseWords-3.300.0-r2:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.24= required by (dev-perl/DBI-1.636.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Digest-HMAC-1.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (dev-perl/Net-HTTP-6.90.0:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.24.0* required by (virtual/perl-Digest-1.170.0-r9:0/0::gentoo, installed)
    ^              ^^^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-Test-Simple-1.1.14_p522-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/IO-HTML-1.1.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Authen-SASL-2.160.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (dev-perl/AnyEvent-7.120.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Digest-Perl-MD5-1.900.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/IO-stringy-2.111.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (dev-perl/Net-SSLeay-1.720.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (dev-perl/DBD-mysql-4.41.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/libintl-perl-1.240.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Encode-Locale-1.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (net-irc/irssi-1.0.3:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/OLE-StorageLite-0.190.0-r1:0/0::gentoo, install
ed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (dev-perl/HTTP-Message-6.110.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-tex/html2latex-1.1-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (x11-terms/rxvt-unicode-9.21:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-ExtUtils-Install-2.40.0-r2:0/0::gentoo, installed)
    ^              ^^^^^

    =dev-lang/perl-5.24.0* required by (virtual/perl-IPC-Cmd-0.920.0-r5:0/0::gentoo, ebuild scheduled for
merge)
    ^              ^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Text-Unidecode-1.270.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Crypt-PasswdMD5-1.400.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-ExtUtils-Manifest-1.700.0-r3:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Spreadsheet-ParseExcel-0.650.0:0/0::gentoo, ins
talled)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/IO-Socket-SSL-2.24.0:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.24.0* required by (virtual/perl-Storable-2.560.0-r2:0/0::gentoo, installed)
    ^              ^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-vcs/git-2.11.1-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (virtual/perl-ExtUtils-MakeMaker-7.100.100_rc-r2:0/0::gentoo, instal
led)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (dev-perl/Module-Build-0.421.600:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (virtual/perl-Carp-1.400.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/libwww-perl-6.150.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (virtual/perl-Module-Metadata-1.0.26-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Algorithm-Diff-1.190.300:0/0::gentoo, installed
)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (virtual/perl-File-Temp-0.230.400-r5:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Net-SMTP-SSL-1.30.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/File-DesktopEntry-0.40.0-r1:0/0::gentoo, instal
led)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/LWP-Protocol-https-6.60.0:0/0::gentoo, installe
d)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/File-Listing-6.40.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/File-BaseDir-0.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (dev-vcs/subversion-1.9.5:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-Unicode-Collate-1.140.0-r2:0/0::gentoo, ebuild schedule
d for merge)
    ^              ^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Unicode-EastAsianWidth-1.330.0-r1:0/0::gentoo,
installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/File-MimeInfo-0.270.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/TermReadKey-2.330.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (virtual/perl-Storable-2.560.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/AnyEvent-I3-0.160.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (virtual/perl-Encode-2.730.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.24.0* required by (virtual/perl-Digest-SHA-5.950.0-r4:0/0::gentoo, installed)
    ^              ^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/Crypt-RC4-2.020.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24= required by (dev-perl/URI-1.710.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.10.0:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-Carp-1.400.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    =dev-lang/perl-5.24.0* required by (virtual/perl-ExtUtils-MakeMaker-7.100.100_rc-r2:0/0::gentoo, insta
lled)
    ^              ^^^^^^^

    dev-lang/perl:0/5.24= required by (dev-perl/Text-CSV_XS-1.230.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/XML-NamespaceSupport-1.110.0-r1:0/0::gentoo, in
stalled)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/LWP-MediaTypes-6.20.0-r1:0/0::gentoo, installed
)
                 ^^^^^^^^

    =dev-lang/perl-5.24.0* required by (virtual/perl-Sys-Syslog-0.330.0-r6:0/0::gentoo, installed)
    ^              ^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/common-sense-3.740.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/HTML-Tagset-3.200.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^


  (dev-lang/perl-5.22.2:0/5.22::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.22* required by (virtual/perl-Data-Dumper-2.158.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Compress-Raw-Bzip2-2.68.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Perl-OSType-1.8.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Perl-OSType-1.8.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-CPAN-Meta-Requirements-2.132.0-r1:0/0::gentoo, ebuild s
cheduled for merge)
    ^              ^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-parent-0.232.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Compress-Raw-Zlib-2.68.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-ExtUtils-Install-2.40.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Getopt-Long-2.450.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-ExtUtils-Manifest-1.700.0-r3:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Data-Dumper-2.158.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Test-Harness-3.350.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-ExtUtils-CBuilder-0.280.221-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Compress-Raw-Zlib-2.68.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Digest-SHA-5.950.0-r4:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-File-Spec-3.560.100-r1:0/0::gentoo, installed)
    ^              ^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Module-Metadata-1.0.26-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Text-ParseWords-3.300.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-libnet-3.50.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Term-ANSIColor-4.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Math-BigInt-1.999.700-r1:0/0::gentoo, ebuild scheduled
for merge)
    ^              ^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Scalar-List-Utils-1.410.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Parse-CPAN-Meta-1.441.400-r3:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Sys-Syslog-0.330.0-r6:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-ExtUtils-ParseXS-3.280.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-parent-0.232.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Scalar-List-Utils-1.410.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Test-Simple-1.1.14_p522-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-IO-Compress-2.68.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-IO-1.350.0-r2:0/0::gentoo, installed)
    ^              ^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-ExtUtils-CBuilder-0.280.221-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-libnet-3.50.0-r2:0/0::gentoo, installed)
    ^              ^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-Parse-CPAN-Meta-1.441.400-r3:0/0::gentoo, installed)
    ^              ^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Term-ANSIColor-4.30.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Digest-1.170.0-r9:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-IO-1.350.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-IO-Compress-2.68.0-r2:0/0::gentoo, installed)
    ^              ^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Time-HiRes-1.972.600-r3:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Time-Local-1.230.0-r4:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Exporter-5.720.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-Getopt-Long-2.450.0-r1:0/0::gentoo, installed)
    ^              ^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-ExtUtils-ParseXS-3.280.0-r1:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Digest-MD5-2.540.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-version-0.990.900-r3:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-CPAN-Meta-2.150.1-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-File-Spec-3.560.100-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-CPAN-Meta-YAML-0.12.0-r2:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-version-0.990.900-r3:0/0::gentoo, installed)
    ^              ^^^^^
    =dev-lang/perl-5.22.2* required by (virtual/perl-XSLoader-0.200.0-r2:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Compress-Raw-Bzip2-2.68.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-JSON-PP-2.273.0-r4:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-Time-HiRes-1.972.600-r3:0/0::gentoo, installed)
    ^              ^^^^^
    =dev-lang/perl-5.22.2* required by (virtual/perl-Test-Harness-3.350.0-r2:0/0::gentoo, installed)
    ^              ^^^^^^^


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

Nikos Alexandris | Remote Sensing *
GPG Key Fingerprint 6F9D4506F3CA28380974D31A9053534B693C4FB3


#2
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 359 posts

paste output of:

grep -rE '(perl|biber)' /etc/portage


www.funtoo.org

#3
NikosAlexandris

NikosAlexandris

    Advanced Member

  • Members
  • PipPipPip
  • 56 posts
  • LocationSwitzerland

paste output of:

grep -rE '(perl|biber)' /etc/portage

grep -rE '(perl|biber)' /etc/portage
/etc/portage/backup_package.accept_keywords:# required by sooperlooper (argument)
/etc/portage/backup_package.accept_keywords:=media-sound/sooperlooper-1.7.3-r1 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/Readonly-XS-1.50.0-r1 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-perl/Text-BibTeX-0.770.0::gentoo
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/Config-AutoConf-0.313.0 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/Text-Roman-3.500.0 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/Business-ISBN-2.90.200_rc ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-perl/Business-ISMN-1.130.0::gentoo
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/Tie-Cycle-1.221.0 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/XML-LibXML-Simple-0.970.0 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=virtual/perl-Unicode-Collate-1.140.0-r2 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/Encode-EUCJPASCII-0.30.0 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/Business-ISMN-1.130.0 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/Lingua-Translit-0.250.0 ~amd64
/etc/portage/backup_package.accept_keywords:# required by virtual/perl-ExtUtils-Manifest-1.700.0-r3::gentoo
/etc/portage/backup_package.accept_keywords:# required by dev-perl/Module-Build-0.421.600::gentoo
/etc/portage/backup_package.accept_keywords:# required by dev-perl/Text-Glob-0.90.0-r1::gentoo
/etc/portage/backup_package.accept_keywords:# required by dev-perl/File-Find-Rule-0.330.0-r1::gentoo
/etc/portage/backup_package.accept_keywords:# required by dev-perl/Data-Compare-1.250.0::gentoo
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-lang/perl-5.24.0-r2 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/Encode-HanExtra-0.230.0-r1 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-perl/Text-BibTeX-0.770.0::gentoo
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/ExtUtils-LibBuilder-0.80.0 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-perl/XML-LibXML-Simple-0.970.0::gentoo
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/File-Slurp-Tiny-0.4.0 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/Encode-JIS2K-0.30.0 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/Text-BibTeX-0.770.0 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/File-Slurp-Unicode-0.7.1-r1 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=virtual/perl-Unicode-Normalize-1.250.0-r2 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-perl/Business-ISBN-2.90.200_rc::gentoo
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/Business-ISBN-Data-20140910.3.0 ~amd64
/etc/portage/backup_package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/backup_package.accept_keywords:# required by biber (argument)
/etc/portage/backup_package.accept_keywords:=dev-perl/Business-ISSN-0.910.0-r1 ~amd64
/etc/portage/package.use:# required by dev-vcs/git-2.7.3-r1::gentoo[subversion,perl]
/etc/portage/package.use:>=dev-vcs/subversion-1.9.4 -dso perl
/etc/portage/package.use:# required by dev-vcs/git-2.7.3-r1::gentoo[subversion,perl]
/etc/portage/package.use:# required by dev-vcs/git-2.7.3-r1::gentoo[subversion,perl]
/etc/portage/package.accept_keywords:# required by sooperlooper (argument)
/etc/portage/package.accept_keywords:=media-sound/sooperlooper-1.7.3-r1 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/Readonly-XS-1.50.0-r1 ~amd64
/etc/portage/package.accept_keywords:# required by dev-perl/Text-BibTeX-0.770.0::gentoo
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/Config-AutoConf-0.313.0 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/Text-Roman-3.500.0 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/Business-ISBN-2.90.200_rc ~amd64
/etc/portage/package.accept_keywords:# required by dev-perl/Business-ISMN-1.130.0::gentoo
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/Tie-Cycle-1.221.0 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/XML-LibXML-Simple-0.970.0 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=virtual/perl-Unicode-Collate-1.140.0-r2 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/Encode-EUCJPASCII-0.30.0 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/Business-ISMN-1.130.0 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/Lingua-Translit-0.250.0 ~amd64
/etc/portage/package.accept_keywords:# required by virtual/perl-ExtUtils-Manifest-1.700.0-r3::gentoo
/etc/portage/package.accept_keywords:# required by dev-perl/Module-Build-0.421.600::gentoo
/etc/portage/package.accept_keywords:# required by dev-perl/Text-Glob-0.90.0-r1::gentoo
/etc/portage/package.accept_keywords:# required by dev-perl/File-Find-Rule-0.330.0-r1::gentoo
/etc/portage/package.accept_keywords:# required by dev-perl/Data-Compare-1.250.0::gentoo
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-lang/perl-5.24.0-r2 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/Encode-HanExtra-0.230.0-r1 ~amd64
/etc/portage/package.accept_keywords:# required by dev-perl/Text-BibTeX-0.770.0::gentoo
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/ExtUtils-LibBuilder-0.80.0 ~amd64
/etc/portage/package.accept_keywords:# required by dev-perl/XML-LibXML-Simple-0.970.0::gentoo
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/File-Slurp-Tiny-0.4.0 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/Encode-JIS2K-0.30.0 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/Text-BibTeX-0.770.0 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/File-Slurp-Unicode-0.7.1-r1 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=virtual/perl-Unicode-Normalize-1.250.0-r2 ~amd64
/etc/portage/package.accept_keywords:# required by dev-perl/Business-ISBN-2.90.200_rc::gentoo
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/Business-ISBN-Data-20140910.3.0 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.5::gentoo
/etc/portage/package.accept_keywords:# required by biber (argument)
/etc/portage/package.accept_keywords:=dev-perl/Business-ISSN-0.910.0-r1 ~amd64
/etc/portage/package.accept_keywords:# required by =dev-tex/biber-2.7 (argument)
/etc/portage/package.accept_keywords:=dev-tex/biber-2.7 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.7::gentoo
/etc/portage/package.accept_keywords:# required by dev-tex/biblatex-3.7-r1::gentoo[biber]
/etc/portage/package.accept_keywords:=dev-perl/DateTime-Calendar-Julian-0.40.0 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.7::gentoo
/etc/portage/package.accept_keywords:# required by dev-tex/biblatex-3.7-r1::gentoo[biber]
/etc/portage/package.accept_keywords:=dev-perl/Sort-Key-1.330.0 ~amd64
/etc/portage/package.accept_keywords:# required by dev-tex/biber-2.7::gentoo
/etc/portage/package.accept_keywords:# required by =dev-tex/biber-2.7 (argument)
/etc/portage/package.accept_keywords:# required by =virtual/perl-Carp-1.400.0-r1 (argument)
/etc/portage/package.accept_keywords:=virtual/perl-Carp-1.400.0-r1 ~amd64
/etc/portage/package.accept_keywords:# required by =virtual/perl-Storable-2.560.0-r2 (argument)
/etc/portage/package.accept_keywords:=virtual/perl-Storable-2.560.0-r2 ~amd64
/etc/portage/package.accept_keywords:# required by =virtual/perl-ExtUtils-MakeMaker-7.100.100_rc-r2 (argument)
/etc/portage/package.accept_keywords:=virtual/perl-ExtUtils-MakeMaker-7.100.100_rc-r2 ~amd64


Nikos Alexandris | Remote Sensing *
GPG Key Fingerprint 6F9D4506F3CA28380974D31A9053534B693C4FB3


#4
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 359 posts

ok so you using stable and there are bunch of ebuilds with unstable keywords added. please, move /etc/portage/package.accept_keywords to /etc/portage/package.accept_keywords.backup and paste output of 

emerge -pvt dev-tex/biber


www.funtoo.org

#5
NikosAlexandris

NikosAlexandris

    Advanced Member

  • Members
  • PipPipPip
  • 56 posts
  • LocationSwitzerland

Yes, I use stable. And, indeed, at the same time, I have recent versions of various stuff installed.

 

By the way, like others, me too, I am a (prime) candidate for kits (http://www.funtoo.or...7_tree_and_Kits).

 

Here the output, after (re-)moving `package.accept_keywords` from being present for portage:

emerge -pvt dev-tex/biber

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild  N     ] dev-tex/biber-2.5::gentoo  USE="-doc {-test}" 1,219 KiB
[ebuild  N    ~]  dev-perl/XML-LibXML-Simple-0.970.0::gentoo  USE="{-test}" 23 KiB
[ebuild  N     ]  dev-perl/XML-LibXSLT-1.940.0::gentoo  112 KiB
[ebuild  N     ]  dev-perl/Data-Compare-1.250.0::gentoo  USE="{-test}" 26 KiB
[ebuild  N     ]   dev-perl/File-Find-Rule-0.330.0-r1::gentoo  USE="{-test}" 15 KiB
[ebuild  N     ]    dev-perl/Text-Glob-0.90.0-r1::gentoo  5 KiB
[ebuild  N    ~]  dev-perl/Text-BibTeX-0.770.0::gentoo  289 KiB
[ebuild  N    ~]   dev-perl/ExtUtils-LibBuilder-0.80.0::gentoo  USE="{-test}" 6 KiB
[ebuild  N    ~]  dev-perl/File-Slurp-Unicode-0.7.1-r1::gentoo  4 KiB
[ebuild  N    ~]  dev-perl/Readonly-XS-1.50.0-r1::gentoo  9 KiB
[ebuild  N     ]   dev-perl/Readonly-2.0.0::gentoo  USE="{-test}" 24 KiB
[ebuild  N    ~]  virtual/perl-Unicode-Normalize-1.250.0-r2::gentoo  0 KiB
[ebuild  N    ~]  virtual/perl-Unicode-Collate-1.140.0-r2::gentoo  0 KiB
[ebuild  N     ]  dev-perl/Log-Log4perl-1.460.0::gentoo  USE="{-test}" 272 KiB
[ebuild  N     ]  dev-perl/List-AllUtils-0.90.0::gentoo  USE="{-test}" 19 KiB
[ebuild  N     ]   dev-perl/List-MoreUtils-0.413.0::gentoo  USE="{-test}" 129 KiB
[ebuild  N     ]    virtual/perl-File-Path-2.90.0-r4::gentoo  0 KiB
[ebuild  N     ]     perl-core/File-Path-2.90.0::gentoo  21 KiB
[nomerge       ] dev-tex/biber-2.5::gentoo  USE="-doc {-test}"
[nomerge       ]  dev-perl/Module-Build-0.421.600::gentoo  USE="{-test}"
[nomerge       ]   virtual/perl-CPAN-Meta-2.150.1-r1::gentoo
[ebuild  N     ]    perl-core/CPAN-Meta-2.150.1::gentoo  USE="{-test}" 98 KiB
[ebuild  N     ]     virtual/perl-CPAN-Meta-Requirements-2.132.0-r1::gentoo  0 KiB
[ebuild  N     ]  dev-perl/Data-Uniqid-0.120.0-r1::gentoo  3 KiB
[ebuild  N     ]   virtual/perl-Math-BigInt-1.999.700-r1::gentoo  0 KiB
[ebuild  N     ]  dev-perl/autovivification-0.160.0::gentoo  49 KiB
[nomerge       ] dev-tex/biber-2.5::gentoo  USE="-doc {-test}"
[nomerge       ]  dev-perl/List-MoreUtils-0.413.0::gentoo  USE="{-test}"
[ebuild  N     ]   dev-perl/Exporter-Tiny-0.42.0::gentoo  USE="{-test}" 32 KiB
[ebuild  N    ~]  dev-perl/Business-ISMN-1.130.0::gentoo  USE="{-test}" 10 KiB
[ebuild  N    ~]   dev-perl/Tie-Cycle-1.221.0::gentoo  USE="{-test}" 10 KiB
[ebuild  N    ~]  dev-perl/Business-ISBN-2.90.200_rc::gentoo  USE="-barcode {-test} -xisbn" 354 KiB
[ebuild  N    ~]   dev-perl/Business-ISBN-Data-20140910.3.0::gentoo  USE="{-test}" 21 KiB
[nomerge       ] dev-perl/XML-LibXML-Simple-0.970.0::gentoo  USE="{-test}"
[ebuild  N    ~]  dev-perl/File-Slurp-Tiny-0.4.0::gentoo  USE="{-test}" 13 KiB
[nomerge       ] dev-tex/biber-2.5::gentoo  USE="-doc {-test}"
[ebuild  N     ]  dev-perl/Unicode-LineBreak-2016.3.0::gentoo  297 KiB
[ebuild  N    ~]  dev-perl/Encode-EUCJPASCII-0.30.0::gentoo  129 KiB
[ebuild  N    ~]  dev-perl/Encode-HanExtra-0.230.0-r1::gentoo  1,530 KiB
[ebuild  N    ~]  dev-perl/Lingua-Translit-0.250.0::gentoo  385 KiB
[ebuild  N    ~]  dev-perl/Encode-JIS2K-0.30.0::gentoo  410 KiB
[ebuild  N     ]  dev-perl/IPC-Run3-0.48.0::gentoo  USE="{-test}" 20 KiB
[ebuild  N     ]  virtual/perl-IPC-Cmd-0.920.0-r5::gentoo  0 KiB
[nomerge       ] perl-core/CPAN-Meta-2.150.1::gentoo  USE="{-test}"
[ebuild  N     ]  virtual/perl-CPAN-Meta-YAML-0.12.0-r2::gentoo  0 KiB
[nomerge       ] dev-perl/autovivification-0.160.0::gentoo
[ebuild  N     ]  virtual/perl-XSLoader-0.200.0-r2::gentoo  0 KiB
[nomerge       ] dev-tex/biber-2.5::gentoo  USE="-doc {-test}"
[ebuild  N    ~]  dev-perl/Config-AutoConf-0.313.0::gentoo  USE="{-test}" 48 KiB
[ebuild  N     ]   dev-perl/Capture-Tiny-0.360.0::gentoo  USE="{-test}" 36 KiB
[nomerge       ] app-portage/genlop-0.30.10::gentoo
[nomerge       ]  dev-perl/Date-Manip-6.510.0::gentoo  USE="{-test}"
[nomerge       ]   virtual/perl-Encode-2.730.0-r1::gentoo
[ebuild  N     ]    perl-core/Encode-2.730.0::gentoo  0 KiB
[ebuild     UD ]     dev-lang/perl-5.22.2:0/5.22::gentoo [5.24.0-r2:0/5.24::gentoo] USE="berkdb gdbm ithre
ads -debug -doc" 0 KiB
[nomerge       ] dev-perl/File-Find-Rule-0.330.0-r1::gentoo  USE="{-test}"
[ebuild  N     ]  dev-perl/Number-Compare-0.30.0-r1::gentoo  3 KiB
[nomerge       ] dev-perl/Unicode-LineBreak-2016.3.0::gentoo
[ebuild  N     ]  dev-perl/MIME-Charset-1.9.3::gentoo  50 KiB
[nomerge       ] dev-perl/File-Slurp-Unicode-0.7.1-r1::gentoo
[ebuild  N     ]  dev-perl/File-Slurp-9999.190.0-r1::gentoo  39 KiB
[nomerge       ] dev-tex/biber-2.5::gentoo  USE="-doc {-test}"
[ebuild  N     ]  dev-perl/Class-Accessor-0.340.0-r1::gentoo  13 KiB
[ebuild  N     ]   dev-perl/Sub-Name-0.50.0-r1::gentoo  4 KiB
[ebuild  N    ~]  dev-perl/Business-ISSN-0.910.0-r1::gentoo  USE="{-test}" 5 KiB
[ebuild  N    ~]  dev-perl/Text-Roman-3.500.0::gentoo  18 KiB
[ebuild  N     ]  dev-perl/XML-Writer-0.625.0::gentoo  USE="{-test}" 29 KiB
[ebuild  N     ]  dev-perl/Regexp-Common-2013031301.0.0::gentoo  114 KiB
[ebuild  N     ]  dev-perl/Data-Dump-1.230.0::gentoo  21 KiB
[ebuild  N     ]  dev-perl/Date-Simple-3.30.0-r1::gentoo  23 KiB

Total: 53 packages (1 downgrade, 52 new), Size of downloads: 5,917 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.24.0-r2:0/5.24::gentoo, installed) pulled in by
    =dev-lang/perl-5.24* required by (virtual/perl-Text-ParseWords-3.300.0-r2:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.24= required by (virtual/perl-Storable-2.560.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    (and 83 more with the same problems)

  (dev-lang/perl-5.22.2:0/5.22::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.22* required by (virtual/perl-Compress-Raw-Zlib-2.68.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-File-Spec-3.560.100-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    (and 51 more with the same problems)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/Readonly-XS-1.50.0-r1 ~amd64
# required by dev-perl/Text-BibTeX-0.770.0::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/Config-AutoConf-0.313.0 ~amd64
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/Text-Roman-3.500.0 ~amd64
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/Business-ISBN-2.90.200_rc ~amd64
# required by dev-perl/Business-ISMN-1.130.0::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/Tie-Cycle-1.221.0 ~amd64
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/XML-LibXML-Simple-0.970.0 ~amd64
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=virtual/perl-Unicode-Collate-1.140.0-r2 ~amd64
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/Encode-EUCJPASCII-0.30.0 ~amd64
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/Business-ISMN-1.130.0 ~amd64
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/Lingua-Translit-0.250.0 ~amd64
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/Encode-HanExtra-0.230.0-r1 ~amd64
# required by dev-perl/Text-BibTeX-0.770.0::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/ExtUtils-LibBuilder-0.80.0 ~amd64
# required by dev-perl/XML-LibXML-Simple-0.970.0::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/File-Slurp-Tiny-0.4.0 ~amd64
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/Encode-JIS2K-0.30.0 ~amd64
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/Text-BibTeX-0.770.0 ~amd64
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/File-Slurp-Unicode-0.7.1-r1 ~amd64
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=virtual/perl-Unicode-Normalize-1.250.0-r2 ~amd64
# required by dev-perl/Business-ISBN-2.90.200_rc::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/Business-ISBN-Data-20140910.3.0 ~amd64
# required by dev-tex/biber-2.5::gentoo
# required by dev-tex/biber (argument)
=dev-perl/Business-ISSN-0.910.0-r1 ~amd64

It still wants to downgrade Perl.


Nikos Alexandris | Remote Sensing *
GPG Key Fingerprint 6F9D4506F3CA28380974D31A9053534B693C4FB3


#6
NikosAlexandris

NikosAlexandris

    Advanced Member

  • Members
  • PipPipPip
  • 56 posts
  • LocationSwitzerland

Yes, I use stable. And, indeed, at the same time, I have recent versions of various stuff installed.

 

By the way, like others, me too, I am a (prime) candidate for kits (http://www.funtoo.or...7_tree_and_Kits).

 

Here the output, after (re-)moving `package.accept_keywords` from being present for portage:

emerge -pvt dev-tex/biber

[..]

It still wants to downgrade Perl.

 

Meanwhile, I am re-doing `perl-cleaner --all`. Will re-post if something changes.


Nikos Alexandris | Remote Sensing *
GPG Key Fingerprint 6F9D4506F3CA28380974D31A9053534B693C4FB3


#7
NikosAlexandris

NikosAlexandris

    Advanced Member

  • Members
  • PipPipPip
  • 56 posts
  • LocationSwitzerland

And, now after cleaning Perl related material, the opposite! Upgrade to the latest Perl version.

emerge -av biber --verbose-conflicts

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] virtual/perl-XSLoader-0.200.0-r2::gentoo  0 KiB
[ebuild  N     ] virtual/perl-IPC-Cmd-0.920.0-r5::gentoo  0 KiB
[ebuild  N     ] virtual/perl-File-Path-2.90.0-r4::gentoo  0 KiB
[ebuild  N     ] dev-perl/Date-Simple-3.30.0-r1::gentoo  23 KiB
[ebuild  N    ~] dev-perl/Text-Roman-3.500.0::gentoo  18 KiB
[ebuild  N     ] dev-perl/Data-Dump-1.230.0::gentoo  21 KiB
[ebuild  N     ] dev-perl/Regexp-Common-2013031301.0.0::gentoo  114 KiB
[ebuild  N     ] dev-perl/XML-Writer-0.625.0::gentoo  USE="{-test}" 29 KiB
[ebuild  N    ~] dev-perl/Business-ISSN-0.910.0-r1::gentoo  USE="{-test}" 5 KiB
[ebuild  N     ] dev-perl/Sub-Name-0.50.0-r1::gentoo  4 KiB
[ebuild  N     ] dev-perl/MIME-Charset-1.9.3::gentoo  50 KiB
[ebuild  N     ] dev-perl/File-Slurp-9999.190.0-r1::gentoo  39 KiB
[ebuild  N     ] dev-perl/Number-Compare-0.30.0-r1::gentoo  3 KiB
[ebuild  N     ] virtual/perl-Math-BigInt-1.999.700-r1::gentoo  0 KiB
[ebuild  N     ] dev-perl/IPC-Run3-0.48.0::gentoo  USE="{-test}" 20 KiB
[ebuild  N     ] dev-perl/Data-Uniqid-0.120.0-r1::gentoo  3 KiB
[ebuild  N    ~] dev-perl/Lingua-Translit-0.250.0::gentoo  385 KiB
[ebuild  N     ] dev-perl/Log-Log4perl-1.460.0::gentoo  USE="{-test}" 272 KiB
[ebuild  N     ] dev-perl/Class-Accessor-0.340.0-r1::gentoo  13 KiB
[ebuild  N    ~] dev-perl/Business-ISBN-Data-20140910.3.0::gentoo  USE="{-test}" 21 KiB
[ebuild  N    ~] dev-perl/Tie-Cycle-1.221.0::gentoo  USE="{-test}" 10 KiB
[ebuild  N     ] dev-perl/Exporter-Tiny-0.42.0::gentoo  USE="{-test}" 32 KiB
[ebuild  N     ] dev-perl/List-MoreUtils-0.413.0::gentoo  USE="{-test}" 129 KiB
[ebuild  N    ~] dev-perl/Encode-JIS2K-0.30.0::gentoo  410 KiB
[ebuild  N    ~] dev-perl/Business-ISMN-1.130.0::gentoo  USE="{-test}" 10 KiB
[ebuild  N    ~] dev-perl/Business-ISBN-2.90.200_rc::gentoo  USE="-barcode {-test} -xisbn" 354 KiB
[ebuild  N    ~] dev-perl/Encode-HanExtra-0.230.0-r1::gentoo  1,530 KiB
[ebuild  N     ] dev-perl/Unicode-LineBreak-2016.3.0::gentoo  297 KiB
[ebuild  N    ~] dev-perl/Encode-EUCJPASCII-0.30.0::gentoo  129 KiB
[ebuild  N     ] dev-perl/List-AllUtils-0.90.0::gentoo  USE="{-test}" 19 KiB
[ebuild  N     ] dev-perl/XML-LibXSLT-1.940.0::gentoo  112 KiB
[ebuild     U ~] dev-lang/perl-5.24.0-r2:0/5.24::gentoo [5.22.2:0/5.22::gentoo] USE="berkdb gdbm ithreads -debug -doc" 0 KiB
[ebuild  N    ~] virtual/perl-Unicode-Collate-1.140.0-r2::gentoo  0 KiB
[ebuild  N    ~] virtual/perl-Unicode-Normalize-1.250.0-r2::gentoo  0 KiB
[ebuild  N     ] dev-perl/Capture-Tiny-0.360.0::gentoo  USE="{-test}" 36 KiB
[ebuild  N     ] dev-perl/autovivification-0.160.0::gentoo  49 KiB
[ebuild  N    ~] dev-perl/File-Slurp-Tiny-0.4.0::gentoo  USE="{-test}" 13 KiB
[ebuild  N    ~] dev-perl/Config-AutoConf-0.313.0::gentoo  USE="{-test}" 48 KiB
[ebuild  N    ~] dev-perl/XML-LibXML-Simple-0.970.0::gentoo  USE="{-test}" 23 KiB
[ebuild  N     ] dev-perl/Readonly-2.0.0::gentoo  USE="{-test}" 24 KiB
[ebuild  N    ~] dev-perl/File-Slurp-Unicode-0.7.1-r1::gentoo  4 KiB
[ebuild  N    ~] dev-perl/ExtUtils-LibBuilder-0.80.0::gentoo  USE="{-test}" 6 KiB
[ebuild  N     ] dev-perl/Text-Glob-0.90.0-r1::gentoo  5 KiB
[ebuild  N    ~] dev-perl/Text-BibTeX-0.770.0::gentoo  289 KiB
[ebuild  N    ~] dev-perl/Readonly-XS-1.50.0-r1::gentoo  9 KiB
[ebuild  N     ] dev-perl/File-Find-Rule-0.330.0-r1::gentoo  USE="{-test}" 15 KiB
[ebuild  N     ] dev-perl/Data-Compare-1.250.0::gentoo  USE="{-test}" 26 KiB
[ebuild  N     ] dev-tex/biber-2.5::gentoo  USE="-doc {-test}" 1,219 KiB

Total: 48 packages (1 upgrade, 47 new), Size of downloads: 5,799 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.22.2:0/5.22::gentoo, installed) pulled in by
    dev-lang/perl:0/5.22= required by (virtual/perl-parent-0.232.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/OLE-StorageLite-0.190.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (perl-core/Encode-2.730.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/libintl-perl-1.240.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Types-Serialiser-1.0.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-ExtUtils-Manifest-1.700.0-r3:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22.2* required by (virtual/perl-File-Spec-3.560.100-r1:0/0::gentoo, installed)
    ^              ^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Text-ParseWords-3.300.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (dev-perl/AnyEvent-7.120.0:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-Math-BigInt-1.999.700-r1:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Net-SMTP-SSL-1.30.0:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-Scalar-List-Utils-1.410.0-r1:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-MimeInfo-0.270.0:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-ExtUtils-ParseXS-3.280.0-r1:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/LWP-Protocol-https-6.60.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-File-Temp-0.230.400-r5:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22.2* required by (virtual/perl-libnet-3.50.0-r2:0/0::gentoo, installed)
    ^              ^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTTP-Date-6.20.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.10.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/XML-SAX-0.990.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (dev-perl/Text-CSV_XS-1.230.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Time-HiRes-1.972.600-r3:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTML-Parser-3.710.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/XML-NamespaceSupport-1.110.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-parent-0.232.0-r1:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Crypt-RC4-2.020.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/XML-Parser-2.440.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-File-Spec-3.560.100-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-Term-ANSIColor-4.30.0-r1:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Test-Harness-3.350.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-JSON-PP-2.273.0-r4:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/XML-Simple-2.200.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTML-Tagset-3.200.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-MIME-Base64-3.150.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-ExtUtils-CBuilder-0.280.221-r1:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.22= required by (dev-perl/Module-Build-0.421.600:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-libnet-3.50.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22.2* required by (virtual/perl-ExtUtils-MakeMaker-7.40.100_rc-r2:0/0::gentoo, installed)
    ^              ^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/IO-HTML-1.1.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Date-Manip-6.510.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-IO-Compress-2.68.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-Module-Metadata-1.0.26-r1:0/0::gentoo, installed)
    ^              ^^^^^
    =dev-lang/perl-5.22.2* required by (virtual/perl-IO-1.350.0-r2:0/0::gentoo, installed)
    ^              ^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (perl-core/File-Temp-0.230.400-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22.2* required by (virtual/perl-XSLoader-0.200.0-r2:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Digest-SHA1-2.130.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/IO-Socket-SSL-2.24.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Algorithm-Diff-1.190.300:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (dev-perl/URI-1.710.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Exporter-5.720.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/common-sense-3.740.0:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22.2* required by (virtual/perl-Parse-CPAN-Meta-1.441.400-r3:0/0::gentoo, installed)
    ^              ^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Digest-MD5-2.540.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-CPAN-Meta-2.150.1-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (dev-perl/Net-SSLeay-1.720.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Getopt-Long-2.450.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Unicode-EastAsianWidth-1.330.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (dev-perl/DBI-1.636.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-DesktopEntry-0.40.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-Time-HiRes-1.972.600-r3:0/0::gentoo, installed)
    ^              ^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-Compress-Raw-Bzip2-2.68.0-r1:0/0::gentoo, installed)
    ^              ^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-Compress-Raw-Zlib-2.68.0-r1:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-IO-1.350.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Data-Dumper-2.158.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (dev-perl/HTTP-Message-6.110.0:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22.2* required by (virtual/perl-Test-Harness-3.350.0-r2:0/0::gentoo, installed)
    ^              ^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Compress-Raw-Zlib-2.68.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Digest-SHA-5.950.0-r4:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/AnyEvent-I3-0.160.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/LWP-MediaTypes-6.20.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (net-irc/irssi-1.0.3:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-ExtUtils-ParseXS-3.280.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Module-Metadata-1.0.26-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (dev-perl/DBD-mysql-4.41.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Test-Simple-1.1.14_p522-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-ExtUtils-CBuilder-0.280.221-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Perl-OSType-1.8.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (dev-vcs/subversion-1.9.5:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Digest-1.170.0-r9:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Storable-2.530.100-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Error-0.170.240:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Time-Local-1.230.0-r4:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Compress-Raw-Bzip2-2.68.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (sys-apps/texinfo-6.1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Encode-Locale-1.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (dev-perl/Net-HTTP-6.90.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/TermReadKey-2.330.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-Listing-6.40.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-Getopt-Long-2.450.0-r1:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTTP-Cookies-6.10.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-ExtUtils-MakeMaker-7.40.100_rc-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-Data-Dumper-2.158.0-r1:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/libwww-perl-6.150.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Encode-2.730.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Spreadsheet-ParseExcel-0.650.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-ExtUtils-Install-2.40.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Text-Unidecode-1.270.0:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-Perl-OSType-1.8.0-r1:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-CPAN-Meta-YAML-0.12.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22.2* required by (virtual/perl-Storable-2.530.100-r2:0/0::gentoo, installed)
    ^              ^^^^^^^
    dev-lang/perl:0/5.22= required by (x11-terms/rxvt-unicode-9.21:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Term-ANSIColor-4.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTTP-Daemon-6.10.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Parse-CPAN-Meta-1.441.400-r3:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Sys-Syslog-0.330.0-r6:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22.2* required by (virtual/perl-IPC-Cmd-0.920.0-r5:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-File-Path-2.90.0-r4:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-CPAN-Meta-2.150.1-r1:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/JSON-XS-3.10.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-vcs/git-2.11.1-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/XML-LibXML-2.12.100:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22.2* required by (virtual/perl-IO-Compress-2.68.0-r2:0/0::gentoo, installed)
    ^              ^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/IO-stringy-2.111.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/XML-SAX-Base-1.80.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-Which-1.90.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Authen-SASL-2.160.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Digest-Perl-MD5-1.900.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Carp-1.360.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-CPAN-Meta-YAML-0.12.0-r2:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.22= required by (virtual/perl-Scalar-List-Utils-1.410.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Digest-HMAC-1.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-BaseDir-0.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Unicode-Map-0.112.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Crypt-PasswdMD5-1.400.0:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.22* required by (virtual/perl-Carp-1.360.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

  (dev-lang/perl-5.24.0-r2:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.24* required by (virtual/perl-ExtUtils-Install-2.40.0-r2:0/0::gentoo, installed)
    ^              ^^^^^
    =dev-lang/perl-5.24.0* required by (virtual/perl-Digest-1.170.0-r9:0/0::gentoo, installed)
    ^              ^^^^^^^
    =dev-lang/perl-5.24* required by (virtual/perl-Exporter-5.720.0-r2:0/0::gentoo, installed)
    ^              ^^^^^
    =dev-lang/perl-5.24* required by (virtual/perl-ExtUtils-Manifest-1.700.0-r3:0/0::gentoo, installed)
    ^              ^^^^^
    =dev-lang/perl-5.24* required by (virtual/perl-Time-Local-1.230.0-r4:0/0::gentoo, installed)
    ^              ^^^^^
    =dev-lang/perl-5.24* required by (virtual/perl-MIME-Base64-3.150.0-r2:0/0::gentoo, installed)
    ^              ^^^^^
    =dev-lang/perl-5.24* required by (virtual/perl-Text-ParseWords-3.300.0-r2:0/0::gentoo, installed)
    ^              ^^^^^
    =dev-lang/perl-5.24.0* required by (virtual/perl-JSON-PP-2.273.0-r4:0/0::gentoo, installed)
    ^              ^^^^^^^
    =dev-lang/perl-5.24* required by (virtual/perl-Test-Simple-1.1.14_p522-r1:0/0::gentoo, installed)
    ^              ^^^^^
    =dev-lang/perl-5.24* required by (virtual/perl-Unicode-Collate-1.140.0-r2:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    =dev-lang/perl-5.24.0* required by (virtual/perl-Digest-SHA-5.950.0-r4:0/0::gentoo, installed)
    ^              ^^^^^^^
    =dev-lang/perl-5.24* required by (virtual/perl-Unicode-Normalize-1.250.0-r2:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    =dev-lang/perl-5.24.0* required by (virtual/perl-Sys-Syslog-0.330.0-r6:0/0::gentoo, installed)
    ^              ^^^^^^^
    =dev-lang/perl-5.24* required by (virtual/perl-Digest-MD5-2.540.0-r2:0/0::gentoo, installed)
    ^              ^^^^^


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

Nikos Alexandris | Remote Sensing *
GPG Key Fingerprint 6F9D4506F3CA28380974D31A9053534B693C4FB3


#8
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 359 posts

to sort this problem:

you need to mask all ebuilds that you see with perl-5.24, masking exact versions. For example you see:

=dev-lang/perl-5.24* required by (virtual/perl-ExtUtils-Install-2.40.0-r2:0/0::gentoo, installed)

you need to put mask for =virtual/perl-ExtUtils-Install-2.40.0-r2, same goes for rest of ebuilds. then you need to mask perl-5.24 itself, then reinstall-5.22, and then run perl-cleaner. If you see that some ebuilds asking to put unstable keywords such as:

[ebuild N ~]

you shouldn't let portage install them, your problem was allowing unstable perl and it's dependencies installed on your box. ideally, it should never happen, but i have no information when and why this happened on your box.

Sorry colored text, i have no idea how to disable it.


www.funtoo.org

#9
NikosAlexandris

NikosAlexandris

    Advanced Member

  • Members
  • PipPipPip
  • 56 posts
  • LocationSwitzerland

Thank you dear Oleg, so much, for your time.

 

I still didn't fix it.  I reached up to...

cat package.mask
>=dev-lang/perl-5.24
=dev-lang/perl-5.24.0-r2
=dev-perl/Business-ISBN-2.90.200_rc
=dev-perl/Business-ISBN-Data-20140910.3.0
=dev-perl/Business-ISMN-1.130.0
=dev-perl/Business-ISSN-0.910.0-r1
=dev-perl/Capture-Tiny-0.360.0
=dev-perl/Class-Accessor-0.340.0-r1
=dev-perl/Config-AutoConf-0.313.0
=dev-perl/Data-Uniqid-0.120.0-r1
=dev-perl/Encode-EUCJPASCII-0.30.0
=dev-perl/Encode-HanExtra-0.230.0-r1
=dev-perl/Encode-JIS2K-0.30.0
=dev-perl/Exporter-Tiny-0.42.0
=dev-perl/ExtUtils-LibBuilder-0.80.0
=dev-perl/File-Slurp-9999.190.0-r1
=dev-perl/File-Slurp-Tiny-0.4.0
=dev-perl/File-Slurp-Unicode-0.7.1-r1
=dev-perl/IPC-Run3-0.48.0
=dev-perl/Lingua-Translit-0.250.0
=dev-perl/List-AllUtils-0.90.0
=dev-perl/List-MoreUtils-0.413.0
=dev-perl/Log-Log4perl-1.460.0
=dev-perl/Log-Log4perl-1.470.0
=dev-perl/MIME-Charset-1.9.3
=dev-perl/Number-Compare-0.30.0-r1
=dev-perl/Readonly-2.0.0
=dev-perl/Readonly-XS-1.50.0-r1
=dev-perl/Sub-Name-0.50.0-r1
=dev-perl/Text-BibTeX-0.770.0
=dev-perl/Text-Glob-0.90.0-r1
=dev-perl/Text-Roman-3.500.0
=dev-perl/Tie-Cycle-1.221.0
=dev-perl/Unicode-LineBreak-2016.3.0
=dev-perl/XML-LibXML-Simple-0.970.0
=dev-perl/XML-LibXSLT-1.940.0
=virtual/perl-Digest-1.170.0-r9
=virtual/perl-Digest-MD5-2.540.0-r2
=virtual/perl-Digest-SHA-5.950.0-r4
=virtual/perl-Exporter-5.710.0-r3
=virtual/perl-Exporter-5.720.0-r2
=virtual/perl-ExtUtils-Install-2.40.0-r2
=virtual/perl-ExtUtils-Manifest-1.700.0-r3
=virtual/perl-File-Path-2.90.0-r4
=virtual/perl-IPC-Cmd-0.920.0-r5
=virtual/perl-JSON-PP-2.272.30-r1
=virtual/perl-JSON-PP-2.273.0-r4
=virtual/perl-Math-BigInt-1.999.700-r1
=virtual/perl-MIME-Base64-3.150.0-r2
=virtual/perl-Sys-Syslog-0.330.0-r6
=virtual/perl-Test-Simple-1.1.14_p522-r1
=virtual/perl-Text-ParseWords-3.300.0-r2
=virtual/perl-Time-Local-1.230.0-r4
=virtual/perl-Unicode-Collate-1.140.0-r2
=virtual/perl-Unicode-Normalize-1.250.0-r2
=dev-perl/Business-ISBN-Data-20140910.2.0
=dev-perl/Encode-JIS2K-0.02
=dev-perl/Business-ISBN-2.50.0-r1
=dev-perl/MIME-Charset-1.12.0
=dev-perl/XML-LibXSLT-1.950.0
=virtual/perl-File-Path-2.120.100_rc-r1
=dev-perl/Log-Log4perl-1.480.0
=dev-perl/Sub-Name-0.150.0
=dev-perl/Config-AutoConf-0.311.0
=dev-perl/ExtUtils-LibBuilder-0.04
=dev-perl/Readonly-2.10.0
=dev-perl/Text-BibTeX-0.720.0
=dev-perl/Text-BibTeX-0.760.0

and then

emerge -av biber --verbose-conflicts

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] virtual/perl-XSLoader-0.200.0-r2::gentoo  0 KiB
[ebuild  N     ] dev-perl/Date-Simple-3.30.0-r1::gentoo  23 KiB
[ebuild  N     ] dev-perl/Data-Dump-1.230.0::gentoo  21 KiB
[ebuild  N     ] dev-perl/Regexp-Common-2013031301.0.0::gentoo  114 KiB
[ebuild  N     ] dev-perl/XML-Writer-0.625.0::gentoo  USE="{-test}" 29 KiB
[ebuild  N    #] dev-perl/Text-Roman-3.500.0::gentoo  18 KiB
[ebuild  N    #] dev-perl/Business-ISSN-0.910.0-r1::gentoo  USE="{-test}" 5 KiB
[ebuild  N    #] dev-perl/Sub-Name-0.50.0-r1::gentoo  4 KiB
[ebuild  N    #] dev-perl/MIME-Charset-1.9.3::gentoo  50 KiB
[ebuild  N    #] dev-perl/File-Slurp-9999.190.0-r1::gentoo  39 KiB
[ebuild  N    #] dev-perl/Number-Compare-0.30.0-r1::gentoo  3 KiB
[ebuild  N     ] perl-core/File-Path-2.90.0::gentoo  21 KiB
[ebuild  N     ] virtual/perl-Math-BigRat-0.260.800-r1::gentoo  0 KiB
[ebuild  N     ] virtual/perl-bignum-0.390.0-r2::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Math-BigInt-FastCalc-0.310.0-r2::gentoo  0 KiB
[ebuild  N    #] virtual/perl-File-Path-2.90.0-r4::gentoo  0 KiB
[ebuild  N    #] dev-perl/IPC-Run3-0.48.0::gentoo  USE="{-test}" 20 KiB
[ebuild  N    #] dev-perl/Lingua-Translit-0.250.0::gentoo  385 KiB
[ebuild  N    #] dev-perl/Class-Accessor-0.340.0-r1::gentoo  13 KiB
[ebuild  N    #] dev-perl/Exporter-Tiny-0.42.0::gentoo  USE="{-test}" 32 KiB
[ebuild  N    #] dev-perl/Tie-Cycle-1.221.0::gentoo  USE="{-test}" 10 KiB
[ebuild  N    #] dev-perl/Business-ISBN-Data-20140910.3.0::gentoo  USE="{-test}" 21 KiB
[ebuild  N     ] perl-core/Math-BigInt-1.999.300::gentoo  211 KiB
[ebuild  N    #] dev-perl/Business-ISBN-2.90.200_rc::gentoo  USE="-barcode {-test} -xisbn" 354 KiB
[ebuild  N    #] dev-perl/Business-ISMN-1.130.0::gentoo  USE="{-test}" 10 KiB
[ebuild  N    #] dev-perl/Encode-JIS2K-0.30.0::gentoo  410 KiB
[ebuild  N    #] dev-perl/Encode-HanExtra-0.230.0-r1::gentoo  1,530 KiB
[ebuild  N    #] dev-perl/Encode-EUCJPASCII-0.30.0::gentoo  129 KiB
[ebuild  N    #] dev-perl/Unicode-LineBreak-2016.3.0::gentoo  297 KiB
[ebuild  N    #] dev-perl/Log-Log4perl-1.460.0::gentoo  USE="{-test}" 272 KiB
[ebuild  N     ] virtual/perl-Math-BigInt-1.999.300-r1::gentoo  0 KiB
[ebuild  N    #] dev-perl/Data-Uniqid-0.120.0-r1::gentoo  3 KiB
[ebuild  N    #] dev-perl/XML-LibXSLT-1.940.0::gentoo  112 KiB
[ebuild     U #] dev-lang/perl-5.24.1_rc4:0/5.24::gentoo [5.22.2:0/5.22::gentoo] USE="berkdb gdbm ithreads
 -debug -doc" 11,302 KiB
[ebuild  N    #] virtual/perl-IPC-Cmd-0.920.100_rc-r1::gentoo  0 KiB
[ebuild  N    #] virtual/perl-Unicode-Collate-1.140.0-r2::gentoo  0 KiB
[ebuild  N    #] virtual/perl-Unicode-Normalize-1.250.0-r2::gentoo  0 KiB
[ebuild  N    #] dev-perl/List-MoreUtils-0.413.0::gentoo  USE="{-test}" 129 KiB
[ebuild  N     ] dev-perl/Capture-Tiny-0.300.0::gentoo  USE="{-test}" 34 KiB
[ebuild  N    #] dev-perl/File-Slurp-Tiny-0.4.0::gentoo  USE="{-test}" 13 KiB
[ebuild  N    #] dev-perl/Readonly-2.0.0::gentoo  USE="{-test}" 24 KiB
[ebuild  N    #] dev-perl/Config-AutoConf-0.313.0::gentoo  USE="{-test}" 48 KiB
[ebuild  N    #] dev-perl/File-Slurp-Unicode-0.7.1-r1::gentoo  4 KiB
[ebuild  N    #] dev-perl/List-AllUtils-0.90.0::gentoo  USE="{-test}" 19 KiB
[ebuild  N    #] dev-perl/XML-LibXML-Simple-0.970.0::gentoo  USE="{-test}" 23 KiB
[ebuild  N    #] dev-perl/ExtUtils-LibBuilder-0.80.0::gentoo  USE="{-test}" 6 KiB
[ebuild  N    #] dev-perl/Text-Glob-0.90.0-r1::gentoo  5 KiB
[ebuild  N    #] dev-perl/Text-BibTeX-0.770.0::gentoo  289 KiB
[ebuild  N    #] dev-perl/Readonly-XS-1.50.0-r1::gentoo  9 KiB
[ebuild  N     ] dev-perl/File-Find-Rule-0.330.0-r1::gentoo  USE="{-test}" 15 KiB
[ebuild  N     ] dev-perl/Data-Compare-1.250.0::gentoo  USE="{-test}" 26 KiB
[ebuild  N     ] perl-core/Test-Simple-1.1.14-r1::gentoo  125 KiB
[ebuild     UD ] virtual/perl-Test-Simple-1.1.14-r3::gentoo [1.1.14_p522-r1::gentoo] 0 KiB
[blocks b      ] perl-core/Test-Simple ("perl-core/Test-Simple" is blocking virtual/perl-Test-Simple-1.1.1
4_p522-r1)
[ebuild  N     ] dev-perl/autovivification-0.160.0::gentoo  49 KiB
[ebuild  N     ] dev-tex/biber-2.5::gentoo  USE="-doc {-test}" 1,219 KiB

Total: 55 packages (1 upgrade, 1 downgrade, 53 new), Size of downloads: 17,453 KiB
Conflict: 1 block

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.22.2:0/5.22::gentoo, installed) pulled in by
    dev-lang/perl:0/5.22= required by (virtual/perl-parent-0.232.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/OLE-StorageLite-0.190.0-r1:0/0::gentoo, install
ed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (perl-core/Encode-2.730.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/libintl-perl-1.240.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Types-Serialiser-1.0.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-ExtUtils-Manifest-1.700.0-r3:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-File-Spec-3.560.100-r1:0/0::gentoo, installed)
    ^              ^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Text-ParseWords-3.300.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (dev-perl/AnyEvent-7.120.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Net-SMTP-SSL-1.30.0:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Scalar-List-Utils-1.410.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-MimeInfo-0.270.0:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-ExtUtils-ParseXS-3.280.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/LWP-Protocol-https-6.60.0:0/0::gentoo, installe
d)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-File-Temp-0.230.400-r5:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-libnet-3.50.0-r2:0/0::gentoo, installed)
    ^              ^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTTP-Date-6.20.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.10.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/XML-SAX-0.990.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (dev-perl/Text-CSV_XS-1.230.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Time-HiRes-1.972.600-r3:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTML-Parser-3.710.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/XML-NamespaceSupport-1.110.0-r1:0/0::gentoo, in
stalled)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-parent-0.232.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Crypt-RC4-2.020.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/XML-Parser-2.440.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-File-Spec-3.560.100-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-JSON-PP-2.273.0-r4:0/0::gentoo, installed)
    ^              ^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Term-ANSIColor-4.30.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Test-Harness-3.350.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-JSON-PP-2.273.0-r4:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/XML-Simple-2.200.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTML-Tagset-3.200.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-MIME-Base64-3.150.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-ExtUtils-CBuilder-0.280.221-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22= required by (dev-perl/Module-Build-0.421.600:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-libnet-3.50.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-ExtUtils-MakeMaker-7.40.100_rc-r2:0/0::gentoo, instal
led)
    ^              ^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Scalar-List-Utils-1.410.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Date-Manip-6.510.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-IO-Compress-2.68.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Module-Metadata-1.0.26-r1:0/0::gentoo, installed)
    ^              ^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-IO-1.350.0-r2:0/0::gentoo, installed)
    ^              ^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (perl-core/File-Temp-0.230.400-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-XSLoader-0.200.0-r2:0/0::gentoo, ebuild scheduled for
 merge)
    ^              ^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Digest-SHA1-2.130.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/IO-Socket-SSL-2.24.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Algorithm-Diff-1.190.300:0/0::gentoo, installed
)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (dev-perl/URI-1.710.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Digest-HMAC-1.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/common-sense-3.740.0:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-Digest-1.170.0-r9:0/0::gentoo, installed)
    ^              ^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-Parse-CPAN-Meta-1.441.400-r3:0/0::gentoo, installed)
    ^              ^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Digest-MD5-2.540.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-CPAN-Meta-2.150.1-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/TermReadKey-2.330.0:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Math-BigInt-FastCalc-0.310.0-r2:0/0::gentoo, ebuild sch
eduled for merge)
    ^              ^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Getopt-Long-2.450.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Unicode-EastAsianWidth-1.330.0-r1:0/0::gentoo,
installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (dev-perl/DBI-1.636.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-DesktopEntry-0.40.0-r1:0/0::gentoo, instal
led)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Time-HiRes-1.972.600-r3:0/0::gentoo, installed)
    ^              ^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Compress-Raw-Bzip2-2.68.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Compress-Raw-Zlib-2.68.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-IO-1.350.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-Digest-SHA-5.950.0-r4:0/0::gentoo, installed)
    ^              ^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Data-Dumper-2.158.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-bignum-0.390.0-r2:0/0::gentoo, ebuild scheduled for m
erge)
    ^              ^^^^^^^

    dev-lang/perl:0/5.22= required by (dev-perl/HTTP-Message-6.110.0:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-Test-Harness-3.350.0-r2:0/0::gentoo, installed)
    ^              ^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Compress-Raw-Zlib-2.68.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Digest-SHA-5.950.0-r4:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/AnyEvent-I3-0.160.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/LWP-MediaTypes-6.20.0-r1:0/0::gentoo, installed
)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (net-irc/irssi-1.0.3:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-ExtUtils-ParseXS-3.280.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Module-Metadata-1.0.26-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (dev-perl/DBD-mysql-4.41.0:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-Sys-Syslog-0.330.0-r6:0/0::gentoo, installed)
    ^              ^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-ExtUtils-CBuilder-0.280.221-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Perl-OSType-1.8.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (dev-vcs/subversion-1.9.5:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Digest-1.170.0-r9:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Carp-1.360.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Error-0.170.240:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Time-Local-1.230.0-r4:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Compress-Raw-Bzip2-2.68.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (sys-apps/texinfo-6.1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Encode-Locale-1.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (dev-perl/Net-HTTP-6.90.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (dev-perl/Net-SSLeay-1.720.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Exporter-5.720.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Getopt-Long-2.450.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTTP-Cookies-6.10.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-ExtUtils-MakeMaker-7.40.100_rc-r2:0/0::gentoo, install
ed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Data-Dumper-2.158.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/libwww-perl-6.150.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Encode-2.730.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Spreadsheet-ParseExcel-0.650.0:0/0::gentoo, ins
talled)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-ExtUtils-Install-2.40.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Text-Unidecode-1.270.0:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Perl-OSType-1.8.0-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-CPAN-Meta-YAML-0.12.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-Storable-2.530.100-r2:0/0::gentoo, installed)
    ^              ^^^^^^^

    dev-lang/perl:0/5.22= required by (x11-terms/rxvt-unicode-9.21:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Term-ANSIColor-4.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/HTTP-Daemon-6.10.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Parse-CPAN-Meta-1.441.400-r3:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Sys-Syslog-0.330.0-r6:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-CPAN-Meta-2.150.1-r1:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/JSON-XS-3.10.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-vcs/git-2.11.1-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Math-BigRat-0.260.800-r1:0/0::gentoo, ebuild scheduled
for merge)
    ^              ^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/XML-LibXML-2.12.100:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22.2* required by (virtual/perl-IO-Compress-2.68.0-r2:0/0::gentoo, installed)
    ^              ^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/IO-stringy-2.111.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/XML-SAX-Base-1.80.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-Which-1.90.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Authen-SASL-2.160.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Digest-Perl-MD5-1.900.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22= required by (virtual/perl-Storable-2.530.100-r2:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-CPAN-Meta-YAML-0.12.0-r2:0/0::gentoo, installed)
    ^              ^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/IO-HTML-1.1.0:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-Listing-6.40.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-BaseDir-0.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Unicode-Map-0.112.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^

    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Crypt-PasswdMD5-1.400.0:0/0::gentoo, installed)
                 ^^^^^^^^

    =dev-lang/perl-5.22* required by (virtual/perl-Carp-1.360.0-r1:0/0::gentoo, installed)
    ^              ^^^^^


  (dev-lang/perl-5.24.1_rc4:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.24* required by (virtual/perl-ExtUtils-Install-2.40.0-r2:0/0::gentoo, installed)
    ^              ^^^^^

    =dev-lang/perl-5.24.1* required by (virtual/perl-IPC-Cmd-0.920.100_rc-r1:0/0::gentoo, ebuild scheduled
 for merge)
    ^              ^^^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-Exporter-5.720.0-r2:0/0::gentoo, installed)
    ^              ^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-ExtUtils-Manifest-1.700.0-r3:0/0::gentoo, installed)
    ^              ^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-Time-Local-1.230.0-r4:0/0::gentoo, installed)
    ^              ^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-Text-ParseWords-3.300.0-r2:0/0::gentoo, installed)
    ^              ^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-MIME-Base64-3.150.0-r2:0/0::gentoo, installed)
    ^              ^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-Unicode-Collate-1.140.0-r2:0/0::gentoo, ebuild schedule
d for merge)
    ^              ^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-Unicode-Normalize-1.250.0-r2:0/0::gentoo, ebuild schedu
led for merge)
    ^              ^^^^^

    =dev-lang/perl-5.24* required by (virtual/perl-Digest-MD5-2.540.0-r2:0/0::gentoo, installed)
    ^              ^^^^^



It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by virtual/perl-ExtUtils-Manifest-1.700.0-r3::gentoo
# required by dev-perl/Module-Build-0.421.600::gentoo
# required by dev-perl/Text-Glob-0.90.0-r1::gentoo
# required by dev-perl/File-Find-Rule-0.330.0-r1::gentoo
# required by dev-perl/Data-Compare-1.250.0::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
=dev-lang/perl-5.24.1_rc4 ~amd64

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Readonly-XS-1.50.0-r1
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Business-ISMN-1.130.0
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Log-Log4perl-1.460.0
# required by dev-perl/Text-BibTeX-0.770.0::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Config-AutoConf-0.313.0
# required by dev-perl/Business-ISMN-1.130.0::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Tie-Cycle-1.221.0
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Text-Roman-3.500.0
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Business-ISBN-2.90.200_rc
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/List-AllUtils-0.90.0
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Business-ISSN-0.910.0-r1
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/XML-LibXML-Simple-0.970.0
# required by virtual/perl-ExtUtils-Manifest-1.700.0-r3::gentoo
# required by dev-perl/Module-Build-0.421.600::gentoo
# required by dev-perl/Text-Glob-0.90.0-r1::gentoo
# required by dev-perl/File-Find-Rule-0.330.0-r1::gentoo
# required by dev-perl/Data-Compare-1.250.0::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /usr/portage/profiles/package.mask/funtoo-perl-oleg:
=dev-lang/perl-5.24.1_rc4
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/List-MoreUtils-0.413.0
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Encode-EUCJPASCII-0.30.0
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/XML-LibXSLT-1.940.0
# required by dev-perl/Unicode-LineBreak-2016.3.0::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/MIME-Charset-1.9.3
# required by dev-perl/File-Find-Rule-0.330.0-r1::gentoo
# required by dev-perl/Data-Compare-1.250.0::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Number-Compare-0.30.0-r1
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Lingua-Translit-0.250.0
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/IPC-Run3-0.48.0
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Encode-HanExtra-0.230.0-r1
# required by dev-perl/List-MoreUtils-0.413.0::gentoo
# required by dev-perl/List-AllUtils-0.90.0::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Exporter-Tiny-0.42.0
# required by dev-perl/Text-BibTeX-0.770.0::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/ExtUtils-LibBuilder-0.80.0
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Data-Uniqid-0.120.0-r1
# required by dev-perl/Class-Accessor-0.340.0-r1::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Sub-Name-0.50.0-r1
# required by dev-perl/File-Slurp-Unicode-0.7.1-r1::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/File-Slurp-9999.190.0-r1
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Encode-JIS2K-0.30.0
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Text-BibTeX-0.770.0
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/File-Slurp-Unicode-0.7.1-r1
# required by dev-perl/File-Find-Rule-0.330.0-r1::gentoo
# required by dev-perl/Data-Compare-1.250.0::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Text-Glob-0.90.0-r1
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /usr/portage/profiles/package.mask/funtoo-perl-oleg:
=virtual/perl-IPC-Cmd-0.920.100_rc-r1
# required by dev-perl/XML-LibXML-Simple-0.970.0::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/File-Slurp-Tiny-0.4.0
# required by dev-perl/Log-Log4perl-1.460.0::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=virtual/perl-File-Path-2.90.0-r4
# required by dev-perl/Readonly-XS-1.50.0-r1::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Readonly-2.0.0
# required by dev-perl/Business-ISBN-2.90.200_rc::gentoo
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Business-ISBN-Data-20140910.3.0
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Unicode-LineBreak-2016.3.0
# required by dev-tex/biber-2.5::gentoo
# required by biber (argument)
# /etc/portage/package.mask:
=dev-perl/Class-Accessor-0.340.0-r1

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Would you like to add these changes to your config files? [Yes/No]

I thought I would manage to get it done.  Looks like I have indeed a messy setup at the moment.


Nikos Alexandris | Remote Sensing *
GPG Key Fingerprint 6F9D4506F3CA28380974D31A9053534B693C4FB3


#10
cardinal

cardinal

    Advanced Member

  • Members
  • PipPipPip
  • 231 posts

biber-2.5 will not work with dev-lang/perl-5.22.2 due to dependency on
Unicode::Collate' => '1.14' and 'Unicode::Normalize' => '1.25'
virtual/perl-Unicode-Collate-1.140.0-r2 and virtual/perl-Unicode-Normalize-1.250.0-r2 require dev-lang/perl-5.24.0-r2
 

funtoo rj # equery g virtual/perl-Unicode-Collate-1.140.0-r2
* Searching for perl-Unicode-Collate1.140.0-r2 in virtual ...

* dependency graph for virtual/perl-Unicode-Collate-1.140.0-r2
`-- virtual/perl-Unicode-Collate-1.140.0-r2 ~x86
`-- dev-lang/perl-5.24.0-r2 (=dev-lang/perl-5.24*) ~x86
`-- perl-core/Unicode-Collate-1.140.0 (~perl-core/Unicode-Collate-1.140.0) [~x86 keyword]
[ virtual/perl-Unicode-Collate-1.140.0-r2 stats: packages (3), max depth (1) ]

funtoo rj # equery g virtual/perl-Unicode-Normalize-1.250.0-r2
* Searching for perl-Unicode-Normalize1.250.0-r2 in virtual ...

* dependency graph for virtual/perl-Unicode-Normalize-1.250.0-r2
`-- virtual/perl-Unicode-Normalize-1.250.0-r2 ~x86
`-- dev-lang/perl-5.24.0-r2 (=dev-lang/perl-5.24*) ~x86
`-- perl-core/Unicode-Normalize-1.250.0 (~perl-core/Unicode-Normalize-1.250.0) [~x86 keyword]
[ virtual/perl-Unicode-Normalize-1.250.0-r2 stats: packages (3), max depth (1) ]

 



#11
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 359 posts

biber will work with perl-5.22.2, it's just stupid dependencies set in ebuild, which forcing newer perl.


www.funtoo.org

#12
NikosAlexandris

NikosAlexandris

    Advanced Member

  • Members
  • PipPipPip
  • 56 posts
  • LocationSwitzerland

biber will work with perl-5.22.2, it's just stupid dependencies set in ebuild, which forcing newer perl.

 

Maybe I can edit directly the ebuild, then?


Nikos Alexandris | Remote Sensing *
GPG Key Fingerprint 6F9D4506F3CA28380974D31A9053534B693C4FB3


#13
NikosAlexandris

NikosAlexandris

    Advanced Member

  • Members
  • PipPipPip
  • 56 posts
  • LocationSwitzerland

I am trying to get biber installed via a local ebuild, where I changed a bit the dependencies. But, it's a large circle of interdependencies. And the wrong way to deal with it.

I need to get this done, to continue my work.

 

Is there really no solution to clean up my environment?

Can I not downgrade to all Perl 5.22 and, even, remove anything that needs Perl 5.24?

 

I would sacrifice for the moment any other tool and more to get things working in LaTeX.  I use i3wm, so I don't depend on KDE (which I do use some times).

Thanks for any recommendations.


Nikos Alexandris | Remote Sensing *
GPG Key Fingerprint 6F9D4506F3CA28380974D31A9053534B693C4FB3


#14
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 359 posts

i'll fix this.


www.funtoo.org



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users