Jump to content

Photo

About =sci-libs/hdf5-1.8.14-r1


3 replies to this topic

#1
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 369 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy
Hello to all ....
I'm on Funtoo "Stable" 64 bits (with xfce4 and kde / plasma-5)
Trying to install digikam, I had to unmask the last version in Portage (media-gfx / digikam-5.3.0), Because with the 4.4.0-r1 I had problems with kde-frameworks / baloo).
 
I made several attempts .... I finally managed to install digikam; But I had to change the local use flags for sci-libs / HDF5 disabling "mpi" and "threads".
 
Rightly so ... or is there a way to use multithreading and multiprocessor support around sci-libs / HDF5?
 
Excuse me (but I'm curious to understand:) ... and thx for info :)


#2
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 415 posts

what exact problem is?


www.funtoo.org

#3
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 369 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

About digikam:

ci74771ht ~ # emerge digikam 
Calculating dependencies... done!
[ebuild  N     ] media-libs/libpgf-6.12.27  USE="-doc -static-libs"  
[ebuild  N     ] dev-libs/qjson-0.8.1-r1  USE="-debug -doc {-test}" ABI_X86="32 
(64) (-x32)"  
[ebuild  N     ] dev-libs/kqoauth-0.98-r1  
[ebuild  NS    ] kde-apps/libkdcraw-15.08.3 [16.04.3] USE="(-aqua) -debug"  
[ebuild  N    ~] dev-libs/quazip-0.7.2  USE="qt4 qt5 -static-libs {-test}"  
[ebuild  N     ] kde-apps/akonadi-1.13.1_pre20160203-r1  USE="mysql -postgres -s
qlite {-test}"                                                                   
[ebuild  N     ] kde-apps/kdepimlibs-4.14.11_pre20160211-r2  USE="handbook ldap 
(-aqua) -debug -prison {-test}"  
[ebuild  NS    ] kde-frameworks/kfilemetadata-4.14.3 [5.26.0-r1] USE="exif ffmpe
g pdf taglib (-aqua) -debug -epub -mobi"                                         
[ebuild  NS    ] kde-apps/ffmpegthumbs-15.08.3 [16.04.3] USE="(-aqua) -debug"  
[ebuild  NS    ] kde-apps/libkipi-15.08.3-r1 [16.04.3] USE="(-aqua) -debug"  
[ebuild  NS    ] kde-frameworks/baloo-4.14.3 [5.26.0-r2] USE="(-aqua) -debug -mi
nimal"                                                                           
[ebuild  N     ] kde-apps/libkface-4.4.0  USE="(-aqua)"  
[ebuild  N     ] media-plugins/kipi-plugins-4.4.0  USE="calendar cdr crypt handb
ook imagemagick ipod opengl scanner (-aqua) -debug -expoblending -gpssync -media
wiki -panorama -redeyes -upnp -videoslideshow -vkontakte" L10N="it -ar -be -bg -
bs -ca -cs -da -de -el -en-GB -eo -es -et -eu -fi -fr -ga -gl -he -hi -hr -hu -i
s -ja -km -ko -lt -lv -ms -nb -nds -nl -nn -oc -pa -pl -pt -pt-BR -ro -ru -se -s
k -sl -sq -sv -th -tr -uk -zh-CN -zh-TW"                                         
[ebuild  NS    ] kde-apps/marble-4.14.3 [16.04.3] USE="gps handbook kde phonon p
lasma zip (-aqua) -debug -designer-plugin (-python) -shapefile {-test}" PYTHON_T
ARGETS="python2_7"  
[uninstall     ] kde-apps/marble-16.04.3  
[blocks b      ] kde-apps/marble:4 ("kde-apps/marble:4" is blocking kde-apps/mar
ble-16.04.3)                                                                     
[ebuild  N     ] kde-apps/libkgeomap-15.08.3  USE="(-aqua) {-test}"  
[ebuild  N     ] media-gfx/digikam-4.4.0-r1  USE="gphoto2 handbook semantic-desk
top thumbnails video -addressbook (-aqua) -debug -doc -mysql -themedesigner" L10
N="it -ar -be -bg -bs -ca -cs -da -de -el -en-GB -eo -es -et -eu -fa -fi -fr -ga
-gl -he -hi -hr -hu -is -ja -km -ko -lt -lv -ms -nb -nds -ne -nl -nn -pa -pl -p
t -pt-BR -ro -ru -se -sk -sl -sq -sv -th -tr -uk -vi -zh-CN -zh-TW"              
[blocks B      ] kde-frameworks/baloo:4[-minimal(-)] ("kde-frameworks/baloo:4[-m
inimal(-)]" is blocking kde-frameworks/baloo-5.26.0-r2)                          

* Error: The above package list contains packages which cannot be 
* installed at the same time on the same system. 

 (kde-frameworks/baloo-4.14.3:4/4.14::gentoo, ebuild scheduled for merge) pulle
d in by
   kde-frameworks/baloo:4 required by (media-gfx/digikam-4.4.0-r1:4/4::gentoo, 
ebuild scheduled for merge)

 (kde-frameworks/baloo-5.26.0-r2:5/5.26::gentoo, installed) pulled in by 
   >=kde-frameworks/baloo-5.23.0:5 required by (kde-apps/baloo-widgets-16.04.3:
5/5::gentoo, installed)                                                          
   >=kde-frameworks/baloo-5.23.0:5 required by (kde-apps/dolphin-16.04.3:5/5::g
entoo, installed)                                                                
   >=kde-frameworks/baloo-5.23.0:5 required by (kde-plasma/plasma-workspace-5.7
.5:5/5::gentoo, installed)                                                       
   >=kde-frameworks/baloo-5.23.0:5 required by (kde-apps/gwenview-16.04.3:5/5::
gentoo, installed)                                                               
   >=kde-frameworks/baloo-5.23.0:5 required by (kde-plasma/plasma-desktop-5.7.5
:5/5::gentoo, installed)                                                         


For more information about Blocked Packages, please refer to the following 
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

Then i've unmasked latest version:

* media-gfx/digikam 
    Available versions:   
    (4)    4.4.0-r1^t (~)4.14.0-r1^t 
    (5)    (~)5.3.0^t

Then trying to emergedigikam-5.3.0 i obtain:

ci74771ht ~ # emerge digikam 
Calculating dependencies... done!

!!! The ebuild selected to satisfy "sci-libs/hdf5:=" has unmet requirements. 
- sci-libs/hdf5-1.8.14-r1::gentoo USE="cxx fortran mpi szip threads zlib -debug 
-examples -fortran2003 -static-libs"                                             

 The following REQUIRED_USE flag constraints are unsatisfied:
   cxx? ( !mpi ) mpi? ( !cxx ) threads? ( !cxx !mpi !fortran )

 The above constraints are a subset of the following complete expression:
   cxx? ( !mpi ) mpi? ( !cxx ) threads? ( !cxx !mpi !fortran ) fortran2003? ( f
ortran )

(dependency required by "media-libs/vigra-1.9.0::gentoo[hdf5]" [ebuild]) 
(dependency required by "media-gfx/hugin-2015.0.0-r1::gentoo" [ebuild]) 
(dependency required by "media-gfx/digikam-5.3.0::gentoo[panorama]" [ebuild]) 
(dependency required by "digikam" [argument]) 
ci74771ht ~ # 

Then with in package.use: 

sci-libs/hdf5 -mpi -threads

 

digikam successfully compiled _'_

 

So not using "threads" and "mpi", HDF5 can run only with a single thread i think .... _'_

 

My question: is right that HDF5 can runs only with single thread instead multithread ?

 

Just a curiosity _'_ :)



#4
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 415 posts

thx for output.

So, cxx USE flag is enabled by default in profiles. threads USE is not. hdf5 ebuild cannot use both. Do you have threads enabled globally?


www.funtoo.org



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users