Jump to content

Photo

Installation instructions question


3 replies to this topic

#1
isaacm

isaacm

    Newbie

  • Members
  • Pip
  • 2 posts

Dont understand instructions from installation page

 

"# tar xpf stage3-latest.tar.xz

Important

It is very important to use tar's "p" option when extracting the Stage 3 tarball - it tells tar topreserve any permissions and ownership that exist within the archive. Without this option, your Funtoo Linux filesystem permissions will be incorrect."

 

As you can see use of the tar -p option is not shown in the code line. So where in the code line should the -p go?

 

I'm asking because I think it might be related to the boot issue I'm having. Getting this message during boot:

 

 

"!! Could not find root block device in . Please specify another value; or press Enter for same, type "shell" for a shell or "q" to skip."

 

__________________________________________________________________________________________

 

Here is my fstab file:

 

 

 

# <fs>                  <mountpoint>    <type>          <opts> <dump/p$
 
/dev/sda1               /boot           ext2            noauto,noatime  1 2
/dev/sda3               none            swap            sw 0 0
/dev/sda4               /               xfs             noatime 0 1


#2
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 366 posts

using of  "p" option is shown in above command how do you see it now shown in tar xpf? maybe you confused with "p" and "-p"?  Your problem is not really related to unpacking of tarball, if you used tar xpf, you are fine. What were your steps before getting this boot failure.


www.funtoo.org

#3
isaacm

isaacm

    Newbie

  • Members
  • Pip
  • 2 posts

Followed install instructions to the letter. Rebooted for the first time. Got the error described above. No new hardware. Not using GPT have bios. Tried troubshooting guide but does not find disk 3 times out of 4. Mounted installation accessing it from inside using boot existing linux install from sys rescue menu. Everything accessible there. need to try to fix from inside I think.



#4
hjozwiak

hjozwiak

    Newbie

  • Members
  • Pip
  • 9 posts
  • LocationFairfax, VA

Your fstab says /dev/sda4 which should be /dev/sda3 unless you've made a typo.





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users