Jump to content
  • 0
ajohnl

Problem with packages that won't update due to dependencies.

Question

Hi, I appear to have some problems with dependencies when doing emerge -auvDNU @world

 

 

http://pastebin.com/bnjTSMBE

 

My package.use and .mask don't have anything unusual, and my epro is amd64 piledriver desktop with gnome and xfce mix-ins. This happened after I tried using kde, then reverted because of some driver issues, the weird thing is that when I try to install some of them manually I get for example:

Calculating dependencies... done!
[ebuild   R    ] media-video/ffmpeg-2.8.6:0/54.56.56::gentoo  USE="X aac alsa bluray bzip2 cdio encode faac gpl hardcoded-tables iconv ieee1394 jpeg2k libass mp3 network opengl postproc pulseaudio theora threads truetype twolame v4l vorbis vpx wavpack webp x264 x265 xvid zlib -aacplus (-altivec) -amr -amrenc (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bs2b -celt -cpudetection -debug -doc -examples -fdk -flite -fontconfig* -frei0r -fribidi -gme -gnutls -gsm -iec61883 -jack -ladspa -libcaca -libressl -librtmp -libsoxr -libv4l -lzma* (-mipsdspr1) (-mipsdspr2) (-mipsfpu) -modplug (-neon) -openal -openssl -opus -oss -pic -quvi -samba -schroedinger -sdl* -snappy -speex -ssh -static-libs {-test} -vaapi -vdpau -xcb -zvbi" ABI_X86="(64) -32* (-x32)" CPU_FLAGS_X86="avx fma3 fma4 mmx mmxext sse sse2 sse3 sse4_1 sse4_2 ssse3 xop -3dnow -3dnowext -avx2" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-video/ffmpeg:0

  (media-video/ffmpeg-2.8.6:0/54.56.56::gentoo, ebuild scheduled for merge) pulled in by
    media-video/ffmpeg (Argument)

  (media-video/ffmpeg-2.8.6:0/54.56.56::gentoo, installed) pulled in by
    >=media-video/ffmpeg-2.8.5:0/54.56.56=[abi_x86_32(-),abi_x86_64(-)] required by (media-plugins/gst-plugins-libav-1.6.3:1.0/1.0::gentoo, installed)
                                                                                                                                                                       
    >=media-video/ffmpeg-2.8.5:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-plugins/gst-plugins-libav-1.6.3:1.0/1.0::gentoo, installed)

It appears I already have the latest packages yet they conflict, any idea what this might be?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...