Jump to content
  • 0
Moopie35

Cinnamon installation causes problems with eselect-ruby for

Question

Hello everybody,

 

I'm currently trying to install Cinnamon Desktop in Funtoo Current but i get a problem with the package eselect-ruby and ruby 2.3.

When i try emerge gnome-extra/cinnamon i get : http://pastebin.com/zF5ktRcy

So i put "==dev-lang/ruby-2.3.0" in /etc/portage/package.unmask

However, the problem continue, i get : http://pastebin.com/dSuvgBtm

 

The eselect-ruby-20151229 is impossible to install !

 

What to do ?

Thanks.

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Please  include your command and the complete output in the paste.
Output from cinnamon mix-ins on my current system with lxde mix-in installed.
app-misc/tracker has both gstreamer and ffmpeg enabled which is not allowed.

the following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( gstreamer ffmpeg )

Line 179 from my output ffmpeg is disabled so it builds with gstreamer
[ebuild N ] app-misc/tracker-1.4.1:0/100::gentoo USE="exif flac gif gstreamer gtk iso jpeg miner-fs mp3 nautilus pdf tiff upower vorbis xml -cue (-eds) -ffmpeg -firefox-bookmarks -gsf -iptc (-libav) -networkmanager -playlist -rss -stemmer {-test} -thunderbird -upnp-av -xmp -xps" 5,799 KiB

Disable either gstreamer or ffmpeg in /etc/portage/package.use for tracker will solve the conflict.

echo "app-misc/tracker -ffmpeg" >> /etc/portage/package.use/tracker
OR
echo "app-misc/tracker -gstreamer" >> /etc/portage/package.use/tracker

There is no /usr/portage/app-eselect/eselect-ruby/eselect-ruby-20151229.ebuild
I don't have any ruby versions unmasked or installed my system.
Portage would install:
[ebuild N ] app-eselect/eselect-ruby-20141227::gentoo 0 KiB
[ebuild N ] dev-lang/ruby-2.2.4:2.2::gentoo USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -jemalloc -libressl -rubytests -socks5 -xemacs" 10,223 KiB
[ebuild N ] dev-lang/ruby-2.1.8:2.1::gentoo USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -rubytests -socks5 -xemacs" 9,165 KiB
[ebuild N ] dev-lang/ruby-2.0.0_p648:2.0::gentoo USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -rubytests -socks5 -xemacs" CPU_FLAGS_X86="sse2" 8,113 KiB

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...