Jump to content
funtoo forums
  • 0
Sign in to follow this  
hlaube

Python single_target target abis

Question

I have a problem with the settings for python.

 

I want to use libreoffice, digikam and util-linux, all want to have python.

 

Without any settings in make.conf,  lensfun does not like me. but libroffice and util-linux are fine

!!! The ebuild selected to satisfy "media-libs/lensfun" has unmet requirements.
- media-libs/lensfun-0.3.2::gentoo USE="-doc -test" CPU_FLAGS_X86="sse sse2" PYTHON_SINGLE_TARGET="python3_3 python3_4 -python3_5" PYTHON_TARGETS="python3_3 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_4? ( python_targets_python3_4 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 )

Setting

PYTHON_ABIS="2.7  3.4"

does not make any difference.

 

Since lensfun wants an minimum python 3.3 I tried  in my make.conf 

PYTHON_SINGLE_TARGET="python3_3"

 

Now libreoffice is not satisfied, but lensfun and util-linux like me

!!! The ebuild selected to satisfy "app-office/libreoffice" has unmet requirements.
- app-office/libreoffice-5.0.4.2::gentoo USE="branding cups dbus gtk java kde (-aqua) -bluetooth -coinmp -collada -debug -eds (-firebird) -gltf -gnome -gstreamer -gtk3 -jemalloc -libressl -mysql -odk -postgres (-telepathy) -test -vlc" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="-python2_7 -python3_4 -python3_5" PYTHON_TARGETS="python2_7 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python2_7 python_single_target_python3_4 python_single_target_python3_5 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python2_7 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python2_7? ( python_targets_python2_7 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 ) bluetooth? ( dbus ) collada? ( gltf ) gnome? ( gtk ) eds? ( gnome ) telepathy? ( gtk ) libreoffice_extensions_nlpsolver? ( java ) libreoffice_extensions_scripting-beanshell? ( java ) libreoffice_extensions_scripting-javascript? ( java ) libreoffice_extensions_wiki-publisher? ( java )

Setting in the make.conf

 

PYTHON_SINGLE_TARGET="python3_4"
PYTHON__TARGET="python3_4"

results into success with libreoffice and lensfun, but util-linux does not play

!!! The ebuild selected to satisfy "sys-apps/util-linux" has unmet requirements.
- sys-apps/util-linux-2.27.1::gentoo USE="cramfs ncurses nls pam python readline static-libs suid udev unicode -caps -fdformat -kill (-selinux) -slang -systemd -test -tty-helpers" ABI_X86="64 -32 -x32" PYTHON_SINGLE_TARGET="python3_4 -python2_7 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_4"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python? ( python_single_target_python3_4? ( python_targets_python3_4 ) )

  The above constraints are a subset of the following complete expression:
    python? ( exactly-one-of ( python_single_target_python2_7 python_single_target_python3_3 python_single_target_python3_4 ) python_single_target_python2_7? ( python_targets_python2_7 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 ) )

I also tried two targets into

 

PYTHON_SINGLE_TARGET="python2_7 python3_4"
PYTHON__TARGET="python2_7 python3_4"

 

Does not work with one of the three ether.  I am pretty sure, there is a simple solution, since two days I do not find it.

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

File a report at bugs.funtoo.org
Link the report to https://bugs.funtoo.org/browse/FL-3026
Solution in https://bugs.funtoo.org/browse/FL-3026 works on my current pure64 system with python-2.7.10-r1 and python-3.3.5-r2 installed.

Add to /etc/portage/package.use

media-libs/lensfun -python_single_target_python3_4
funtoo rj # emerge -pv lensfun

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] media-libs/lensfun-0.3.2::gentoo  USE="-doc {-test}" CPU_FLAGS_X86="sse sse2" PYTHON_SINGLE_TARGET="python3_3 -python3_4 -python3_5" PYTHON_TARGETS="python3_3 -python3_4 -python3_5" 767 KiB

Total: 1 package (1 new), Size of downloads: 767 KiB

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×