Jump to content
Funtoo Linux
  • 0
maldoror

Is ubuntu 14.04 LTS a good live cd for a funtoo install?

Question

I tried installing funtoo from ubuntu and when it came time to chroot ubuntu would not recognize this command:

env -i HOME=/root TERM=$TERM chroot . bash -l

When I ran the previous command it echoed: env: chroot: No such file or directory

And if I ran only the chroot portion of it it said something about illegal instruction and a core dumped.

 

I thought maybe the problem was my stage tarball: intel64-sandybridge subarch, my processor is a Intel? Pentium® CPU G630 @ 2.70GHz ? 2 I think that was the right one.

 

I'm completely lost as to what the problem is.

 

I will try the install again with systemrescuecd, I'm worried it will be a waste of time if there is something wrong with the stage tarball.

 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

I used lubuntu-32bit livecd to install 32bit funtoo stable and ran into same error.
In the case of ubuntu based livecd clearing the environment removes PATH from shell.
Shell can't find env or chroot without knowing the PATH.

 env: chroot: No such file or directory

Use which command to find path to env:

root@lubuntu:/mnt/funtoo# which env
/usr/bin/env

Use which command to find path to chroot:

root@lubuntu:/mnt/funtoo# which chroot
/usr/sbin/chroot

Command on 32-bit lubuntu to chroot into stage3-generic_32-funtoo-stable-2015-10-05.tar.xz

extracted to /mnt/funtoo:

root@lubuntu:/mnt/funtoo# /usr/bin/env -i HOME=/root TERM=$TERM /usr/sbin/chroot . bash -l
lubuntu / #
 

Shortcut:

root@lubuntu:/mnt/funtoo# env -i PATH=$PATH HOME=/root TERM=$TERM chroot . bash -l
lubuntu / #

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×