Jump to content
  • 0

Can't emerge desktop


tbill
 Share

Question

Always used kde before with Gentoo; never had a problem.  Now kde install borks at pda-apps/libplist.  Couldn't get past it, so I tried Gnome. Same,  WTF?  Tried Cinnamon and xfce; all same.  Granted, it's been awhile since I left Linux alone (damned MS and its then-president!), but I didn't expect this prob when I came back to the light side.  Had no probs installing the basic OS, or even getting X going with twm.  Cannot see my way past this.  Thanks to anyone in advance for a successfully helping hand!

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Check again as some changes were made last night that may resolve your issue.

emerge --sync

I had problem with pda-apps/libplist described in my funtoo bug report:   https://bugs.funtoo.org/browse/FL-3050
Oleg made changes which enabled me to merge pda-apps/libplist
Oleg commented on pda-apps/libplist gentoo bug report : https://bugs.gentoo.org/show_bug.cgi?id=548372#c5
Oleg add package.mask 

diff --git a/profiles/package.mask/funtoo-staging-oleg b/profiles/package.mask/funtoo-staging-oleg
index 783913d..8d3fdd4 100644
--- a/profiles/package.mask/funtoo-staging-oleg
+++ b/profiles/package.mask/funtoo-staging-oleg
@@ -1,3 +1,6 @@
+# mask broken versions of libplist until https://bugs.gentoo.org/show_bug.cgi?id=548372 is fixed.
+>=app-pda/libplist-1.11-r2
+
 # temporarily mask dev-util/sysdig, that require, EAPI=6 libb64. It doesnt have reverse deps. Until FL-3010 covered.
 >=dev-util/sysdig-0.5

New mask downgrades app-pda/libplist-1.12  to app-pda/libplist-1.11-r1 on my current pure64 system.

funtoo rj # emerge -avuDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/nss-3.21-r2::gentoo [3.21-r1::gentoo] USE="cacert nss-pem -utils" 0 KiB
[ebuild     UD ] dev-lang/python-2.7.10-r1:2.7::gentoo [2.7.10-r3:2.7::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened -tk -wininst (-libressl%)" 0 KiB
[ebuild   R    ] dev-lang/python-3.3.5-r2:3.3::gentoo  USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -doc -examples -hardened -tk -wininst (-libressl%)" 0 KiB
[ebuild  r  UD ] app-pda/libplist-1.11-r1:0/2::gentoo [1.12:0/3::gentoo] USE="python -static-libs" PYTHON_TARGETS="python2_7 (-python3_3%*) (-python3_4%) (-python3_5%)" 0 KiB
[ebuild     U  ] dev-python/numpy-1.10.4::gentoo [1.10.2-r1::gentoo] USE="-doc -lapack {-test}" PYTHON_TARGETS="python2_7 python3_3 -python3_4 -python3_5" 3,975 KiB
[ebuild  rR    ] app-pda/libusbmuxd-1.0.9:0/2::gentoo  USE="-static-libs" 0 KiB
[ebuild  rR    ] sys-power/upower-0.99.3-r1:0/3::gentoo  USE="deprecated ios -introspection" 0 KiB
[ebuild  rR    ] gnome-base/gvfs-1.24.2::gentoo  USE="bluray cdda gtk http ios mtp udev udisks -afp -archive -fuse -gnome-online-accounts -gphoto2 -libsecret -nfs -samba -systemd {-test} -zeroconf" 0 KiB

Total: 8 packages (2 upgrades, 2 downgrades, 4 reinstalls), Size of downloads: 3,975 KiB

The following packages are causing rebuilds:

  (app-pda/libplist-1.11-r1:0/2::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (app-pda/libusbmuxd-1.0.9:0/2::gentoo, ebuild scheduled for merge)
    (sys-power/upower-0.99.3-r1:0/3::gentoo, ebuild scheduled for merge)
    (gnome-base/gvfs-1.24.2:0/0::gentoo, ebuild scheduled for merge)

Provide output from these commands to get assistance:

emerge --info
emerge libplist -pv
Link to comment
Share on other sites

  • 0

I know I should have posted the emerge info, but....  Seemed to me that there would be so many complaints about this that the emerge info would be a glut on the forum.

 

And thanks for responding!  I so recently ran an rsync and etc that I figured I'd have the most recent everything.  Evidently not!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...