Jump to content
  • 0

Annoying scroll on terminal


riskio
 Share

Question

Hi everyone,

I have an annoying problem using the terminal and I cannot look for a solution on google because I don't know how to phrase it. 

That is why I am asking here..

 

So basically: 

when I have load of text on terminal (for instance after a dmesg) and I try to scroll up to look for the bit of text I am interested in, after 

a random amount of time the terminal automatically scrolls down where the cursor is...

 

Also I noticed that when xscreensaver is running, the login gui comes out without any input from keyboard. And do you know in xscreensaver there

is an "elapsing time" bar that gives you more time ( the bar increase ) when you start type in?

well it increase once without any input from me... 

 

so I thought I have some random input from the keyboard... but how to solve this annoying problem? 

 

I have been trying to track down the event generated with xev but it is quite difficult..

 

on the terminal I have temporarily solved un-ticking "scroll on keyboard press", but it is not a reasonable permanent solution ... 

the whole system, as xscreensaver confirm, is affected...

 

Any idea?

any particular kernel module to load/unload?

 

thank you!

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hi everyone!

I am sorry if I have never gave further updates to this forum! 

So the issue I have tried to describe is a bug on xfce4-power-manager from 1.5.2. Basically in "presentation mode" power manager every now and then send dummy keystroke to keep the system awake. 

Everything is written in Unix & Linux Exchange.

 

Thank you

Andrea

Link to comment
Share on other sites

  • 0

I don't understand you description, but I'll guess. As far as I know, if you are in X Windows and using xterm or xfce4-terminal, the terminal emulator window will automatically scroll down to show new output each time it is displayed. Maybe you can try several terminal emulators and find one that locks to a position. With xfce4-terminal (that I use with the xfce4 desktop) I have edit > preferences... > general > scrolling > checkbox for scroll on output. I never tried unchecking it, but that sort of thing may be what you want.

 

I notice that my screensaver does not automatically show the login prompt when I open my laptop. I just hit a modifier key alone (cntrl or shift) to see the prompt to unlock the screen. I have a power manager that has a setting for locking the screen or not if the lid is closed. I am not sure what you mean in your reference to xscreensaver.

 

I don't know why you want to load or unload kernel modules. Maybe you mean to include a kernel module with your kernel setup (maybe using genkernel not emerge). I don't know why you would not be looking for a portage package to include desktop goodies/add-ons (i.e. http://goodies.xfce.org).If it is not in the portage tree, you probably don't want it.

 

Good luck!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...