Jump to content
Read the Funtoo Newsletter: Summer 2023 ×

network not usable for 45 seconds

Recommended Posts

When I run '/etc/init.d/netif.eth0 start', it immediately returns succcess and ifconfig confirms I have an ip address.  'rc-status' shows the netif.eth0 service is started.  System logs show "e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx".  But I find that the network is not usable for approximately 45 seconds after it is supposedly up.


Any ideas what could be causing the delay?  My test tries to ping another machine on the same network by ip address.  So DNS and gateway should not be involved. 




By the way, I have a static IP address.

Link to comment
Share on other sites

Did you try to use just bare ifconfig without any scripts to set your network up temporary? Did you try to ping a local IP address? Was it an IP addres from an other subnetwork? Was it a global address? Did you use a DNS name? With the amount of information given it is hard to tell what is wrong with your system for a telepathy is currently not available for me.

Link to comment
Share on other sites

Based on your suggestion I ran '/etc/init.d/netif.eth0 stop', then configured my ip address and netmask wtih ifconfig.  I got the same results.  So maybe it's got to do with my environment.  I will try to test this on a different network this weekend and report back.


As to your other questions:  I am pinging a private IP address on the same subnet.  No DNS, no routers/gateways.

Link to comment
Share on other sites

This way it is pretty much narrows down to 3 possible sources of problem:

1) The kernel. If you are using a custom kernel you can try something standard like booting from a live CD and trying the same thing. There are some idiotic distros like Arch for axample with no ifconfig included on a live CD for an unknown reason. If that apears to be the case you can use "ip" command instead with a slightly different syntax.

2) Your hardware (an NIC). Most likely this is not the case but you can try to connect an other machine to the same port to make sure.

3) Your network infrastructure. In most cases there is nothing can be done about it but you can try to replace your network swicth or hub with something simple and dumb if it is possible in your situation. You can also try to connect the machine you are trying to ping somewhere close to the pinging system. You can use an ethernet crosscable to be 100% sure but something like an old spare 5-port hub should do just fine.


P.S. I hope you are not typing the commands to the machine through a remote terminal like ssh or telnet. The whole discussion would apear pointless otherwise.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...