Jump to content


  • Content Count

  • Joined

  • Last visited

  • Days Won


hick518 last won the day on May 4 2016

hick518 had the most liked content!

About hick518

  • Rank
    Advanced Member

Recent Profile Visitors

735 profile views
  1. For a while now I haven't been able to print to my Brother DCP-7065dn printer. It used to work. I've got net-print/brother-dcp-7065dn-drivers installed. I've also tried re-installing it. One thing I notice is that all binaries in /usr/local/Brother/Printer/DCP7065DN are 32-bit. Should these work on my Funtoo 1.4 system? I've set cups logging to "debug", but haven't gotten anything useful out of the logs.
  2. Thanks bcowan, I had already tried that and the situation didn't improve. As it turns out, as long as I used '--backtrack=30' for every emerge operation, it worked ok. On one of my previous upgrades, that didn't help so on this one I didn't try it right away. But I will from now on!
  3. Adding '--backtrack=30' fixed this. emerge --backtrack=30 --jobs=3 -u =dev-lang/python-3.7* But now I'm getting similar conflicts when running the next step, ' emerge -auDN --backtrack=30 @world --jobs=3 --exclude dev-lang/perl'. Any suggestions on how to handle these types of conflicts in general would be appreciated.
  4. # eselect python list Available Python interpreters, in order of preference: [1] python3.6 [2] python2.7 (fallback)
  5. I've upgraded 3 systems from 1.3 to 1.4, and each one has caused me major headaches. I'm on my fourth one now, and figured it's time to ask for help. I'm following the instructions here, and I'm up to the point of upgrading python: https://www.funtoo.org/Upgrade_Instructions/1.4-release # emerge -u =dev-lang/python-3.7* Connected to xxxxxxxxx Fetching /packages/Packages to /tmp/tmprupi7h74 /packages/Packages 100% 1839KB 226.0KB/s 00:08 Calculating dependencies... done! [binary U ] app-arch/bzip2-1.0.8 [1.0.6-r9] USE="-abi_riscv_lp64% -abi_risc v_lp64d% -split-usr%" [binary U ] sys-libs/readline-8.0 [7.0_p5] USE="-abi_riscv_lp64% -abi_riscv _lp64d%" [binary NS ] dev-lang/python-3.7.3 [2.7.15, 3.6.8] !!! Multiple package instances within a single package slot have been pulled !!! into the dependency graph, resulting in a slot conflict: sys-libs/readline:0 (sys-libs/readline-8.0:0/8::core-kit, binary scheduled for merge) pulled in by >=sys-libs/readline-4.1:0/8= required by (dev-lang/python-3.7.3:3.7/3.7m::py thon-kit, binary scheduled for merge) ^^^^^ (sys-libs/readline-7.0_p5:0/7::core-kit, installed) pulled in by sys-libs/readline:0/7= required by (net-dns/bind-tools-9.12.2_p2-r1:0/0::cor e-kit, installed) ^^^^^ sys-libs/readline:0/7= required by (app-crypt/gnupg-2.2.11:0/0::core-kit, in stalled) ^^^^^ sys-libs/readline:0/7= required by (net-wireless/bluez-5.50-r1:0/3::core-kit , installed) ^^^^^ >=sys-libs/readline-4.1:0/7= required by (dev-lang/python-3.6.8:3.6/3.6m::py thon-kit, installed) ^^^^^ >=sys-libs/readline-4.1:0/7= required by (net-misc/ntp-4.2.8_p12:0/0::core-k it, installed) ^^^^^ sys-libs/readline:0/7= required by (sys-apps/util-linux-2.33:0/0::core-kit, installed) ^^^^^ sys-libs/readline:0/7= required by (net-fs/samba-4.9.2-r1:0/0::core-server-k it, installed) ^^^^^ ^^^^^ sys-libs/readline:0/7= required by (net-wireless/bluez-5.50-r1:0/3::core-kit, installed) ^^^^^ >=sys-libs/readline-4.1:0/7= required by (dev-lang/python-3.6.8:3.6/3.6m::python-kit, installed) ^^^^^ >=sys-libs/readline-4.1:0/7= required by (net-misc/ntp-4.2.8_p12:0/0::core-kit, installed) ^^^^^ sys-libs/readline:0/7= required by (sys-apps/util-linux-2.33:0/0::core-kit, installed) ^^^^^ sys-libs/readline:0/7= required by (net-fs/samba-4.9.2-r1:0/0::core-server-kit, installed) ^^^^^ (and 14 more with the same problems) app-arch/bzip2:0 (app-arch/bzip2-1.0.8:0/1::core-kit, binary scheduled for merge) pulled in by app-arch/bzip2:0/1= required by (dev-lang/python-3.7.3:3.7/3.7m::python-kit, binary scheduled for merge) ^^^^^ (app-arch/bzip2-1.0.6-r9:0/0::core-kit, installed) pulled in by app-arch/bzip2:0/0= required by (dev-lang/python-2.7.15:2.7/2.7::python-kit, installed) ^^^^^ (and 1 more with the same problem) NOTE: Use the '--verbose-conflicts' option to display parents omitted above !!! The slot conflict(s) shown above involve package(s) which may need to !!! be rebuilt in order to solve the conflict(s). However, the following !!! package(s) cannot be rebuilt for the reason(s) shown: (net-wireless/bluez-5.50-r1:0/3::core-kit, installed): ebuild is masked or unavailable (net-fs/samba-4.9.2-r1:0/0::core-server-kit, installed): ebuild is masked or unavailable (sys-apps/util-linux-2.33:0/0::core-kit, installed): ebuild is masked or unavailable (net-dns/bind-tools-9.12.2_p2-r1:0/0::core-kit, installed): ebuild is masked or unavailable (net-misc/ntp-4.2.8_p12:0/0::core-kit, installed): ebuild is masked or unavailable (app-crypt/gnupg-2.2.11:0/0::core-kit, installed): ebuild is masked or unavailable It may be possible to solve this problem by using package.mask to prevent one of those packages from being selected. However, it is also possible that conflicting dependencies exist such that they are impossible to satisfy simultaneously. If such a conflict exists in the dependencies of two different packages, then those packages can not be installed simultaneously. You may want to try a larger value of the --backtrack option, such as --backtrack=30, in order to see if that will solve this conflict automatically. For more information, see MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. I've tried manually upgrading readline and bzip2, but that just results in more conflicts. Any idea what my best path forward is? Each of the last three upgrades took me several days to work out, and I'm hoping the next two won't have to be as bad.
  6. Thanks Cardinal. The Follow button is white until you are actually following. I still think it's a good idea to give some other type of notification of upgrades, although it is a little less critical for me now that I'm following News and Announcements per your suggestion. For instance, Ubuntu utilizes motd to let you know when you log in at the CLI that a release upgrade is available. Following News and Announcements isn't exactly going to fill my inbox, but it does contain a wide variety of news. For instance, "Funtoo 1.4 is released" and "Funtoo is now on Discord" have significantly different levels of importance to me, especially since "Funtoo 1.4 is released" means that my 1.3 system will stop receiving updates at some point in time. Anyway, just food for thought for the powers that be. Thanks again, Cardinal.
  7. I don't frequent the forum, and this is the second or third time now that a big upgrade was made available that I didn't know about. The first time I went for months without any package updates because I didn't know I had to upgrade to a newer Funtoo version. I would like to suggest that a notification of available upgrade be presented when running 'ego sync' or 'emerge @world'. The notification should tell the sysadmin that there's a newer Funtoo version available, and the date it was made available (so the sysadmin will know how mature the upgrade is and also how out of date he is). For instance: Funtoo 1.4 was made available on August 1, 2019. See https://www.funtoo.org/Upgrade_Instructions/1.4-release
  8. When I upgrade to 1.4, I'm instructed to use a gfxcard mix-in. If I do that, should I remove the VIDEO_CARDS line from make.conf?
  9. An upgrade to sssd 1.16.3 today fixed the problem.
  10. After upgrading per the instructions here: https://www.funtoo.org/Upgrade_Instructions sssd will not start, and that prevents me from logging in with any LDAP user. I get the following error: failed to get [krb5_rcache_dir] from [config/sssd] It looks like as part of that upgrade, sssd went from version 1.12.1 to 1.13.1. I think ldb is used by sssd, and that went from version 1.3.5 to 1.4.2. sssd also requires tdb, and that was upgraded from 1.3.15 to 1.3.16. The error message indicates it may be a kerberos problem, but I am not using kerberos for authentication (at least, my sssd.conf contains no references to kerberos). Any ideas how to debug this?
  11. https://www.funtoo.org/Upgrade_Instructions The upgrade instructions say that after upgrading gcc (I went from 5.4.0 to 7.3.1): "For upgrading to 1.2, you have to rebuild all packages, which will ensure that your system is fully optimized with the new gcc." Before I do this, I want to make sure it is really necessary. I did not change my subarch (something which was covered in those upgrade instructions). I am staying with "generic_64". So do I still need to rebuild all the packages on my system?
  12. Sound in firefox-bin recently stopped working for me. It gives me a message that I may need to install pulseaudio, but pulseaudio is already installed. Is there some new setting or use flag that's needed to make this work? Sound was working fine for me up until a couple weeks ago. Sound works for all my other applications.
  13. Thanks palica. I never considered that they were supposed to look like that. The gray icons look an awful lot like "unavailable" grayed-out items.
  14. After a recent upgrade, gimp's icons have lost all their color. See attached screenshot. $ emerge --info gimp ... media-gfx/gimp-2.9.6::media-kit was built with the following: USE="alsa jpeg2k pdf python udev webp wmf -aalib (-altivec) (-aqua) -debug -doc -gnome -mng -openexr -postscript -smp -test -vector-icons -xpm" CPU_FLAGS_X86="mmx sse" LINGUAS="-am -ar -ast -az -be -bg -br -ca -ca@valencia -cs -csb -da -de -dz -el -en_CA -en_GB -eo -es -et -eu -fa -fi -fr -ga -gl -gu -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kn -ko -lt -lv -mk -ml -ms -my -nb -nds -ne -nl -nn -oc -pa -pl -pt -pt_BR -ro -ru -rw -si -sk -sl -sr -sr@latin -sv -ta -te -th -tr -tt -uk -vi -xh -yi -zh_CN -zh_HK -zh_TW" PYTHON_TARGETS="python2_7" Do I need to change my USE flags? Or maybe install some icon package?
  • Create New...