Jump to content
funtoo forums
  • 0
kanliot

wierdness installing funtoo. (lxqt)

Question

new funtoo installer here.  Installed from chroot/tarball.

 

everything was going ok, untill I installed lxqt

 

i got this error:
xinit? QXcbConnection: Could not connect to display
 

turns out xorg-x11 wasn't installed.  wtf?  I installed lxqt but no xorg-x11?

is this a normal error?

 

also the /etc/portage/profile directory wasn't there,

so I had to create that and the /etc/portage/profile/use.mask file

Why do I feel like i'm fumbling in the dark here?

 

then i had more xorg errors

turns out  x11-base/xorg-drivers wasn't emerged after xorg-x11

is this a normal error?

 

despite people on irc saying the lxqt metapackage had applications, All i had were pcmanfm and a web browser.

any comments on that?

 

the one that took the longest to figure out was when I tried installing qterminal

http://pastie.org/10258016

"!!! The ebuild selected to satisfy "qterminal" has unmet requirements.
- x11-terms/qterminal-0.6.0::gentoo USE="-debug -qt4 -qt5"

 

after straining my brain past its design limits, i figured out taht to install qterminal  I had to add a line to /etc/portage/make.conf with:

USE="qt5"

is this normal error?

 

startx was only working for the root user until i did a echo "exec startlxqt" > .xinitrc

xdm still isn't working.  Xdm flashes like it's doing something, but then flashes back to the xdm screen.

 

so i have qterminal and stuff now.  It's working.

so It feels like i'm still fumbling around in the dark.  Why was this stuff necessary?  This can't be a normal funtoo install can it? 

I feel that I may have found a bug, or that I really don't understand how to use funtoo.  Please shed some light on the questions in bold.  TIA.

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

I have not installed LXQt but will try to help.  :)

 

turns out xorg-x11 wasn't installed.  wtf?  I installed lxqt but no xorg-x11?
is this a normal error?

 
Normally the X Window System (x11-base/xorg-x11) is merged first as a separate step before merging a desktop environment such as LXQt. Unfortunately the LXQt wiki page is currently lacking a reminder/warning about xorg-x11. I too would have expected portage to have complained about X being absent when merging LXQt. I had a similar issue once with enlightenment (forgetting xorg-x11). 

EDIT: I have updated the LXQt wiki to mention xorg-x11 on clean installs.
 

also the /etc/portage/profile directory wasn't there,
so I had to create that and the /etc/portage/profile/use.mask file
Why do I feel like i'm fumbling in the dark here?

Do you recall why portage asked you to create /etc/portage/profile/use.mask?
 

then i had more xorg errors
turns out  x11-base/xorg-drivers wasn't emerged after xorg-x11
is this a normal error?

Before merging x11-base/xorg-x11 one needs to set the variables VIDEO_CARDS and INPUT_DEVICES in /etc/portage/make.conf (see http://www.funtoo.org/X_Window_System). With those set emerge xorg-x11 should pull in xorg-drivers (e.g. x11-drivers/xf86-video-* packages)

 

 

the one that took the longest to figure out was when I tried installing qterminal

http://pastie.org/10258016

"!!! The ebuild selected to satisfy "qterminal" has unmet requirements.
- x11-terms/qterminal-0.6.0::gentoo USE="-debug -qt4 -qt5"

 

after straining my brain past its design limits, i figured out taht to install qterminal  I had to add a line to /etc/portage/make.conf with:

USE="qt5"

is this normal error?

Portage is telling you that x11-terms/qterminal requires one (and only one) of the USE flags "qt4" and "qt5". The fact that it reported "-qt4 -qt5" indicates that neither one was enabled'. Adding USE="qt5" to /etc/portage/make.conf certainly solved that problem.

Now I could be wrong but it seems strange to me that neither one was set for you. After the base (stage3) install but before emerge lxqt-meta, did you add any profile mix-ins such as 'lxqt'? (In other words, what does eselect profile list or epro show give you?)

 

 

startx was only working for the root user until i did a echo "exec startlxqt" > .xinitrc

xdm still isn't working.  Xdm flashes like it's doing something, but then flashes back to the xdm screen.

What do you mean by "flashes back to the xdm screen"? Back to the terminal?

 

Have you considered using a Display Manager? (see http://www.funtoo.org/Package:XDM_(Display_Manager)). That may be easier and give you a nice login screen.  ;)

 

 

so i have qterminal and stuff now.  It's working.

so It feels like i'm still fumbling around in the dark.  Why was this stuff necessary?  This can't be a normal funtoo install can it? 

You have described a tricky experience but well done for getting there in the end.  :)

 

Having merged x11-base/xorg-x11 first before LXQt would have been helpful but unfortunately the current LXQt page lacks a reminder.

 

Regarding LXQt applications - I do not know the answer to that.

 

Was the lack of qt4 or qt5 USE flags a bug? It would help to know first what profile/mix-ins you set (if any).

 

Need more information on your xdm problem.

Share this post


Link to post
Share on other sites
  • 0

1st, let me thank you intensely for the quality of the reply!

 

After the base (stage3) install but before emerge lxqt-meta, did you add any profile mix-ins such as 'lxqt'? (In other words, what does eselect profile list or epro show give you?)

 

 

I'm fairly sure I set the mix-ins after I did the emerge lxqt-meta.
 

 

Before merging x11-base/xorg-x11 one needs to set the variables VIDEO_CARDS and INPUT_DEVICES in /etc/portage/make.conf

 

 

I humbly suggest that that page be linked in the 2 different  funtoo "get started" install instructions.  As well as the lxqt page.

 

 

as for using lightdm, that would require the "gnome" use flag IIRC, is that a problem on my desktop?  Is that something I should try?

Share this post


Link to post
Share on other sites
  • 0

I wish I knew what was going on with qt5 at the moment. As far as I know qt5 should be enabled on a per package basis at this time.

But if it works, then leave it.

I have USE="qt4" and per package as needed I add qt5.  Here is the line you are looking for that is important.

The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( qt4 qt5 )

And this is simply informational and telling you what you need, is normal. Sorry it does not always just give you one option. Sometimes the first option such as qt4 above is the best choice and the one I try.

Sometimes is the second option that ends up working.

 

I often install  kde before xorg-x11, only because it happens to be late and going to bed, so let the big package run over night while sleeping.

So the order does not really matter.

Share this post


Link to post
Share on other sites
  • 0

You didn't follow the install guide then.

 

What's your point exactly?  The description of mix-ins was so vague, how was I to know that an "emerge -uavDN @world" wouldn't fix it.  I didn't even know there was an lxqt funtoo-wiki page until i found it by accident on google.  and I don't think that was the cause of the problem anyhow. So my mistake isn't relevant to the lxqt problem.

Share this post


Link to post
Share on other sites
  • 0

The point is that if you had followed the install guide then you would have set up a flavor and mixin which would have automatically set things like X. There was no need for you to view the wiki page to "fumble in the dark", the install guide cleary tells you:

 

To view available profiles: (chroot) # epro list

 

and then details how to enable whichever you like. Did you look at the output of epro list? There is a listing for lxqt there.

 

This is why it is relevant that you didn't follow the documentation. The other issues you mention are simple setting up USE flags and when this needs to be done portage explains what you should do.

Share this post


Link to post
Share on other sites
  • 0

The point is that if you had followed the install guide then you would have set up a flavor and mixin which would have automatically set things like X. There was no need for you to view the wiki page to "fumble in the dark", the install guide cleary tells you:

 

 

and then details how to enable whichever you like. Did you look at the output of epro list? There is a listing for lxqt there.

 

This is why it is relevant that you didn't follow the documentation. The other issues you mention are simple setting up USE flags and when this needs to be done portage explains what you should do.

 

Besides assuming that lxqt-meta would pull in xorg, I don't see what other mistake I made.  The wiki certainly doesn't say that if you set your profile late you will be fubar.    And no, portage doesn't tell you how how you need to fix make.conf.    Been on here hours, and I haven't seen an explanation of profiles. 

 

quoting the wiki: 

The first step in setting up a graphical environment is to set up the X Window System. Then, you will be able to install the graphical environment of your choice. GNOME is a popular option for new users.

 

 

Ok I'm an ignorant neophyte.  I just typed "emerge xorg" instead of googling your wiki to find the setup instructions for a package that I didn't know I needed to configure, which portage installed without xorg's drivers.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...