Jump to content
funtoo forums

whiteghost

Members
  • Content Count

    34
  • Joined

  • Last visited

  • Days Won

    2

whiteghost last won the day on July 23 2016

whiteghost had the most liked content!

1 Follower

About whiteghost

  • Rank
    Advanced Member
  1. tmpfs /tmp tmpfs noatime 0 0 tmpfs /var/tmp/portage tmpfs size=8G,uid=portage,gid=portage,mode=775,noatime 0 0 tmpfs /dev/shm tmpfs nodev,nosuid,noexec,noatime 0 0
  2. google linuxsea. go to chapter 7, manually configuring a kernel. here is pappy's last seed. i copy it to linux folder, run make old config, then make menuconfig to add my drivers. well, that didn't work. i can't upload file correctly. the link on http://www.funtoo.org/Additional_Kernel_Resources for kernel seeds is dead here is a good link http://www.elilabs.com/~pappy/
  3. https://www.google.com/search?q=during+the+boot%2C+the+system+gets+stuck+in%3A+Wiping+%2Ftmp+directory&oq=during+the+boot%2C+the+system+gets+stuck+in%3A+Wiping+%2Ftmp+directory&aqs=chrome..69i57&sourceid=chrome&ie=UTF-8 http://deshack.net/debian-hangs-during-boot/ http://swift.siphos.be/linux_sea/kernelbuilding.html
  4. after grub loads my kernel i'm at login in less than 2 seconds. i build kernels with as few drivers and modules as i can.
  5. there was a kernel paramater --slow-usb or something like that i can't find it now. there is rootwait /usr/src/linux/Documentation/kernel-parameters
  6. sandro, i think you are missing the point on pstate driver. when i use i7z, it may show frequency maxed out at 3.9GHz, but c1 state shows 97 percent of processor is in halt state. isn't that power saving? for a long time i had microcode enabled in kernel and would see in dmesg something about microcode driver. i assumed it was working but there is more too it. i use git-sources. i use method two from this page https://fitzcarraldoblog.wordpress.com/2014/11/06/updating-intel-cpu-microcode-from-gentoo-linux/
  7. i7z works good for monitoring in real time and showing c states, which i think are more relevant than frequency. just moving my mouse around can raise frequency to max level
  8. i added cpupower to default runlevel with this line in conf.d START_OPTS="--governor powersave -d 1000MHz -u 2000MHz" and it works.
  9. Every 5.0s: cat /proc/cpuinfo | grep "MHz" Fri Jul 15 18:43:12 2016 cpu MHz : 3899.902 cpu MHz : 3900.329 cpu MHz : 3899.902 cpu MHz : 3900.115 look at documentation - /usr/src/linux/Documentation/cpu-freq/ i disable acpi driver enable pstate and powersave gov and pstate works automatically. googling pstate - it gets too technical for me. i use cpupower frequency info and cpupower frequency set
  10. # CPU Frequency scaling # CONFIG_CPU_FREQ=y # CONFIG_CPU_FREQ_STAT is not set # CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set CONFIG_CPU_FREQ_DEFAULT_GOV_POWERSAVE=y # CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set # CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND is not set # CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set # CONFIG_CPU_FREQ_DEFAULT_GOV_SCHEDUTIL is not set CONFIG_CPU_FREQ_GOV_PERFORMANCE=m CONFIG_CPU_FREQ_GOV_POWERSAVE=y # CONFIG_CPU_FREQ_GOV_USERSPACE is not set # CONFIG_CPU_FREQ_GOV_ONDEMAND is not set # CONFIG_CPU_FREQ_GOV_CONSERVATIVE is not set # CONFIG_CPU_FREQ_GOV_SCHEDUTIL is not set # # CPU frequency scaling drivers # CONFIG_X86_INTEL_PSTATE=y # CONFIG_X86_PCC_CPUFREQ is not set # CONFIG_X86_ACPI_CPUFREQ is not set # CONFIG_X86_SPEEDSTEP_CENTRINO is not set # CONFIG_X86_P4_CLOCKMOD is not set # # shared options # # CONFIG_X86_SPEEDSTEP_LIB is not set # # CPU Idle # CONFIG_CPU_IDLE=y # CONFIG_CPU_IDLE_GOV_LADDER is not set CONFIG_CPU_IDLE_GOV_MENU=y # CONFIG_ARCH_NEEDS_CPU_IDLE_COUPLED is not set CONFIG_INTEL_IDLE=y # cpupower frequency-info analyzing CPU 0: driver: intel_pstate CPUs which run at the same hardware frequency: 0 CPUs which need to have their frequency coordinated by software: 0 maximum transition latency: Cannot determine or is not supported. hardware limits: 800 MHz - 3.90 GHz available cpufreq governors: performance powersave current policy: frequency should be within 800 MHz and 3.90 GHz. The governor "powersave" may decide which speed to use within this range. current CPU frequency: 895 MHz (asserted by call to hardware) boost state support: Supported: yes Active: yes i do not have cpupower added to rc
  11. make sure /boot is mounted cd /usr/src/linux cp arch/x86/boot/bzImage /boot/<new-name>
  12. i have xorg-server-1.17.2-r1 try #echo "x11-base/xorg-server" >> /etc/portage/package.unmask
  13. It might be possible to break this cycle by applying any of the following changes: - dev-libs/openssl-1.0.2d (Change USE: -kerberos) - app-crypt/mit-krb5-1.13.2 (Change USE: -pkinit) do you really need kerberos use flag enabled? also i often install xorg-server from chroot with no problem
  14. i tried with and without clutter too. i can do without parole. just wonder why it never works for me.
×
×
  • Create New...