Jump to content
funtoo forums
  • 0
spuriousdata

emerge world forcing a bunch of stuff to 32-bit

Question

Ever since I did a sync on Friday, the following emerge update is trying to force a bunch of stuff to 32 bit. I didn't change anything in /etc/portage or /etc/make.conf.

user@host:~$ sudo emerge -auDN @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] virtual/libintl-0-r1  ABI_X86="32*"                                                                           
[ebuild   R    ] virtual/libiconv-0-r2  ABI_X86="32*"                                                                              
[ebuild   R    ] dev-util/pkgconf-0.9.11  ABI_X86="32*"                                                                            
[ebuild   R    ] net-libs/libasyncns-0.8-r3  ABI_X86="32*"                                                                            
[ebuild   R    ] virtual/pkgconfig-0-r1  ABI_X86="32*"                                                                                
[ebuild   R    ] media-libs/libogg-1.3.2  ABI_X86="32*"                                                                                
[ebuild   R    ] media-libs/webrtc-audio-processing-0.1-r1  ABI_X86="32*"                                                                 
[ebuild   R    ] sys-libs/ncurses-5.9-r4  ABI_X86="32*"                                                                                     
[ebuild   R    ] app-arch/bzip2-1.0.6-r7  ABI_X86="32*"                                                                                        
[ebuild   R    ] dev-libs/expat-2.1.0-r4  ABI_X86="32*"                                                                                        
[ebuild   R    ] dev-libs/gmp-6.0.0a  ABI_X86="32*"                                                                                              
[ebuild   R    ] dev-libs/libffi-3.2.1  ABI_X86="32*"                                                                                             
[ebuild   R    ] sys-apps/tcp-wrappers-7.6.22-r1  ABI_X86="32*"                                                                                    
[ebuild   R    ] sys-libs/readline-6.3_p8-r2  ABI_X86="32*"                                                                                         
[ebuild   R    ] virtual/libffi-3.0.13-r1  ABI_X86="32*"                                                                                            
[ebuild   R    ] dev-lang/orc-0.4.23  ABI_X86="32*"                                                                                                 
[ebuild   R    ] sys-libs/zlib-1.2.8-r1  ABI_X86="32*"                                                                                              
[ebuild   R    ] media-libs/libvorbis-1.3.5  ABI_X86="32*"                                                                                           
[ebuild   R    ] dev-libs/nettle-2.7.1-r4  ABI_X86="32*" 
[ebuild   R    ] media-libs/libjpeg-turbo-1.4.0  ABI_X86="32*" 
[ebuild   R    ] dev-libs/json-c-0.12  ABI_X86="32*" 
[ebuild   R    ] media-libs/freetype-2.6  ABI_X86="32*" 
[ebuild   R    ] media-libs/libpng-1.6.17  ABI_X86="32*" 
[ebuild   R    ] virtual/jpeg-0-r2  ABI_X86="32*" 
[ebuild   R    ] dev-libs/libpcre-8.37-r1  ABI_X86="32*" 
[ebuild   R    ] media-libs/libmng-2.0.2-r1  ABI_X86="32*" 
[ebuild   R    ] dev-libs/openssl-1.0.1m  ABI_X86="32*" 
[ebuild   R    ] x11-proto/xproto-7.0.27  ABI_X86="32*" 
[ebuild   R    ] x11-proto/xextproto-7.3.0  ABI_X86="32*" 
[ebuild   R    ] x11-proto/inputproto-2.3.1  ABI_X86="32*" 
[ebuild   R    ] x11-proto/kbproto-1.0.6-r1  ABI_X86="32*" 
[ebuild   R    ] x11-proto/renderproto-0.11.1-r1  ABI_X86="32*" 
[ebuild   R    ] dev-libs/libpthread-stubs-0.3-r1  ABI_X86="32*" 
[ebuild   R    ] x11-proto/videoproto-2.3.2  ABI_X86="32*" 
[ebuild   R    ] x11-proto/recordproto-1.14.2-r1  ABI_X86="32*" 
[ebuild   R    ] x11-proto/randrproto-1.4.1  ABI_X86="32*" 
[ebuild   R    ] x11-proto/xf86bigfontproto-1.2.0-r1  ABI_X86="32*" 
[ebuild   R    ] x11-proto/scrnsaverproto-1.2.2-r1  ABI_X86="32*" 
[ebuild   R    ] x11-libs/libICE-1.0.9  ABI_X86="32*" 
[ebuild   R    ] x11-libs/libXau-1.0.8  ABI_X86="32*" 
[ebuild   R    ] x11-libs/libXdmcp-1.1.2  ABI_X86="32*" 
[ebuild   R    ] x11-proto/fixesproto-5.0-r1  ABI_X86="32*" 
[ebuild   R    ] media-libs/fontconfig-2.11.93  ABI_X86="32*" 
[ebuild   R    ] media-libs/alsa-lib-1.0.29  ABI_X86="32*" 
[ebuild   R    ] sys-apps/attr-2.4.47-r3  ABI_X86="32*" 
[ebuild   R    ] dev-libs/libgpg-error-1.19  ABI_X86="32*" 
[ebuild   R    ] media-libs/flac-1.3.1-r1  ABI_X86="32*" 
[ebuild   R    ] dev-libs/libgcrypt-1.6.3-r1  ABI_X86="32*" 
[ebuild   R    ] media-libs/libsndfile-1.0.25-r1  ABI_X86="32*" 
[ebuild   R    ] dev-libs/libtasn1-4.5  ABI_X86="32*" 
[ebuild   R    ] dev-libs/icu-55.1-r1001  ABI_X86="32*" 
[ebuild   R    ] dev-db/sqlite-3.8.10.2  ABI_X86="32*" 
[ebuild   R    ] dev-libs/libxml2-2.9.2-r1001  ABI_X86="32*" 
[ebuild   R    ] x11-proto/xcb-proto-1.11-r1000  ABI_X86="32*" 
[ebuild   R    ] x11-libs/libxcb-1.11-r1  ABI_X86="32*" 
[ebuild   R    ] net-libs/gnutls-3.3.15  ABI_X86="32*" 
[ebuild   R    ] x11-libs/libX11-1.6.3  ABI_X86="32*" 
[ebuild   R    ] x11-libs/libXext-1.3.3  ABI_X86="32*" 
[ebuild   R    ] x11-libs/libXrender-0.9.8  ABI_X86="32*" 
[ebuild   R    ] x11-libs/libXfixes-5.0.1  ABI_X86="32*" 
[ebuild   R    ] x11-libs/libXi-1.7.4  ABI_X86="32*" 
[ebuild   R    ] x11-libs/libXcursor-1.1.14  ABI_X86="32*" 
[ebuild   R    ] x11-libs/libXrandr-1.4.2  ABI_X86="32*" 
[ebuild   R    ] x11-libs/libXv-1.0.10  ABI_X86="32*" 
[ebuild   R    ] x11-libs/libXScrnSaver-1.2.2-r1  ABI_X86="32*" 
[ebuild   R    ] x11-libs/libXtst-1.2.2  ABI_X86="32*" 
[ebuild   R    ] sys-apps/util-linux-2.25.2-r1  ABI_X86="32*" 
[ebuild   R    ] x11-libs/libSM-1.2.2-r1  ABI_X86="32*" 
[ebuild   R    ] sys-libs/libcap-2.24-r1  ABI_X86="32*" 
[uninstall     ] app-emulation/emul-linux-x86-xlibs-20140508 
[blocks b      ] app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]" is blocking x11-libs/libSM-1.2.2-r1, x11-proto/renderproto-0.11.1-r1, x11-libs/libXcursor-1.1.14, x11-proto/xproto-7.0.27, x11-libs/libX11-1.6.3, x11-proto/xf86bigfontproto-1.2.0-r1, x11-libs/libXau-1.0.8, x11-proto/xextproto-7.3.0, x11-libs/libXext-1.3.3, x11-libs/libXrandr-1.4.2, media-libs/fontconfig-2.11.93, x11-libs/libXtst-1.2.2, x11-libs/libXdmcp-1.1.2, x11-proto/inputproto-2.3.1, x11-proto/kbproto-1.0.6-r1, x11-proto/videoproto-2.3.2, x11-proto/recordproto-1.14.2-r1, x11-libs/libxcb-1.11-r1, x11-proto/scrnsaverproto-1.2.2-r1, x11-libs/libXScrnSaver-1.2.2-r1, x11-libs/libXfixes-5.0.1, x11-proto/randrproto-1.4.1, x11-libs/libICE-1.0.9, x11-libs/libXv-1.0.10, dev-libs/libpthread-stubs-0.3-r1, x11-libs/libXi-1.7.4, x11-proto/fixesproto-5.0-r1, x11-libs/libXrender-0.9.8)                                                                                                                                         
[blocks b      ] app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]" is blocking x11-proto/xcb-proto-1.11-r1000)                                                                                                                                     
[ebuild   R    ] sys-apps/dbus-1.8.16  ABI_X86="32*" 
[ebuild   R    ] dev-libs/glib-2.42.2  ABI_X86="32*" 
[ebuild   R    ] net-print/cups-2.0.2-r1  ABI_X86="32*" 
[uninstall     ] app-emulation/emul-linux-x86-baselibs-20140508-r15 
[blocks b      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32]" is blocking sys-apps/util-linux-2.25.2-r1)                                                                                                                                      
[blocks b      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32]" is blocking dev-libs/libgcrypt-1.6.3-r1)                                                                                                                                        
[blocks b      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]" is blocking media-libs/libmng-2.0.2-r1, dev-libs/nettle-2.7.1-r4, dev-libs/glib-2.42.2, dev-libs/json-c-0.12, dev-libs/libffi-3.2.1, media-libs/libpng-1.6.17, media-libs/libjpeg-turbo-1.4.0, dev-libs/libgpg-error-1.19, dev-libs/libtasn1-4.5, sys-apps/dbus-1.8.16, dev-libs/expat-2.1.0-r4, dev-db/sqlite-3.8.10.2, net-libs/gnutls-3.3.15)                                                                                                                                    
[blocks b      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]" is blocking dev-libs/gmp-6.0.0a, sys-libs/readline-6.3_p8-r2, sys-libs/ncurses-5.9-r4, sys-apps/tcp-wrappers-7.6.22-r1, sys-libs/zlib-1.2.8-r1, dev-libs/libpcre-8.37-r1, dev-libs/openssl-1.0.1m, sys-apps/attr-2.4.47-r3, app-arch/bzip2-1.0.6-r7)                                                                           
[blocks b      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]" is blocking net-print/cups-2.0.2-r1)                                                                                                                                      
[ebuild   R    ] media-sound/pulseaudio-5.99.3-r1  ABI_X86="32*" 
[uninstall     ] app-emulation/emul-linux-x86-soundlibs-20140508 
[blocks b      ] app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]" is blocking media-libs/flac-1.3.1-r1, media-libs/libsndfile-1.0.25-r1, media-libs/libogg-1.3.2, media-sound/pulseaudio-5.99.3-r1, media-libs/alsa-lib-1.0.29, media-libs/webrtc-audio-processing-0.1-r1, media-libs/libvorbis-1.3.5)                                                                                         
[ebuild   R    ] media-libs/gstreamer-0.10.36-r2  ABI_X86="32*" 
[ebuild   R    ] media-libs/gst-plugins-base-0.10.36-r2  ABI_X86="32*" 
[uninstall     ] app-emulation/emul-linux-x86-medialibs-20140508-r6 
[blocks b      ] app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)]" is blocking media-libs/gstreamer-0.10.36-r2, media-libs/gst-plugins-base-0.10.36-r2)                                                                                    
[ebuild   R    ] dev-qt/qtcore-4.8.7  ABI_X86="32*" 
[ebuild   R    ] dev-qt/qtscript-4.8.7  ABI_X86="32*" 
[ebuild   R    ] dev-qt/qtgui-4.8.7  ABI_X86="32*" 
[ebuild   R    ] dev-qt/qtdbus-4.8.7  ABI_X86="32*" 
[ebuild   R    ] dev-qt/qtxmlpatterns-4.8.7  ABI_X86="32*" 
[ebuild   R    ] dev-qt/qtwebkit-4.8.7  ABI_X86="32*" 
[ebuild   R    ] dev-db/mariadb-10.0.19  ABI_X86="32*" 
[uninstall     ] app-emulation/emul-linux-x86-db-20140508-r3 
[blocks b      ] app-emulation/emul-linux-x86-db[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-db[-abi_x86_32(-)]" is blocking dev-db/mariadb-10.0.19)                                                                                                                                                   
[ebuild   R    ] virtual/mysql-5.6-r2  ABI_X86="32*" 
[ebuild   R    ] dev-qt/qtsql-4.8.7  ABI_X86="32*" 
[ebuild   R    ] dev-qt/qt3support-4.8.7  ABI_X86="32*" 
[uninstall     ] app-emulation/emul-linux-x86-qtlibs-20140508-r1 
[blocks b      ] app-emulation/emul-linux-x86-qtlibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-qtlibs[-abi_x86_32(-)]" is blocking dev-qt/qtwebkit-4.8.7, dev-qt/qtscript-4.8.7, dev-qt/qtsql-4.8.7, dev-qt/qtxmlpatterns-4.8.7, dev-qt/qtdbus-4.8.7, dev-qt/qtgui-4.8.7, dev-qt/qt3support-4.8.7, dev-qt/qtcore-4.8.7)                                                                                                                                   

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-qt/qtsql-4.8.7[mysql]
# required by dev-qt/qt3support-4.8.7
# required by dev-qt/qtgui-4.8.7[qt3support]
# required by dev-qt/qtwebkit-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=virtual/mysql-5.6-r2 abi_x86_32
# required by net-libs/gnutls-3.3.15
# required by net-print/cups-2.0.2-r1[ssl]
# required by dev-qt/qtgui-4.8.7[cups]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-libs/libtasn1-4.5 abi_x86_32
# required by net-im/skype-4.3.0.37-r5[pulseaudio]
# required by @selected
# required by @world (argument)
>=media-sound/pulseaudio-5.99.3-r1 abi_x86_32
# required by x11-libs/libX11-1.6.3
# required by x11-libs/libXtst-1.2.2
# required by media-sound/pulseaudio-5.99.3-r1[X]
# required by @selected
# required by @world (argument)
>=x11-proto/xf86bigfontproto-1.2.0-r1 abi_x86_32
# required by media-sound/pulseaudio-5.99.3-r1[asyncns]
# required by @selected
# required by @world (argument)
>=net-libs/libasyncns-0.8-r3 abi_x86_32
# required by media-sound/pulseaudio-5.99.3-r1[caps]
# required by @selected
# required by @world (argument)
>=sys-libs/libcap-2.24-r1 abi_x86_32
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-qt/qtscript-4.8.7:4 abi_x86_32
# required by dev-qt/qtcore-4.8.7[qt3support]
# required by dev-qt/qtsql-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-qt/qtgui-4.8.7:4 abi_x86_32
# required by media-sound/pulseaudio-5.99.3-r1[webrtc-aec]
# required by @selected
# required by @world (argument)
>=media-libs/webrtc-audio-processing-0.1-r1 abi_x86_32
# required by media-libs/gst-plugins-base-0.10.36-r2
# required by dev-qt/qtwebkit-4.8.7[gstreamer]
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=media-libs/gstreamer-0.10.36-r2:0.10 abi_x86_32
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=x11-libs/libICE-1.0.9 abi_x86_32
# required by net-libs/gnutls-3.3.15
# required by net-print/cups-2.0.2-r1[ssl]
# required by dev-qt/qtgui-4.8.7[cups]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
=dev-libs/nettle-2.7.1-r4 abi_x86_32
# required by dev-libs/libgpg-error-1.19[nls]
# required by dev-libs/libgcrypt-1.6.3-r1
# required by net-print/cups-2.0.2-r1[ssl]
# required by dev-qt/qtgui-4.8.7[cups]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=virtual/libintl-0-r1 abi_x86_32
# required by virtual/jpeg-0-r2
# required by media-libs/libmng-2.0.2-r1
# required by dev-qt/qtgui-4.8.7[mng]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=media-libs/libjpeg-turbo-1.4.0 abi_x86_32
# required by x11-libs/libXrandr-1.4.2
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=x11-proto/randrproto-1.4.1 abi_x86_32
# required by dev-qt/qtwebkit-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-qt/qtxmlpatterns-4.8.7:4 abi_x86_32
# required by dev-libs/nettle-2.7.1-r4[gmp]
# required by net-libs/gnutls-3.3.15
# required by net-print/cups-2.0.2-r1[ssl]
# required by dev-qt/qtgui-4.8.7[cups]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-libs/gmp-6.0.0a abi_x86_32
# required by dev-qt/qtwebkit-4.8.7[gstreamer]
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=media-libs/gst-plugins-base-0.10.36-r2:0.10 abi_x86_32
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=x11-libs/libXcursor-1.1.14 abi_x86_32
# required by x11-libs/libXtst-1.2.2
# required by media-sound/pulseaudio-5.99.3-r1[X]
# required by @selected
# required by @world (argument)
>=x11-proto/inputproto-2.3.1 abi_x86_32
# required by x11-libs/libXrandr-1.4.2
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=x11-libs/libXext-1.3.3 abi_x86_32
# required by net-im/skype-4.3.0.37-r5
# required by @selected
# required by @world (argument)
>=dev-qt/qtwebkit-4.8.7:4 abi_x86_32
# required by virtual/mysql-5.6-r2
# required by dev-qt/qtsql-4.8.7[mysql]
# required by dev-qt/qt3support-4.8.7
# required by dev-qt/qtgui-4.8.7[qt3support]
# required by dev-qt/qtwebkit-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-db/mariadb-10.0.19 abi_x86_32
# required by dev-qt/qtgui-4.8.7[xv]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=x11-proto/videoproto-2.3.2 abi_x86_32
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=media-libs/libpng-1.6.17 abi_x86_32
# required by net-libs/gnutls-3.3.15
# required by net-print/cups-2.0.2-r1[ssl]
# required by dev-qt/qtgui-4.8.7[cups]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=virtual/pkgconfig-0-r1 abi_x86_32
# required by virtual/pkgconfig-0-r1
# required by x11-proto/fixesproto-5.0-r1
# required by x11-libs/libXfixes-5.0.1
# required by x11-libs/libXcursor-1.1.14
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
=dev-util/pkgconf-0.9.11 abi_x86_32
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=media-libs/fontconfig-2.11.93 abi_x86_32
# required by x11-libs/libXcursor-1.1.14
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=x11-libs/libXfixes-5.0.1 abi_x86_32
# required by media-libs/libsndfile-1.0.25-r1[-minimal]
# required by media-sound/pulseaudio-5.99.3-r1
# required by @selected
# required by @world (argument)
>=media-libs/flac-1.3.1-r1 abi_x86_32
# required by x11-libs/libxcb-1.11-r1
# required by x11-libs/libX11-1.6.3
# required by x11-libs/libXtst-1.2.2
# required by media-sound/pulseaudio-5.99.3-r1[X]
# required by @selected
# required by @world (argument)
>=x11-proto/xcb-proto-1.11-r1000 abi_x86_32
# required by media-libs/gst-plugins-base-0.10.36-r2
# required by dev-qt/qtwebkit-4.8.7[gstreamer]
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-libs/libxml2-2.9.2-r1001 abi_x86_32
# required by x11-libs/libXv-1.0.10
# required by dev-qt/qtgui-4.8.7[xv]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=x11-proto/xproto-7.0.27 abi_x86_32
# required by x11-libs/libX11-1.6.3
# required by x11-libs/libXtst-1.2.2
# required by media-sound/pulseaudio-5.99.3-r1[X]
# required by @selected
# required by @world (argument)
>=x11-proto/kbproto-1.0.6-r1 abi_x86_32
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=x11-libs/libSM-1.2.2-r1 abi_x86_32
# required by x11-libs/libX11-1.6.3
# required by x11-libs/libXtst-1.2.2
# required by media-sound/pulseaudio-5.99.3-r1[X]
# required by @selected
# required by @world (argument)
>=x11-libs/libxcb-1.11-r1 abi_x86_32
# required by dev-qt/qtgui-4.8.7[cups]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=net-print/cups-2.0.2-r1 abi_x86_32
# required by dev-libs/glib-2.42.2
# required by dev-qt/qtwebkit-4.8.7[gstreamer]
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=virtual/libffi-3.0.13-r1 abi_x86_32
# required by net-im/skype-4.3.0.37-r5
# required by @selected
# required by @world (argument)
>=x11-libs/libXScrnSaver-1.2.2-r1 abi_x86_32
# required by net-im/skype-4.3.0.37-r5
# required by @selected
# required by @world (argument)
>=dev-qt/qtdbus-4.8.7:4 abi_x86_32
# required by net-print/cups-2.0.2-r1[dbus]
# required by dev-qt/qtgui-4.8.7[cups]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=sys-apps/dbus-1.8.16 abi_x86_32
# required by dev-qt/qtgui-4.8.7[qt3support]
# required by dev-qt/qtwebkit-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-qt/qt3support-4.8.7 abi_x86_32
# required by net-print/cups-2.0.2-r1[ssl]
# required by dev-qt/qtgui-4.8.7[cups]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-libs/libgcrypt-1.6.3-r1 abi_x86_32
# required by x11-libs/libxcb-1.11-r1
# required by x11-libs/libX11-1.6.3
# required by x11-libs/libXtst-1.2.2
# required by media-sound/pulseaudio-5.99.3-r1[X]
# required by @selected
# required by @world (argument)
>=x11-libs/libXdmcp-1.1.2 abi_x86_32
# required by x11-libs/libSM-1.2.2-r1[uuid]
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=sys-apps/util-linux-2.25.2-r1 abi_x86_32
# required by dev-qt/qtcore-4.8.7[iconv]
# required by dev-qt/qtsql-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by dev-qt/qtgui-4.8.7[qt3support]
# required by dev-qt/qtwebkit-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=virtual/libiconv-0-r2 abi_x86_32
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=x11-libs/libXrandr-1.4.2 abi_x86_32
# required by sys-libs/readline-6.3_p8-r2
# required by dev-libs/libxml2-2.9.2-r1001[readline]
# required by dev-qt/qtwebkit-4.8.7[gstreamer]
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=sys-libs/ncurses-5.9-r4 abi_x86_32
# required by dev-db/mariadb-10.0.19[ssl]
# required by virtual/mysql-5.6-r2
# required by dev-qt/qtsql-4.8.7[mysql]
# required by dev-qt/qt3support-4.8.7
# required by dev-qt/qtgui-4.8.7[qt3support]
# required by dev-qt/qtwebkit-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-libs/openssl-1.0.1m abi_x86_32
# required by media-sound/pulseaudio-5.99.3-r1[tcpd]
# required by @selected
# required by @world (argument)
>=sys-apps/tcp-wrappers-7.6.22-r1 abi_x86_32
# required by x11-libs/libXext-1.3.3
# required by x11-libs/libXv-1.0.10
# required by dev-qt/qtgui-4.8.7[xv]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=x11-proto/xextproto-7.3.0 abi_x86_32
# required by media-libs/libsndfile-1.0.25-r1[-minimal]
# required by media-sound/pulseaudio-5.99.3-r1
# required by @selected
# required by @world (argument)
>=media-libs/libvorbis-1.3.5 abi_x86_32
# required by x11-libs/libXrandr-1.4.2
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=x11-proto/renderproto-0.11.1-r1 abi_x86_32
# required by x11-libs/libxcb-1.11-r1
# required by x11-libs/libX11-1.6.3
# required by x11-libs/libXtst-1.2.2
# required by media-sound/pulseaudio-5.99.3-r1[X]
# required by @selected
# required by @world (argument)
>=x11-libs/libXau-1.0.8 abi_x86_32
# required by dev-libs/glib-2.42.2[xattr]
# required by dev-qt/qtwebkit-4.8.7[gstreamer]
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=sys-apps/attr-2.4.47-r3 abi_x86_32
# required by x11-libs/libXrandr-1.4.2
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=x11-libs/libXrender-0.9.8 abi_x86_32
# required by x11-libs/libXtst-1.2.2
# required by media-sound/pulseaudio-5.99.3-r1[X]
# required by @selected
# required by @world (argument)
>=x11-proto/recordproto-1.14.2-r1 abi_x86_32
# required by net-im/skype-4.3.0.37-r5
# required by @selected
# required by @world (argument)
>=media-libs/alsa-lib-1.0.29 abi_x86_32
# required by dev-qt/qtgui-4.8.7[mng]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=media-libs/libmng-2.0.2-r1 abi_x86_32
# required by media-libs/libmng-2.0.2-r1
# required by dev-qt/qtgui-4.8.7[mng]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=virtual/jpeg-0-r2:0 abi_x86_32
# required by dev-qt/qtwebkit-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-qt/qtcore-4.8.7:4 abi_x86_32
# required by x11-libs/libXtst-1.2.2
# required by media-sound/pulseaudio-5.99.3-r1[X]
# required by @selected
# required by @world (argument)
>=x11-libs/libXi-1.7.4 abi_x86_32
# required by dev-db/sqlite-3.8.10.2[icu]
# required by dev-qt/qtwebkit-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-libs/icu-55.1-r1001 abi_x86_32
# required by virtual/libffi-3.0.13-r1
# required by dev-libs/glib-2.42.2
# required by dev-qt/qtwebkit-4.8.7[gstreamer]
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-libs/libffi-3.2.1 abi_x86_32
# required by media-libs/fontconfig-2.11.93
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-libs/expat-2.1.0-r4 abi_x86_32
# required by x11-libs/libXScrnSaver-1.2.2-r1
# required by net-im/pidgin-2.10.11[gtk,xscreensaver]
# required by @selected
# required by @world (argument)
>=x11-proto/scrnsaverproto-1.2.2-r1 abi_x86_32
# required by dev-db/mariadb-10.0.19[-bindist]
# required by virtual/mysql-5.6-r2
# required by dev-qt/qtsql-4.8.7[mysql]
# required by dev-qt/qt3support-4.8.7
# required by dev-qt/qtgui-4.8.7[qt3support]
# required by dev-qt/qtwebkit-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=sys-libs/readline-6.3_p8-r2 abi_x86_32
# required by net-print/cups-2.0.2-r1[ssl]
# required by dev-qt/qtgui-4.8.7[cups]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
=net-libs/gnutls-3.3.15 abi_x86_32
# required by media-libs/freetype-2.6[bzip2]
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=app-arch/bzip2-1.0.6-r7 abi_x86_32
# required by media-sound/pulseaudio-5.99.3-r1[X]
# required by @selected
# required by @world (argument)
>=x11-libs/libXtst-1.2.2 abi_x86_32
# required by media-sound/pulseaudio-5.99.3-r1
# required by @selected
# required by @world (argument)
>=media-libs/libsndfile-1.0.25-r1 abi_x86_32
# required by dev-libs/libgcrypt-1.6.3-r1
# required by net-print/cups-2.0.2-r1[ssl]
# required by dev-qt/qtgui-4.8.7[cups]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-libs/libgpg-error-1.19 abi_x86_32
# required by media-libs/gst-plugins-base-0.10.36-r2[orc]
# required by dev-qt/qtwebkit-4.8.7[gstreamer]
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-lang/orc-0.4.23 abi_x86_32
# required by media-sound/pulseaudio-5.99.3-r1
# required by @selected
# required by @world (argument)
>=dev-libs/json-c-0.12 abi_x86_32
# required by dev-libs/libxml2-2.9.2-r1001
# required by dev-qt/qtwebkit-4.8.7[gstreamer]
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=sys-libs/zlib-1.2.8-r1 abi_x86_32
# required by dev-qt/qtwebkit-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-db/sqlite-3.8.10.2 abi_x86_32
# required by dev-db/mariadb-10.0.19
# required by virtual/mysql-5.6-r2
# required by dev-qt/qtsql-4.8.7[mysql]
# required by dev-qt/qt3support-4.8.7
# required by dev-qt/qtgui-4.8.7[qt3support]
# required by dev-qt/qtwebkit-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-libs/libpcre-8.37-r1 abi_x86_32
# required by x11-libs/libxcb-1.11-r1
# required by x11-libs/libX11-1.6.3
# required by x11-libs/libXtst-1.2.2
# required by media-sound/pulseaudio-5.99.3-r1[X]
# required by @selected
# required by @world (argument)
>=dev-libs/libpthread-stubs-0.3-r1 abi_x86_32
# required by dev-qt/qtwebkit-4.8.7[gstreamer]
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-libs/glib-2.42.2 abi_x86_32
# required by dev-qt/qt3support-4.8.7
# required by dev-qt/qtgui-4.8.7[qt3support]
# required by dev-qt/qtwebkit-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=dev-qt/qtsql-4.8.7:4 abi_x86_32
# required by dev-qt/qtgui-4.8.7[xv]
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=x11-libs/libXv-1.0.10 abi_x86_32
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=media-libs/freetype-2.6 abi_x86_32
# required by media-libs/libsndfile-1.0.25-r1[-minimal]
# required by media-sound/pulseaudio-5.99.3-r1
# required by @selected
# required by @world (argument)
>=media-libs/libogg-1.3.2 abi_x86_32
# required by x11-libs/libXrender-0.9.8
# required by dev-qt/qtwebkit-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=x11-libs/libX11-1.6.3 abi_x86_32
# required by x11-libs/libXfixes-5.0.1
# required by x11-libs/libXcursor-1.1.14
# required by dev-qt/qtgui-4.8.7
# required by dev-qt/qt3support-4.8.7
# required by kde-apps/kalgebra-4.14.3
# required by kde-apps/kdeedu-meta-4.14.3
# required by kde-base/kde-meta-4.14.3
# required by @selected
# required by @world (argument)
>=x11-proto/fixesproto-5.0-r1 abi_x86_32

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

I tried adding "abi_x86_64" and "-abi_x86_32" to USE, I also tried adding ABI_X86="64". It seems to ignore both of these. I did a "emege --sync" a few times over the weekend hoping that it would be fixed, but it'st still doing it after pulling changes four or five times.

 

FWIW, this is my make.conf

user@host:~$ cat /etc/make.conf 
# These settings were set by the metro build script that automatically built this stage.
# Please consult /etc/portage/make.conf.example for a more detailed example.

CFLAGS="-march=core-avx2 -O2 -pipe"
CXXFLAGS="-march=core-avx2 -O2 -pipe"
MAKEOPTS="-j6"
#USE="video_cards_intel vim_syntax -chromium icu qt4 -ipv6 cups abi_x86_64"
USE="video_cards_intel vim_syntax -chromium icu qt4 -ipv6 cups" 
INPUT_DEVICES="synaptics evdev"

Any help would be greatly appreciated.

 

 

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Maybe an announcement might have been in order on this, with some detailed info on integrating the changes. This is probably ruining a few Monday mornings. :-( I'm not clear on how to proceed here, which I guess is my fault for trying to ignore 32/64 bit issues for the past five years. Just a heads up on the news feed would have been great.

Share this post


Link to post
Share on other sites
  • 0

you'll need back abi_x86_32 USE flag. remove all of emul-linux-* packages on your box, then rebuild everything by emerge -auDN @world.

 

You're saying i need to ADD abi_x86_32? I'm running a 64 bit machine, why is it trying to add this stuff in 32 bit mode?

Share this post


Link to post
Share on other sites
  • 0

Maybe an announcement might have been in order on this, with some detailed info on integrating the changes. This is probably ruining a few Monday mornings. :-( I'm not clear on how to proceed here, which I guess is my fault for trying to ignore 32/64 bit issues for the past five years. Just a heads up on the news feed would have been great.

 

Right, I did check eselect news, hoping for something to tell me what I'm doing wrong, but there was nothing there since like 2013.

Share this post


Link to post
Share on other sites
  • 0

 

Funtoo doesn't use the eselect news feature anymore. News is normally posted to the web site or the forum.

 

http://www.funtoo.org/News:Emul_Linux_Packages_Deprecation

 

I agree that a better user level HOWTO for this conversion is probably in order.

 

I am not an expert but I'll try to clear few things up. The base architecture of your system is set by your profile, not by the abi_x86_32 USE flag.   You can see arch setting in your profile with these commands.

epro show
eselect profile show

You'll probably see arch: x86-64bit which is 64 bit but compatible with 32bit libraries.   If you wanted pure 64 bit you would have selected "pure64".

 

Your emerge output shows that you have the app-emulation/emul-linux-x86* packages installed.  Those are 32bit libraries that were provided so that you can run programs that require 32bit libraries - Wine and Steam are examples.

 

The app-emulation/emul-linux-x86* packages have been depricated.  In order to maintain compatability with the programs you run that require 32bit libraries you need to remove the app-emulation/emul-linux-x86* packages and apply the abi_x86_32 USE flag to build the 32bit libraries that you require.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...