Jump to content
  • 0

xf86-video-intel crashes at SNA, works at UXA


jorgicio
 Share

Question

Hi!

 

I have a Sandybridge, with that Intel integrated driver, and I ever had the xf86-video-intel with sna enabled and uxa disabled. It ever worked. However, yesterday, came out a new fix, the version 2.99.917-r1, and it broke everything. I tried downgrading to the previous version, and the same happens. I also have KMS enabled.

 

So the only workaround, by the moment, is disabling SNA and enabling UXA. It works, although I know SNA is better than UXA, but at least, it works.

 

Does it happen the same to someone else since then?

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I'll check my work PC tomorrow.

 

I have a different problem that I haven't filed a bug for yet - I cannot use X (also xf86-video-intel) with any kernel >=4.x.x.  I get a segfault everytime.  Works fine with 3.x.x.  Started having the problem around the same time as the tool chain update, which included linux-headers-4.0 & the 4 series kernel.

 

Looks like you already complained at bugs.gentoo.org.  Did you file a new bug there?  Did you file one at bugs.funtoo.org?

Link to comment
Share on other sites

  • 0

I found the problem: Kernel 4.0.

 

I applied the patch found there: https://bugzilla.opensuse.org/show_bug.cgi?id=931917. It did the trick.

 

The patch: https://bugzilla.opensuse.org/attachment.cgi?id=635268

 

EDIT: I also reported the problem in the Gentoo bugtracker, so if approved, it'll be in some next tree sync.

https://bugs.gentoo.org/show_bug.cgi?id=552124

 

BREAKING NEWS: The patch is tested and accepted in Gentoo, so yes, it WILL be in a next sync here.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...