Jump to content
  • 0

Non-interactive ssh does not set LANG


prof
 Share

Question

I'm comparing Funtoo behavior to other linux (specifically Oracle Enterprise Linux (OEL), which is a RedHat fork).

Funtoo does not have locale configuration (specifically, I expect LANG=en_US.utf8) during non-interactive shells.

In my real world scenario, going "ssh <myhost>" then followed by "tmux attach" command interactively works fine

whereas "ssh <myhost> -t tmux attach" messes up all Unicode characters because LANG is not set and locale defaults to POSIX while using non-interactive shell.

Other linux (OEL, for example) has locale configuration called from .bashrc, while Funtoo .bashrc skeleton is literally empty.

I have no problem working around by adding that setting in .bashrc by hands, but should not that be a reasonable default? If so, I probably should file a bug. What do you think? What are the reasons of not setting locale in .bashrc for all shells including non-interactive? Whose strategy is right or wrong, Funtoo or OEL?

Thank you for your input

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...