Jump to content

prof

Members
  • Posts

    6
  • Joined

  • Last visited

  1. Oh Gee, I would never come up to this on my own! Thank you @cardinal for the workaround which actually works. I did not even expect anyone to be able to answer this at all, not to mention the same day answer! Just for the record, on top of doing everything you described, I also had to remove a reference to virtual/libcrypto from the ebuild as this package does not exist in Funtoo, and manually download the openssh tarball from distfiles.gentoo.org into /var/cache/portage/distfiles directory. Got my SSH daemon back! Thank you again! P.S. We both understand that it is just a dirty hack, a real solution is to be delivered from Funtoo... Upvoted a bug.
  2. Hi, sshd does not accept connections, even from the local system. Once the computer was powered up last time months ago, it worked fine. Unfortunately, I cannot remember for sure if there ran package update or it happened out of blue. sshd_config was not touched since the last time sshd worked, I started playing with config only after sshd already broke apart. arch: x86-32bit subarch: atom_32 OpenSSH_8.4p1, OpenSSL 1.1.1l 24 Aug 2021 Any ssh attempt drops connection immediately. Server command and log: /usr/sbin/sshd -dddDe -o PidFile=/run/sshd.pid Client command and log: ssh -vvv localhost Tried different things found on google, such as network MTU, various ciphers/MACs/KexAlgorithms settings, nothing sheds any light. Getting kind of desperate now. Thank you for all your help!
  3. Besides getting intel64-sandybridge stage3 file, I have also set variables: CHOST x86_64-pc-linux-gnu CFLAGS -march=corei7-avx -O2 -pipe I do not think it is a good idea to bother cups/networkmanager/other package developers/maintainers, because that does not appear to be package specific. I would say systemwide instead. I removed everything and started from scratch, going back one step to intel64-nehalem subarch (with a corresponding CFLAGS change), all illegal instructions have gone like a magic. So to summarize, I know how to fix it, but have no idea why it did not work with an original configuration. Thanks.
  4. I solved a similar problem in an opposite way, by forcing it to run in python2.7 (eselect python showed 3.4 as a default)
  5. Well, maybe I started the topic from the wrong question. Does getting "Illegal instruction" message have a most possible cause of choosing a wrong subarchitecture at first place? Response much appreciated.
  6. Hi all, I carefully reviewed my CPU info and googled to see the proper architecture Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz That points to intel64-sandybridge However, using that architecture I receive "Illegal instruction" error during various steps (e.g. compiling cups or running NetworkManager) I do not want to be "too safe" and choose a generic architecture. Could you please point to the right one closest to that particular CPU? Thank you
×
×
  • Create New...