Jump to content
  • 0

Screen goes dark during boot-up [solved]


frodo42
 Share

Question

I am an oldtime Gentoo user that really did not use Linux a lot for a period of years, but now I have a server (HP Proliant Gen6) that I am trying to install Funtoo on, it is supposed to run some CPU and RAM heavy work (machine learning and geophysical inversion mostly) and I need for me and my co-worker to be able to access it remotely with some kind of GUI on it that can be accessed, I am probably going to use some setup with an RDP protocol, but I haven't gotten to that just yet.

I went through the Install guide, shifting over to working over SSH as soon as possible (the server room is not a pleasant place to be) and it all seemed to work as expected. I have installed from the stage3-tarball.

However now that I am trying to get the X-system to work I have run into an issue that I have not been able to find a solution for in the past days.

During boot the monitor stops displaying anything, either I get a message on the screen from the monitor system itself saying "not a suitable resolution, recommended resolution 1600x1200 60hz" or when I try different other settings I simply get a black screen on the monitor.

The GRUB screen shows just fine and the first part of the messages that run over the screen of the booting linux setup (those statements with the first part screen of driver loading etc) show up, I can't follow the lines but I am guessing it is at some point where it is initializing some kind of video drivers that the monitor stops displaying anything.

I can log in to the system through SSH without problems, but without having a working monitor physically it is difficult to GUI stuff up and running. I have done the 

From LSPCI I found the screen card I am using to be:

01:03.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] ES1000 (rev 02)

I have step by step gone from flavor of core to server to desktop in the process of trying to fix this problem and installing the X-system.

Right now I have "gfxcard-radeon" set as the graphic card in mix-ins, I started out trying with "gfxcard-ancient-ati", did a "emerge -uavD world" after that change, still same problem.

At present my boot.conf looks like this (been trying to play around with it quite a bit, with no changes

boot {
        generate grub
        default "Funtoo Linux"
        timeout 3
}

display {
        gfxmode 1600x1200x32
}

"Funtoo Linux" {
        kernel bzImage[-v]
}

"Funtoo Linux genkernel" {
        kernel kernel[-v]
        initrd initramfs[-v]

        params += real_root=auto rootfstype=auto
}


I am trying a few different things fiddling around, but the past two days I have not been able to solve this issue, tried using a few different VGA screens but the same kind of problems (the server only has VGA output port)

Any help or suggestions would be greatly appreciated.

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 1
  • Funtoo Linux BDFL

@frodo42 I think I have the answer for you because I had the exact same problem.

I have an older server with a built-in matrox video card. Recent kernels would cause the screen to go blank as you describe with an invalid mode. The solution was for me to figure out what module it was using for framebuffer and BLACKLIST that module, so the framebuffer would not initialize.

I put:

blacklist matroxfb_base

Into /etc/modprobe.d/video.conf, and this did the trick. (reboot after, of course) Do some grepping of "lsmod" and see what video modules have a usage count of > 0 and blacklist one until you prevent the kernel from kicking the framebuffer into an incompatible mode. 

Sometimes, the monitors in datacenters are old and may not support the default resolution of the chip in the server, or the refresh rate. Or this could simply be a new bug in Linux kernels related to older server gfx chipsets and how it initialized the framebuffer.

Unfortunate that this is needed but I did start seeing this with newer kernels after I updated them recently. Previous kernels did not have the issue. I also played around with different gfxmode settings and nomodeset but this never seemed to help. The blacklist of the module did.
 

Link to comment
Share on other sites

  • 0

Hi seemant

Yes I also tried using "nomodeset" but on and off, it doesn't make any difference really, the only thing I see a difference on is when I try and edit the grub.cnf file directly I managed to get the screen from giving this message of wrong resolution to just be black. What makes it more strange to me is that the blackout or error message from the screen comes at some point during the boot messages, which makes me think it does not originate from the grub settings but rather something with some driver that loads at some point in that process.

Link to comment
Share on other sites

  • 0
  • Funtoo Linux BDFL

Also note, this was on a server where I didn't care if I had graphics capability or not -- I just wanted to make sure I could get to a console I could see in the datacenter. This is really all you need for a server (in theory) as you can connect remotely for everything else except emergencies.

Link to comment
Share on other sites

  • 0

Thank you very much drobbins, that solved at least this problem with the monito going black for now.

Putting

blacklist radeonfb

into the /etc/modprobe.d/video.conf gives me a screen with a login on the monitor now.

Now on to trying to get the X-system running and if it will work without this radeonfb module, the way I am going to use the server it is not going to be really possible to run the programs we need to run without a GUI, some binary programs that I can only run through their GUI and so on needs to be run on that server and so on.

Link to comment
Share on other sites

  • 0
  • Funtoo Linux BDFL

@frodo42 most servers have crappy video. If you are truly doing GUI things in this server, I recommend picking up one of these cards if you can:

https://www.newegg.com/amd-100-506115/p/N82E16814105101

I am a fan of this card -- it is powering my dual 4K setup and is very fast (so yes, this is my primary graphics card for my home workstation.) This particular model comes with a low-profile bracket which are often found in servers (as well as full height bracket.) All you will need is a free PCIe (full height or low-profile) slot, x16 if you have it but this card should work in an x8 slot as well.

EDIT: I picked mine up about 3 weeks ago from Newegg for $220, so hunt around and you may be able to find cheaper (newegg is currently showing ~$290 for this card). It's the HP edition which includes the extra bracket. You will also get FULL HP WARRANTY since it's a HP card in an HP server 😉 (there's a note in the box it comes in that the card warranty only applies if you plug it into HP-branded equipment).

Link to comment
Share on other sites

  • 0

Hi drobbins

Thank you very much for the suggestions!

I will definitely look around for a better graphics card for this server, I am not sure what kind of PCI slots are available in that server but I will investigate later when I have all the software up and running, so far I got the first test of the X-system running just fine and got the compile of gnome-light started before I left for a little christmas visit with family on the other side of Denmark, I am able to SSH to the server still from here, maybe I will try and get the "remote desktop stuff" up and running through it if I find the time, otherwise the setup continues when I am back in the western parts of Denmark in a few days. It is a very nice feeling that comes with finally having a Funtoo server, I tried out Ubuntu a few times  while I was away from Gentoo after my last private desktop computer crashed and I was working in a company that was completely windows based. Starting my own company to begin with I also started out with windows stuff, but now I feel the time is finally there to step by step move back to Linux which just feels more right for me.

I do not think we are going to run anything that is really very demanding in terms of the GUI, it is more like some software in our in house python front end based software that has some kind of GUI build in to control it, some different geophysics software that needs a grahics interface to active the license and some matlab scripts that I have not yet bothered to convert to python (my cooperation partners at Aarhus University still have not really managed to move away from this Matlab development things) and Windows native stuff that I will also attempt to get up and running on the server through wine. A lot of these geophysics programs for modelling the underground in different ways takes day, weeks and even months to run, even more so as we are developing the machine learning side of my company more and more.
The more graphics heavy stuff I plan for now to do on other computers, the server will mostly be used by my brother (mathematician turned "data scientist"/geophysics software developer) who also works for me to run some of the testing on the machine learning things he is developing, he has since the old harddisk crashed been developing some neural network stuff where GPU might actually also be more critical for some of the calculations there, for that reason it makes sense to look into getting an upgrade on the graphics card.

I have the server in my basement in Denmark, my brother is remotely using it from Spain where he lives and the idea is to step by step expand the servers in that basement as they also have a little nice secondary effect of heating my house while I can without problems put the electricity bills to run the servers on my company's finances 😉

I have found there is an abundance of very affordable second hand servers on the market, this server I have now has some 300 GB of ram installed in it which we need for a lot of the geophysics software to run optimally and it cost me less than 1000 usd to buy all the hardware including a lot of spare parts, a lot of companies are going "cloud" here in Denmark with stuff they precious have been running on servers themselves which gives a nice opportunity for people like me who enjoy playing around with the hardware side of things as well.

Edited by frodo42
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...