Jump to content

Screen flashing in SDDM login screen


rwardrup
 Share

Recommended Posts

Hi everyone,

I just installed kde-plasma-5 and sddm and I'm getting weird behavior when logging in. When I move the mouse over the password field, the screen flickers and flashes. I'm using xf86-video-intel drivers.

I haven't touched the Xorg configuration file from installation.

Is there something I need to install? Is this just a bug in SDDM? I got the behavior with xorg-drivers as well.

Link to comment
Share on other sites

I've tried using modesetting per an answer on the Gentoo forums but it hasn't worked. 

Section "Device"
        Identifier  "Intel Graphics"
        Driver      "modesetting"
        Option      "AccelMethod"    "glamor"
        Option      "DRI"            "3"
EndSection

The Xorg log confirms that it is loading the modesetting driver:

[     7.552] (II) LoadModule: "modesetting"
[     7.553] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[     7.554] (II) Module modesetting: vendor="X.Org Foundation"
[     7.554]     compiled for 1.20.10, module version = 1.20.10
[     7.554]     Module class: X.Org Video Driver
[     7.554]     ABI class: X.Org Video Driver, version 24.1
[     7.554] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
Edited by rwardrup
Link to comment
Share on other sites

  • Funtoo Linux BDFL

We talked about this on Discord a bit -- I definitely recommend trying out our official desktop (gnome in particular) stage3's first, and ensuring those are working well for you, before playing with KDE, as we don't have a KDE stage yet and it's not officially support (but in progress): https://www.funtoo.org/Support_Matrix

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...