Jump to content
  • 0

SOLVED :My first Funtoo boot resulted in a ModemManager error message


Question

Hi !

Newbie here, has just finished my first Funtoo install and got it to boot all the way to login, but it stopped there with the message shown in the screenpic enclosed as "meddelande.png".

Below, some hardware info in hope you can tip me on what can be done.

lspci:

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 7 Series/C210 Series Chipset Family KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (Lewisville) (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6235 (rev 24)

lshw network:

  *-network
       description: Ethernet interface
       product: 82579LM Gigabit Network Connection (Lewisville)
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: enp0s25
       version: 04
       serial: 74:2b:62:87:8c:e0
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=5.10.61-gentoo-x86_64 duplex=full firmware=0.13-4 ip=192.168.0.111 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:27 memory:f0600000-f061ffff memory:f063b000-f063bfff ioport:2080(size=32)
  *-network
       description: Wireless interface
       product: Centrino Advanced-N 6235
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 24
       serial: c4:d9:87:a3:34:82
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.10.61-gentoo-x86_64 firmware=18.168.6.1 6000g2b-6.ucode latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:30 memory:f0500000-f0501fff

Attachments 00_19.0  and 00_1c.2 are listings from /sys/devices/pci0000\.......  for the 2 devices in the error message.

 

I am liking the Funtoo way 🙂

Meddelande.thumb.png.644550d57df2403e191f1250ba25b75f.png

full_lshw_listing 00_19.0 00_1c.2

Edited by fredmyra
to adjust attachments; mark as solved
Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I insisted and by pressing several keys I was finally able to proceed to  log in. But I still would appreciate help on the modem issue. I noticed that during booting it was reported that

" scanning for e1000  .... loaded"

but I don´t know if it means anything of interest.

Link to post
Share on other sites
  • 0

@fredmyra

If the computer doesn't connect to the internet using a cellular data modem disable modemmanager USE flag so it can be removed.

In /etc/make.conf add this:

USE="-modemmanager"

Remove modemmanager:

emerge -Ca modemmanager

Rebuild packages now that the modemmanager USE has been disabled:
 

emerge -avuDN @world

 

Link to post
Share on other sites
  • 0
Quote

If the computer doesn't connect to the internet using a cellular data modem disable modemmanager USE flag so it can be removed.

In /etc/make.conf add this:


USE="-modemmanager"

Remove modemmanager:


emerge -Ca modemmanager

Rebuild packages now that the modemmanager USE has been disabled:
 


emerge -avuDN @world

Thanks cardinal! I  understand this and it sounds good. But I will try it tomorrow, ´cause now I am having trouble concentrating. Too Tired.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...