Jump to content
  • 0

Trouble getting a desktop installed


Question

Some time ago I got new hardware  for my desktop, to replace what I currently run. Asus B450 Prime mainboard, AMD Ryzen 7 1700 (non-X!) and 2x 8GB RAM from Transend. For video I used an old nVidia GT710 card, as I won't be doing anything fancy like gaming on the machine anyway. I managed to get a base Funtoo system installed, eventually, using the first gen Zen stage3. But when expanding the install to a full desktop I got all kinds of issues. Following the install guides on the Funtoo Wiki I got Xorg and Mate to install. When I rebooted, I couldn't log in, despite setting Lightdm to auto-login of my user (I'm the only one using it) Eventually I booted into a sysrescuecd again as I couldn't get a single-user boot from the Grub menu (it's not provided OOTB and any editing of the Grub menu failed to get a root shell either) and purged everything Mate and Xorg. So, that's where I am now, although I did manage to install Devuan on the same machine (different SSD) successfully, including Mate, in the mean time.

 

One particular error I got today was a missing opencl-headers package. Syncing the tree didn't help, it's not there.

 

Goes w/o saying that this is very frustrating, having used Funtoo in the past I really want this to work and I'm still trying to get this done for 6+ weeks now.

Note, I really do appreciate all the work the dev's put in, free of charge, but (installing) Funtoo is more complicated then it should be. IMO.

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

When you boot into lightdm-greeter gui, type in your password, click the login button does lightdm start the mate-session desktop?

Adding autologin-user=rj  to /etc/lightdm/lightdm.conf  under [Seat:*] auto-logins my regular user rj 

lightdm has good logs at /var/log/lightdm/lightdm.log .

 

Single user mode with root partition mounted rw, no networking:

Genkernel initrd including debian-sources{-lts} add init_opts=1 to kernel command line.

Kernel with no initramfs add the number 1 to the kernel command line.

 

 

Link to post
Share on other sites
  • 0

That's how I got my user to auto-login, but it didn't work, it went back to the greeter. Filling in my user and password didn't do anything, I just returned (again) to the greeter. Trying root instead made no difference (as it should, no GUI login for root!) Currently I have no graphics related packages installed (no Xorg nor Mate) and I can login from the cli w/o any problems.

 

I wasn't aware of the init_opts option, thx for that 🙂

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...