Jump to content
  • 0

Installing Funtoo bootloader problem


Question

Hello,

I' trying to install funtoo from arch linux. I downloaded amd-pildriver stage tar file, I followed the Install guide, which doesn't seems to be accurate. I started to have different results when tried to emerge ibus. This seems that updated a lot of packages(131), and also installed genkernel. So, afterwards I installed linux-firmware and grub. And here is my problem. Grub installed without problem, but now when I run "ego boot update", it doesn't do nothing and no /boot/grub/grub.cfg genereted.

I have an MBR system and I already have grub installed, so I don't want to install grub again, just to generate the grub.cfg file. I don't have a /boot partition and I have set / in fstab using the UUID of partition.

The boot.conf file has these:

boot {
	generate grub
	default "Funtoo Linux" 
	timeout 3 
}

"Funtoo Linux" {
	kernel bzImage[-v]
}

"Funtoo Linux genkernel" {
	kernel kernel[-v]
	initrd initramfs[-v]

	# IMPORTANT: Most users will want to remove "nomodeset", below!
	#
	# It is included in the initial install to ensure that virtually all
	# systems boot up with a readable initial console.

	# But all graphics drivers (with the one exception of the proprietary
	# NVIDIA drivers) REQUIRE mode setting to be enabled, and thus the
	# nomodeset option must be REMOVED prior to setting up a graphical
	# environment or X will not start. Remember to run "ego boot update" after
	# removing the option, and then reboot prior to configuring X.

	# Also note that if you are using a 4K or higher resolution display, your
	# console text may become very small after enabling kernel mode setting
	# since it will display your console at the native resolution of your
	# display.

	params += real_root=auto rootfstype=auto
}

When I run "ego boot update" I get this:

  * Generating config for grub...

  * No /etc/fstab entry for /boot; not mounting.

and no grub.conf is generated.

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

You're multi-booting, booted into arch linux with grub2 already installed, installing funtoo on another partition or partition/drive on the same computer?

Boot update only works if you have funtoo installed as the first linux os on the drive and it was used to install grub2.

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...