Jump to content
Read the Funtoo Newsletter: Summer 2023 ×
  • 0

distcc prepare phase failed



i am using linux mint debbi 4 ( live usb ) to install funtoo ( using generic_64 since using westmere gives me illegal instruction when i try to do ego update ) onto my p6100 intel cpu laptop and i want to use distcc to use my other more powerful windows 10 ltsc 2019 laptop ( with ubuntu 20.04 LTS from microsoft store (better performance than regular virtual machine??) ) to speed up building programs for my p6100 laptop since last time i tried installing gentoo and it was taking forever, i was still on the handbook at the time and installing the network dependencies were around half way finished after leaving this laptop running all night, if i am doing anything wrong please tell me because i am somewhat new to linux in general especially gentoo/funtoo, anyway here are the error logs when i tried emerging distcc

Thanks for any help

build.log emerge errors environment

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • -1

i have found a fix, apperantly distcc dosen't like the default -march=native so i have found this guide

( https://blogs.gentoo.org/mgorny/2014/06/23/inlining-marchnative-for-distcc/ )

and used this command  gcc -### -march=native -x c - which  gives all of the cpu information and i have put it into the make.conf files under CFLAGS="{insert here}" and distcc has installed with no problems

Link to comment
Share on other sites

  • 1

The patches need to be updated for distcc-3.3.5.ebuild

My workaround for failed updates is git revert the commit to the prior version distcc-3.3.3.ebuild

After successfully emerging distcc-3.3.3 mask it until the patches are fixed and distcc-3.3.5 will build.

funtoo /var/git/meta-repo/kits/core-kit # git log --all --full-history -- "*distcc*.*"
Checkout the 2nd commit in the result to restore distcc-3.3.3.ebuild
funtoo /var/git/meta-repo/kits/core-kit # git checkout 8d890
funtoo /var/git/meta-repo/kits/core-kit # emerge -av distcc
Mask distcc-3.3.5 from update until it's fixed.
funtoo /var/git/meta-repo/kits/core-kit # echo ">sys-devel/distcc-3.3.3" >> /etc/portage/package.mask/distcc
Change core-kit back to head.
funtoo /var/git/meta-repo/kits/core-kit # git checkout 1.4-release


Bug report:

Autogened sys-libs/distcc-3.3.5 update patch fails prepare


Edited by cardinal
Add bug report link.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...