Jump to content
  • 1

Missing flag gles2 in dev-qt/qtgui


Go to solution Solved by cardinal,

Question

Hi

On install kde-meta showed me a mistake

Quote

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-qt/qtgui-5.11.1:5[gles2=]".
!!! One of the following packages is required to complete your request:
- dev-qt/qtgui-5.15.2::qt-kit (Missing IUSE: gles2)
- dev-qt/qtgui-5.15.1-r1::qt-kit (Missing IUSE: gles2)
(dependency required by "kde-apps/kdenlive-19.04.2::kde-kit" [ebuild])
(dependency required by "kde-apps/kdemultimedia-meta-19.04.2::kde-kit" [ebuild])
(dependency required by "kde-apps/kde-apps-meta-19.04.2::kde-kit" [ebuild])
(dependency required by "kde-apps/kde-meta-19.04.2::kde-kit" [ebuild])
(dependency required by "kde-meta" [argument])

emerge -av dev-qt/qtgui

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-qt/qtgui-5.15.2:5/5.15.2::qt-kit  USE="X dbus egl gif jpeg libinput png udev wayland -accessibility -debug -eglfs -evdev -gles2-only -ibus -test -tslib -tuio -vnc -vulkan" 0 KiB

 

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 1
  • Solution

Funtoo's freshest kde ebuilds are in kde-kit non-default 5.20-release branch for testing.

Manual override default branch for kde-kit and emerge.

funtoo /home/rj # ego config set kits kde-kit 5.20-release
funtoo /home/rj # ego kit
funtoo /home/rj # ego sync

If configured correctly:

Syncing kde-kit branch 5.20-release (non-default)
Already on '5.20-release'
Your branch is up to date with 'origin/5.20-release'.
HEAD is now at 23455e77e Automated updates by metatools for md5-cache and python profile settings.
Already up to date.

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...