Jump to content
funtoo forums

kris

Members
  • Content Count

    5
  • Joined

  • Last visited

About kris

  • Rank
    Newbie

Personal

  • Location
    Poland
  1. kris

    Invalid token '1999-2017' (not '=')

    I chose No. 3,
  2. kris

    Invalid token '1999-2017' (not '=')

    eselect python list select python, this should solve the problem. add to the beginning of the sentence # # Copyright 1999-2017 Gentoo Foundation
  3. Hi I've recently freshly installed Funtoo ZFS Ik get the following during shutdown: * Unmounting loop devices * Unmounting filesystems * Unmounting /boot ... [ ok ] * Unmounting /usr/src ... [ ok ] * Unmounting /usr/portage/packages ... [ ok ] * Unmounting /usr/portage/distfiles ... [ ok ] * Unmounting /usr/portage ... [ ok ] * Unmounting /home ... [ ok ] * Unmounting ZFS filesystems ... umount: /: nie zamontowany cannot unmount '/': umount failed [ !! ] * Deactivating swap devices ... [ ok ] * Shutting down the Logical Volume Manager * Finished shutting down the Logical Volume Manager * Stopping lvmetad ... [ ok ] * Stopping udev ... [ ok ] * Setting hardware clock using the system clock [Local Time] ... [ ok ] * Terminating remaing process ... * Saving depedency cache ... * Remounting / read only ... * failedbecause we are using / * ERROR: mount-ro failed to start /var/rc.log rc shutdown logging started at Mon Sep 28 19:11:00 2015 * Stopping local [ ok ] * Unsharing ZFS filesystems ... [ ok ] * Stopping ZFS Event Daemon ... [ ok ] * Stopping kdm ... [ ok ] * Stopping vixie-cron ... [ ok ] * Saving random seed ... [ ok ] * Deactivating additional swap space ... [ ok ] * Stopping sshd ... [ ok ] * Unmounting network filesystems ... [ ok ] * Shutting down network interface lo ... [ ok ] * Network interface eth0 down ... [ ok ] * Stopping ConsoleKit daemon ... [ ok ] * Stopping syslog-ng ... [ ok ] * Stopping D-BUS system messagebus ... [ ok ] * Unmounting loop devices * Unmounting filesystems * Unmounting /boot ... [ ok ] * Unmounting /usr/src ... [ ok ] * Unmounting /usr/portage/packages ... [ ok ] * Unmounting /usr/portage/distfiles ... [ ok ] * Unmounting /usr/portage ... [ ok ] * Unmounting /home ... [ ok ] * Unmounting ZFS filesystems ... umount: /: nie zamontowany cannot unmount '/': umount failed [ !! ] * Deactivating swap devices ... [ ok ] * Shutting down the Logical Volume Manager * Finished shutting down the Logical Volume Manager * Stopping lvmetad ... [ ok ] * Stopping udev ... [ ok ] * Setting hardware clock using the system clock [Local Time] ... [ ok ] rc shutdown logging stopped at Mon Sep 28 19:11:06 2015 rc sysinit logging started at Mon Sep 28 19:12:50 2015 OpenRC 0.12.4 is starting up Funtoo Linux (x86_64) * /proc is already mounted * Mounting /run ... * /run/openrc: creating directory * /run/lock: creating directory * /run/lock: correcting owner * Using /dev mounted from kernel ... [ ok ] * Mounting /dev/mqueue ... [ ok ] * Mounting /dev/shm ... [ ok ] * Creating list of required static device nodes for the current kernel ... [ ok ] * Bringing up network interface lo ... [ ok ] * Mounting debug filesystem ... [ ok ] * Mounting cgroup filesystem ... [ ok ] * Mounting fuse control filesystem ... [ ok ] * setting up tmpfiles.d entries for /dev ... [ ok ] * Starting udev ... [ ok ] * Generating a rule to create a /dev/root symlink ... [ ok ] * Populating /dev with existing devices through uevents ... [ ok ] * Waiting for uevents to be processed ... [ ok ] rc sysinit logging stopped at Mon Sep 28 19:12:50 2015 rc boot logging started at Mon Sep 28 19:12:50 2015 * Setting system clock using the hardware clock [Local Time] ... [ ok ] * Autoloaded 0 module(s) * /run/lvm: creating directory * Starting lvmetad ... [ ok ] * Setting up the Logical Volume Manager ... No volume groups found No volume groups found No volume groups found [ ok ] * Checking local filesystems ... /dev/sda1: czysty, 295/64000 plik?w, 30772/256000 blok?w [ ok ] * Activating swap devices ... [ ok ] * Mounting ZFS filesystem(s) ... [ ok ] * Mounting local filesystems ... [ ok ] * Configuring kernel parameters ... [ ok ] * Creating user login records ... [ ok ] * Wiping /tmp directory ... [ ok ] * Remounting filesystems ... [ ok ] * Setting terminal encoding [UTF-8] ... [ ok ] * Setting console font [lat2-16] ... [ ok ] * Configuring /etc/hosts ... [ ok ] * Setting hostname to funtoo ... [ ok ] * Setting keyboard mode [UTF-8] ... [ ok ] * Loading key mappings [pl] ... [ ok ] * Mounting misc binary format filesystem ... [ ok ] * Loading custom binary format handlers ... [ ok ] * Activating additional swap space ... [ ok ] * setting up tmpfiles.d entries ... [ ok ] * Initializing random number generator ... [ ok ] rc boot logging stopped at Mon Sep 28 19:13:01 2015 rc default logging started at Mon Sep 28 19:13:01 2015 * Starting D-BUS system messagebus ... [ ok ] * Network interface eth0 up ... [ ok ] * Mounting network filesystems ... [ ok ] * Checking your configfile (/etc/syslog-ng/syslog-ng.conf) ... [ ok ] * Starting syslog-ng ... [ ok ] * Starting sshd ... [ ok ] * Starting vixie-cron ... [ ok ] * Starting ConsoleKit daemon ... [ ok ] * Setting up kdm ... [ ok ] * Starting ZFS Event Daemon ... [ ok ] * Sharing ZFS filesystems ... [ ok ] * Starting local [ ok ] rc-update -v show alsasound | bootmisc | boot busybox-ntpd | busybox-watchdog | calibre-server | consolefont | boot consolekit | cups-browsed | cupsd | dbus | default devfs | sysinit device-mapper | dhcpcd | dmcrypt | dmesg | sysinit dmeventd | fsck | boot fuse | git-daemon | gpm | hostname | boot hwclock | boot ip6tables | iptables | keymaps | boot killprocs | shutdown kmod-static-nodes | sysinit local | default localmount | boot lvm | boot lvm-monitoring | lvmetad | mdadm | mdraid | modules | boot mount-ro | shutdown mtab | mysql | netif.eth0 | default netif.lo | sysinit netif.tmpl | netmount | default numlock | pciparm | postfix | procfs | boot pwcheck | pydoc-2.7 | pydoc-3.3 | root | boot rsyncd | saslauthd | savecache | shutdown slapd | sshd | default swap | boot swapfiles | boot swclock | sysctl | boot sysfs | sysinit syslog-ng | default termencoding | boot tmpfiles.dev | sysinit tmpfiles.setup | boot udev | sysinit udev-mount | sysinit udev-postmount | boot urandom | boot vixie-cron | default xdm | default xdm-setup | zed | zfs-import | boot zfs-mount | boot zfs-share | default zfs-zed | default "how to fix it?"
  4. I added: # make modules_prepare # emerge --ask @module-rebuild [ebuild R ] sys-kernel/spl-0.6.3 [ebuild R ] sys-fs/zfs-kmod-0.6.3 this kernel (3.17.2-gentoo) does not support modules: spl-0.6.3, zfs-kmod-0.6.3 * ERROR: sys-fs/zfs-kmod-0.6.3 failed (setup phase): * Linux 3.16 is the latest supported version. * * Call stack: * ebuild.sh, line 93: Called pkg_setup * zfs-kmod-0.6.3.ebuild, line 71: Called die * The specific snippet of code: * [ ${PV} != "9999" ] && \ * { kernel_is le 3 16 || die "Linux 3.16 is the latest supported version."; } I have to wait for upgrade modules: spl, zfs-kmod
  5. What am I doing wrong when updating kernel gentoo-sources with genkernel --zfs initramfs # make -j5 bzImage modules && make install && make modules_install # cd /boot # ls System.map-3.15.1-gentoo-kris initramfs-genkernel-x86_64-3.15.1-gentoo-kris System.map-3.15.1-gentoo-kris.old initramfs-genkernel-x86_64-3.17.2-gentoo-kris System.map-3.17.2-gentoo-kris lost+found boot splash.jpg config-3.15.1-gentoo-kris vmlinuz-3.15.1-gentoo-kris config-3.15.1-gentoo-kris.old vmlinuz-3.15.1-gentoo-kris.old config-3.17.2-gentoo-kris vmlinuz-3.17.2-gentoo-kris grub funtoo kris # cd /boot funtoo boot # ls System.map-3.15.1-gentoo-kris initramfs-genkernel-x86_64-3.15.1-gentoo-kris System.map-3.15.1-gentoo-kris.old initramfs-genkernel-x86_64-3.17.2-gentoo-kris System.map-3.17.2-gentoo-kris lost+found boot splash.jpg config-3.15.1-gentoo-kris vmlinuz-3.15.1-gentoo-kris config-3.15.1-gentoo-kris.old vmlinuz-3.15.1-gentoo-kris.old config-3.17.2-gentoo-kris vmlinuz-3.17.2-gentoo-kris grub # genkernel --zfs initramfs # boot-update boot-update 1.7.1 / Copyright 2009-2012 Funtoo Technologies [use option "-l" for license info, "-h" for help] * Generating config for grub... DEFAULT > Funtoo ZFS - vmlinuz-3.15.1-gentoo-kris Funtoo ZFS - vmlinuz-3.17.2-gentoo-kris * WARN : No boot/default match found - using first boot entry by default. * Completed successfully with warnings. Reboot .... >> Importing ZFS pool tank Failed to load ZFS module stack, Load the module manually by running 'insmod <location>/zfs.ko' ass root, !! Importing tank failed >> Determinning root device... Failed to load ZFS module stack, Load the module manually by running 'insmod <location>/zfs.ko' ass root, !! tank/funtoo/root is not a filesystem !! Could not find the root block device in ZFS=tank/funtoo/root, Please specify another value or: press Enter for the same, type "shell" for a shell, root block device(ZFS=tank/funtoo/root) :: _ Regards
×